Andreas Stangenes

Todays windows10 update (fall creator)

Recommended Posts

Hi Guys,

Just an update, following the initial problems I had & rollback to fix those issues Win10 did a new update a couple of weeks ago which I allowed with some trepidation. This time however all seems to have worked fine thank goodness. 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Just allowed mine to update. AISuite wouldn't work, lots of error messages. Couldn't uninstall it either. Had to roll back, then uninstall, and redo the update. Now I've installed the latest AISuite it's all working. 1709 build. X99 and 5830K.

Share this post


Link to post
Share on other sites
41 minutes ago, MarkJHarris said:

Now I've installed the latest AISuite it's all working.

Which version of AI Suite did you install? On the Asus forums they are advising to try the latest beta (v3.00.10).

Share this post


Link to post
Share on other sites

With both fear and trembling I too finally broke down and enabled "automatic" updates for Windows 10--I now have 1709 with OS Build 16299.125. Did a test flight earlier this morning with P3D v. 3.4xx and so far all is fine. I am hoping it stays that way. 

Share this post


Link to post
Share on other sites

I had a WIN10 update a few days ago (4056891) which broke my ASUS Fan control which an update to the latest software didn't fix so I uninstalled the update.

However it came back yesterday so I allowed it again but the same thing. So I once again uninstalled the update & this time have hidden it. Hopefully it won't annoy me again & in the meantime ASUS updates their software again. 

Share this post


Link to post
Share on other sites

So far I have not had any problems with Windows updates as you mention with your fan control. Mine has been flight sim programs past and present. In case you may not know you can control how Window Updates are installed. This is what I discovered while reading a post on another forum and what I did to stop the Win 10 updates:

--Control Panel

--Click on Administrative Tools

--Click on "Services"--scroll down the long list of services until you find "Window Updates"

--Double click (left click) on Window Updates. You will see "Windows Update Properties (Local Computer)

--Click on "Start Up" then you will see different options that will allow you to control Window Updates (Manual, Automatic [delayed start], Automatic and Disabled). At first I clicked on "Disabled", then rolled back to the previous version (1703) when 1709 was causing problems with 32 bit flight sims. The "Disabled" mode prevented any further automatic attempt to update my desktop to 1709. 

--Once I read on this and other forums that MS got their act together and Fall Creator (1709) was no longer creating errors or CTD's for flight sims, I finally reset the above to "Automatic" especially in light of the most recent reports of viruses and bad guys trying to hack into computers (desktops, laptops and smart phones).

Share this post


Link to post
Share on other sites

Forgot to mention--once you choose an option, then you must click the "Apply" tab and then the Okay" tab for the change to take affect.

Share this post


Link to post
Share on other sites

NVidia are releasing a updated Drivers with a security patch included, if your are sticking with an older driver you will not get the patch. 

Share this post


Link to post
Share on other sites
20 hours ago, raymie said:

So far I have not had any problems with Windows updates as you mention with your fan control. Mine has been flight sim programs past and present. In case you may not know you can control how Window Updates are installed. This is what I discovered while reading a post on another forum and what I did to stop the Win 10 updates:

--Control Panel

--Click on Administrative Tools

--Click on "Services"--scroll down the long list of services until you find "Window Updates"

--Double click (left click) on Window Updates. You will see "Windows Update Properties (Local Computer)

--Click on "Start Up" then you will see different options that will allow you to control Window Updates (Manual, Automatic [delayed start], Automatic and Disabled). At first I clicked on "Disabled", then rolled back to the previous version (1703) when 1709 was causing problems with 32 bit flight sims. The "Disabled" mode prevented any further automatic attempt to update my desktop to 1709. 

--Once I read on this and other forums that MS got their act together and Fall Creator (1709) was no longer creating errors or CTD's for flight sims, I finally reset the above to "Automatic" especially in light of the most recent reports of viruses and bad guys trying to hack into computers (desktops, laptops and smart phones).

Thanks for that Raymie, I do have it set to manual but even then once it's downloaded & ready to go the only options showing for a shut down or restart include updating. I didn't think I could turn them off with this version of Windows.

 

6 hours ago, vortex681 said:

There's a beta version of the AI Suite which fixes the problem. See: https://rog.asus.com/forum/showthread.php?98800-AI-Suite-3-Beta-Version-3-00-10-user-test-report-thread

Thanks Vortex, had a look but am unable to download as yet, the site appears to be getting a hammering. Did see a couple of recent posts where users are having problems including one where the beta has not fixed the Win10 update issue for them.

Will download when I can (says try in another 20 hours!!)

Have bookmarked the page.

Share this post


Link to post
Share on other sites
4 hours ago, Rossco said:

Thanks Vortex, had a look but am unable to download as yet, the site appears to be getting a hammering.

Did you try the alternative download link in the first post from the link? Just tried and it worked for me.

Share this post


Link to post
Share on other sites
19 hours ago, vortex681 said:

Did you try the alternative download link in the first post from the link? Just tried and it worked for me.

Thanks, missed that & was able to download & install without getting any blue screens (so far). All previous versions refused to work on my rig even with the recommended updated ME drivers that were supposedly causing the conflict.

Am yet to update Win10 to see how it goes.

Share this post


Link to post
Share on other sites

Yes, I have the latest one. It lists;

EZ Update 2.03.17

Dual Intelligent Processors 5 1.05.11

System Information 1.01.19

USB BIOS Flashback 1.03.08

 

it's the DIP program that I think is the problem...

 

All working fine on mine now.

 

Share this post


Link to post
Share on other sites

Now I get a repeated Unknown USB Device (Device Descriptor Request Failed) coming up. I uninstall it and it returns even after just a hibernation cycle. MS got me to reinstall the latest build of Win10 and it still does it. Occasional freezing of the machine too.

 

Not HP.

Share this post


Link to post
Share on other sites
On 13/02/2018 at 9:42 PM, MarkJHarris said:

I uninstall it and it returns even after just a hibernation cycle.

Windows has never been good with hibernation and USB ports. Do you need to use hibernation? Windows 10 boots much quicker than old versions and, after the latest big update, leaving apps open on shutdown re-opens them on startup anyway.

It's also worth checking the USB power management settings as they can cause problems in Windows 10: https://www.drivereasy.com/knowledge/fix-issue-after-upgrade-system-to-windows-10-usb-ports-dont-work/

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now