mihalich

Initial flight plan route line is slightly off course with x-plane 11

Recommended Posts

Hi,

   Not sure what is causing this, whether it's xplane 11.11 or p2a 2.4.x.

   I've flown 2 flights now, one from KJFK to KROC, and one from KORD to KDEN.  In both cases, i built the flight plan, and it was exported to the xplane fms output directory and i loaded it into the FMS.  The initial route line from leaving the airport to the first waypoint has been off a decent amount, compared to what the airplane instruments show.  Screenshot is attached for the KORD-KDEN route.  You can see that on the plane's gps display, i'm right on top of the route line, but in p2a I'm a decent amount off the line.  ATC keeps telling me i'm off course, and giving me vectors back to the line it thinks is correct.  But, when i'm on auto pilot, i can't get back to the p2a line cuz the plane gps thinks the line is different.

   Not sure what's going on here, but i have never seen this prior to 2.4.

https://photos.app.goo.gl/MBew6p5L0uH1TprI3

 

Joe

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

This can be caused by differences in AIRAC data or interpretation of the SID/STAR/Approach route by the FMS vs P2A.

The thing to do is to increase the allowed Off Course distance in the Config ATC Settings.  That should stop the off course calls.

 

Share this post


Link to post
Share on other sites

What is the best way to solve this (other than altering the off course distance)?  If i were to get a navigraph subscription, would the best approach be to update the navigraph db in xplane 11 to match the airac cycle you have in pilot 2 atc?  Or could I update both xplane and p2a to have the latest version of the airac cycle (if this would even fix it). I checked x-plane 11.11, and it's using the october 2016 - november 2016 airac cycle, and p2a is using 201705 (I believe).

btw, after the first way point, the navigation lines match between p2a and the fms.  It just seems to be that first segment.

Thanks,

Joe

 

Share this post


Link to post
Share on other sites

Getting a Navigraph subscription and getting X-Plane and P2A to the same AIRAC level will fix most of these kinds of problems.

There will still be occasions where the FMS calculates part of the course differently from P2A.  For example, when there's a vector as part of a procedure, they might make different assumptions about when it starts and where it finishes...but those are not that common.

Share this post


Link to post
Share on other sites

I also thought a Navigraph subscription might fix this. Unfortunately, it didn't.

Using AIRAC 1811, plotting a direct course from KELP->KSAT, I'm getting the same thing.

---

I really wish P2ATC had a visual progressive taxi indicator like the built-in ATC. It's difficult to taxi and watch the taxi route on the P2ATC map when in VR.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now