Evil Knedl

Recent problems with the GTN and Carenado B200

Recommended Posts


The GTN worked perfect in the Carenado B200 not long ago, but something must have happend and i can't figure out what.

As soon as i install the GTN in to the plane, the VC buttons become unclickable, the throttle doesn't respond at all and so on. The plane is not flyable.

I had a chat with the Carenado team at first, they suggested me to test the addons i have, installing/reinstalling them and as soon i removed the GTN, the plane was suddenly just fine again.

I must say at this point, that i use the GTN in other planes without any problem at all.

I wonder if any of you pilots have a simmilar experience with the B200, maybe a known error that someone knows how to fix?

Iam running xplane 11.11 and the GTN is fresh updated and reinstalled, also the B200 is fresh installed.


Share this post

Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

There is an issue with the Carenado B200 regarding click spots. Believe it is a carenado sasl issue. There are a couple post in regards to this issue.


  • Upvote 1

Share this post

Link to post
Share on other sites

Did the solution to this ever get worked out? Just bought the gtn 750 and I cant even use it.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now