Jump to content

Sign in to follow this  
jackralston

FS9 frozen on splash screen

Recommended Posts

[Posted this in other forums as I really want to try get some clues towards an answer without having to do a full re-installation]

Absolutely gutted and I hope I can find a way to resolve this.

I hadn't loaded up FS9 for a month or so due to moving house. Once I moved in I booted the PC up and there were tons of Windows 10 updates which took a while. In the past few days I have been updating my AI collection by adding as many winter 17/18 traffic files from AIG and forum members. I also installed FAIB 767, SBAI CS100/300 and FAIB NEO range. 

So I decided to startup FS9 and it did the 'generating scenery file indexes' which I expected due to the large new amount of traffic bgls...then it just froze on 100%, didn't start or anything, left it for 5 mins but still stuck there at 100, clicked on it and it was showing as not responding, so I closed it. 

I tried removing the new traffic bgl files in case one was corrupt and it did the exact same thing.

I put them back and tried removing the FS9.cfg so it would rebuild but it didn't rebuild properly, the new FS9.cfg was showing but with 0kb and had froze. The generating scenery indexes never appeared as I assume all the bgl files had been put back and showing.

I put back the other FS9.cfg that had been working in (since I last used FS9) and then tried removing all scenery.dat files so it could rebuild in case it was corrupt too. It rebuilt them as I watching on task manager the writing to disk for FS9 was high/busy so I thought it was working...then it stopped (I assumed it had rebuilt them all) but it still remained froze. It didn't show the rebuild scenery index again.

Also tried removing scenerystatus.dat and it rebuilt one with a smaller file size but again when I loaded FS9 it was stuck on the splash screen with nothing happening.

I am truly baffled, no new sceneries have been installed, just the Windows 10 updates, AI traffic files, a couple of new call signs manually in editvoicepack and the new AI models mentioned above.

The latest I am up to after manually cleaning the scenery.cfg and making sure the amount of areas matches the amount of layers entries, is that FS9 still loads the splash screen then just won't load and shows as 'not responding' in task manager. There are no .dlls that shows as been modified since last playing FS9 either. What could it possibly be?!

Share this post


Link to post
Share on other sites

FIXED IT (kind of)  :yeah: So it seems that deleting all the entries in scenery.cfg and leaving the default ones there worked and it has loaded up fine. I'll need to manually add the scenery entries as I go along and see if I can find which one caused an issue.

One problem I now have is AA on full screen refuses to work. I have downloaded the latest graphics driver for GTX750ti, the latest nvidia inspector and keep setting AA to override any application setting. In windowed mode the AA and settings are clear and work but if you press ALT+ENTER to full screen mode, the AA disappears and everything is more blurry than Donald Trump's memory! Any ideas?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...