Sign in to follow this  
jackralston

FS9 no AA in fullscreen

Recommended Posts

This is a rather strange one for me, never had such an issue before! 

So since sorting out my previous issue with it freezing on the splash screen, I have now got stuck on trying to make AA work in fullscreen mode. In fullscreen, there is no AA and everything is very blurry/jaggy. BUT, switch to windowed mode and it works perfectly as per my nvidia inspector settings 8xSQ 16x etc. 

I use nvidia inspector 1.9.7.3, Driver version GeForce 353.62 WHQL. I have tried more recent driver versions and it still had the same issue. I have removed FS9.exe from the stock 'MS Flight Simulator 2004' profile setting and made a new one called 'FS9' and applied it to FS9.exe.

Any ideas what could be blocking it from working in fullscreen?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I just went from Win7 to Win10 (Fall Creators Update) and installed FS9 from scratch again. I also had no AA in full screen mode, but enabling AA inside FS9 and setting

Inspector to enhance the application settings works. I set 4x Multisampling and 4x Sparse Grid Supersampling and it looks fine to me.

I also set the anisotropic filtering the same old way, User Defined 16x.

Share this post


Link to post
Share on other sites

Someone tell me what AA is? Something to do with drinking booze?

Share this post


Link to post
Share on other sites
57 minutes ago, rogwen said:

Someone tell me what AA is? Something to do with drinking booze?

Yes, it's Anti-Aliasing (which gets rid of the jaggies), the lack of which can drive anyone to the bottle eventually...

Share this post


Link to post
Share on other sites

Ah. I know what anti-aliasing does I but had never come across the abbreviation. I don't have it turned on. I have everything at the maximum setting except water effects and found mip mapping to be far more effective.

Share this post


Link to post
Share on other sites

hey roger hey all yes antialiasing just makes things clearer i think?

Share this post


Link to post
Share on other sites

Going to have to bump this I'm afraid, really baffled by this.

In fullscreen: AA doesn't work, very jaggy but FPS seems decent

In windowed: AA works as set by the nvidia inspector settings. 

Within FS9 settings AA is set to off and in inspector it is set to 'override any application settings'. The only way for AA to work in fullscreen is to turn on AA in FS9 and set inspector settings to 'enhance any application settings'. Any ideas why it still won't work?  

Currently using drivers 353.62, GTX750 Ti card. I tried a few different drivers but to no avail yet. Any ideas?

For the images as reference, I have posted them in the AIG forum
http://www.alpha-india.net/forums/index.php?topic=26801.0

 

Share this post


Link to post
Share on other sites
Posted (edited)

If you're using Windows 10, this is a known issue which can't be tweaked away. Even if you are using Windows 10, it won't hurt to check that your Windows screen resolution is set to the recommended size, and that your FS9 display resolution matches it. I have my Inspector behaviour flag set to "Disable Antialiasing at NVIDIA control panel" which negates the whole "override or enhance" issue. Your video drivers won't affect this issue.The AIG forum link asks for login details by the way, so I couldn't see your screenshots.

Edited by A32xx

Share this post


Link to post
Share on other sites

Thanks for the reply. I am using Windows 10 and it use to work perfectly fine before a fairly recent major update. Both the PC and FS9 have a resolution of 1920x1080. I tried your recommendation of setting it to "Disable Antialiasing at NVIDIA control panel" but unfortunately that didn't do the trick.

So I have set it back to AA off in FS9, "Override any application setting" and no behaviour flags. Once again it doesn't work in fullscreen but it still works ok in Windowed mode. Also reinstalled nvidia inspector and gone back to version 1.9.7.3 (appears on the website as 1.9.7.6) and that hasn't made a difference either. I have deleted the profile in the nvidia control panel and remade the FS9 one there too. 

It simply seems to be confused between the fullscreen mode and windowed mode. 

Share this post


Link to post
Share on other sites

It is a windows 10 issue already  mentioned in the Forum:

Creators 1709 update and Nvidia inspector

I updated and retrograded my windows10 1703 twice before I decided to stay with
the creators 1709 version.The main reason of rolling back was the Nvidia driver issue with 
this last Creators update. Even if I have excluded driver updates when updating Windows 10,
the NV driver uninstall information was not in the control panel nor I could control any 
Antialiasing or Filter setting with the NvidiaprofilInspector for FSX & FS9 in fullscreen mode.

After completely uninstalling all Nv drivers with ddu and the device manager and reinstalling the latest
Nv driver (388.43) it was still not working.

By google searching I came across to this incredible solution for the Nvprofile setting:
see link :

https://a2asimulations.com/forum/viewtopic.php?f=23&t=62072 .

Re.this topic the profile settings in your FSX Inspector profile you will see a setting called "Antialiasing compatibility."

Set that to "0x004412C1 (Diablo III)" . It seems that this is true for many games!!

And now on my PC, NI profiles work as expected in fullscreen and windows mode fore FSX-SE and FS9
in DX9 mode. It should also work in DX10 mode.

It's just unbeleavable; but true, a kind of swiss knife!

Jean

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

I've just tested this tweak and...  IT WORKS!!! Thank you for the heads-up Jean, you're a star!

Mods: Could Jean's post be pinned please? It applies to FSX as well!

Edited by A32xx

Share this post


Link to post
Share on other sites

I've tested it too and IT WORKS! Fantastic find Jean, thank you oh so much!!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this