Jump to content

Sign in to follow this  
Dragn

Runtime error "9"

Recommended Posts

 

Just to edit this post, I'm not getting the runtime error 9 now.  But, when I load a pln in RC (I'm already at the departure airport) and click to Start RC, it then transports me to the middle of the ocean off the West coast of Africa.

Hi all,

  Just getting RC up and running with P3Dv4.1.   Ran makerwys.exe ok, have all the files located in main P3D folder.  After selecting the flight plan and clicking on the Start RC button I get an error message as follows:

 

Run-time error '9'

RC.rc4 module.initialize

RC fails to run after that.

Any help much appreciated.   Used to beta test RC up through V4 but it's been a long time since I've been able to use it.


Robert Abernathy

Share this post


Link to post
Share on other sites

Hi Rob. Long time no hear. Hope you’re well. :smile:

This happens when RC cannot identify the departure airport in your plan. This topic covers the same issue. 

It sounds like the RC database is either missing the airport or there’s something odd in the pln. I don’t have P3D v4 but with v3 you need to use Lorby’s Addon Organiser program to generate a temporary scenery.cfg that includes any airports that have an Addon folder rather than an entry in scenery.cfg.

Search for Lorby Addon Organiser as you will probably need it. Come back if you need more help.


Ray (Cheshire, England).
System: P3D v4.5, Intel i7-8086K o/c to 4.6Ghz, Nvidia GTX 1080 Ti 11Gb, Samsung 970 EVO M.2 SSD, 1Tb Samsung 860 EVO SSD, Asus Prime Z370-A mobo, 32Gb G.Skill DDR4 3000Mhz RAM, Win 10 Pro 64-bit, BenQ PD3200U 32” UHD monitor.
Cheadle Hulme Weather

Share this post


Link to post
Share on other sites

Thanks Ray.  Glad to see you still involved with RC.  Had a great time testing with all of you.  I do like testing so now I'm a beta tester for Orbx.  Love it.

Now as to this issue.  I've read the post you linked.   Went to another airport and created a flight plan.  Got all set and opened RC, loaded the flight plan, started RC.  Again I'm placed at 0 longitude 0 Latitude.   It must be my database is corrupt.  I've deleted the files created by make runways.exe and have ran that again.  I do have Lorby's Addon Organiser but not sure I'm using it right.  Does MakeRunways automatically find it and use it?

 

EDIT

  After reading over the pdf for Lorby's program, it states that makerunways will automatically detect it and create a scenery.cfg in the main P3D folder, which it did.  I then run the Scenery Database function in RC, right?

 

Next thing I tried is to delete the old created scenery.cfg (because I said I had a networked option) and tried again to rebuild the Scenery DB in RC using the regular non networked choice.  It gives an error message that "makerwys.exe is not in your flight sim path and should be".   This must be my problem!  How do I get makerwys.exe to recognize my flight sim path to P3Dv4?

Also I have RC version 4.0.3675   This must be outdated too?  Where would I get an update/link?

Thanks Ray!


Robert Abernathy

Share this post


Link to post
Share on other sites

Hi Rob,

Firstly, check you have the latest Make Runwys. 4.84 from here.

http://forum.simflight.com/topic/66136-useful-additional-programs/

Running MakeRunwys generates a few files required by RC. They are:-

r5.csv this is copied and renamed as r4.csv into the data subfolder.

A new a4.csv will be built by RC.

Finally a c4.csv will be built.

The a4.csv is the airports file. I presume if your airport isn’t in that file you will be placed at 0/0 in P3D.

c4.csv appears to be all the centres. I have 4024 entries in mine.

r4.csv is the runways file.

f4.csv holds all the frequencies for the airports.

f5.csv is another frequencies file.

It might be necessary to create a dummy FSX.EXE file in the P3D folder. Just create a text file and rename it.

That should be enough to keep RC happy. My build is 4.3.3845. If you need that contact Doug Thompson at dthompss@comcast.net

I’m sure he will remember you. :smile: Hope that helps.


Ray (Cheshire, England).
System: P3D v4.5, Intel i7-8086K o/c to 4.6Ghz, Nvidia GTX 1080 Ti 11Gb, Samsung 970 EVO M.2 SSD, 1Tb Samsung 860 EVO SSD, Asus Prime Z370-A mobo, 32Gb G.Skill DDR4 3000Mhz RAM, Win 10 Pro 64-bit, BenQ PD3200U 32” UHD monitor.
Cheadle Hulme Weather

Share this post


Link to post
Share on other sites

Thanks Ray.  I've emailed Doug for a link to 4.3.3845 and will work on the items in your post.

Thanks again  :smile:


Robert Abernathy

Share this post


Link to post
Share on other sites

Hope you soon have it working Rob. :smile:


Ray (Cheshire, England).
System: P3D v4.5, Intel i7-8086K o/c to 4.6Ghz, Nvidia GTX 1080 Ti 11Gb, Samsung 970 EVO M.2 SSD, 1Tb Samsung 860 EVO SSD, Asus Prime Z370-A mobo, 32Gb G.Skill DDR4 3000Mhz RAM, Win 10 Pro 64-bit, BenQ PD3200U 32” UHD monitor.
Cheadle Hulme Weather

Share this post


Link to post
Share on other sites

Thanks Ray.   I'll try again after the update to 4.3   Right now the msg I get is that makerwys.exe can't find the path to P3Dv4


Robert Abernathy

Share this post


Link to post
Share on other sites

Rob,

Do you have makerwys.exe in the P3D folder? If so how can it not know the path to the Prepar3D.exe?

If this problem continues ask on Pete’s forum.


Ray (Cheshire, England).
System: P3D v4.5, Intel i7-8086K o/c to 4.6Ghz, Nvidia GTX 1080 Ti 11Gb, Samsung 970 EVO M.2 SSD, 1Tb Samsung 860 EVO SSD, Asus Prime Z370-A mobo, 32Gb G.Skill DDR4 3000Mhz RAM, Win 10 Pro 64-bit, BenQ PD3200U 32” UHD monitor.
Cheadle Hulme Weather

Share this post


Link to post
Share on other sites

Yes, it is in the main P3Dv4 folder.  Does seem odd for sure.  I'll ask Pete.  Right now I just received an email from Doug and am in the process of uninstalled RC, and then a reinstall with the 4.3 files.


Robert Abernathy

Share this post


Link to post
Share on other sites

Hi Ray,

 Happy to report all is well with RC in P3Dv4.1    Received a link to the latest version.  Uninstalled the prior version, installed new one.  Set up makerwys.exe and built the RC scenery DB.   Just ran a flight plan from KRDD to KSMF with no issues.  Everything working just like in the past.  Still a great program and I'm glad to have it back in action!

Thanks again


Robert Abernathy

Share this post


Link to post
Share on other sites

Great news Rob. Glad you’re sorted. :smile:


Ray (Cheshire, England).
System: P3D v4.5, Intel i7-8086K o/c to 4.6Ghz, Nvidia GTX 1080 Ti 11Gb, Samsung 970 EVO M.2 SSD, 1Tb Samsung 860 EVO SSD, Asus Prime Z370-A mobo, 32Gb G.Skill DDR4 3000Mhz RAM, Win 10 Pro 64-bit, BenQ PD3200U 32” UHD monitor.
Cheadle Hulme Weather

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...