CP Air

Autopilot in NAV mode won't track a GPS course

Recommended Posts

1 minute ago, nightxpress said:

Fails exactly the same way with the original database. I will try to reinstall. Maybe the problem is somewhere on my side. I works for others....

This is not a database issue... most likely a bug in the latest GNS version..

I am still using an older one..

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

24 minutes ago, Bert Pieke said:

This is not a database issue... most likely a bug in the latest GNS version..

I am still using an older one..

You mean Reality XP Version or Trainer Version?

Share this post


Link to post
Share on other sites
25 minutes ago, nightxpress said:

You mean Reality XP Version or Trainer Version?

RXP version...

I just foolishly installed the latest RXP GNS2, just for FSX, as a test, and I now have the same autopilot problem, in both FSX and P3Dv4   :huh:

  • Upvote 1

Share this post


Link to post
Share on other sites

Hi Bert,

That is "fantastic". Now we can agree that 2.3.9.0 has a Bug. I hope this Info helps the Development. Its not a big Deal, Bugs are the everyday Business of Programming ;-)

Do you know where the affected Users can Download the last/a Version with a working Autopilot (in GPS mode)? Would it be enough just to overinstall?

 

Best,

Paul

 

Share this post


Link to post
Share on other sites
41 minutes ago, Bert Pieke said:

I now have the same autopilot problem, in both FSX and P3Dv4 

Thanks Bert, as always.

Share this post


Link to post
Share on other sites
1 hour ago, nightxpress said:

Fails exactly the same way with the original database. I will try to reinstall. Maybe the problem is somewhere on my side. I works for others....

Believe you meant to say It works for others?  That is actually the basis for my earlier post.  Is there anyone who is not experiencing the issue. Not sure I have seen anyone affirm that.

Share this post


Link to post
Share on other sites
2 minutes ago, fppilot said:

Believe you meant to say It works for others?  That is actually the basis for my earlier post.  Is there anyone who is not experiencing the issue. Not sure I have seen anyone affirm that.

Hi Frank,

I was not precise enough with the term "It worked for others". In fact Bert just updated and has the same problem. For now it seems it is  a problem with the newest Version (Version 2.3.9.0) until somebody could confirm otherwise.

 

@all : Please post if Version 2.3.9.0 works. Q: AP in GPS Mode (flying RNP/GPS procedures on Autopilot) works or for you or not?

Share this post


Link to post
Share on other sites

Yesterday, I flew the A2A PA24 w/ RXP V2 G430 2.3.9 and no AP-GPS problem in NAV. However, a few minutes ago while performing a test with Carenado PA31-310 w/ RXP V2 G530, AP did follow GPS in NAV. 

I can do another test in the Comanche. 

 

Share this post


Link to post
Share on other sites
5 minutes ago, Les Parson said:

Yesterday, I flew the A2A PA24 w/ RXP V2 G430 2.3.9 and no AP-GPS problem in NAV. However, a few minutes ago while performing a test with Carenado PA31-310 w/ RXP V2 G530, AP did follow GPS in NAV. 

I can do another test in the Comanche. 

 

Thank you. Then its not everyone. Hmmm. (Will continue testing too)

Share this post


Link to post
Share on other sites
24 minutes ago, fppilot said:

Thanks Bert, as always.

Stay on your older release!

Share this post


Link to post
Share on other sites
42 minutes ago, nightxpress said:

Thank you. Then its not everyone. Hmmm. (Will continue testing too)

Tried it in my Baytower RV7, RealAir Duke, and Carenado T210..

They all used to work - no more after this update..

Share this post


Link to post
Share on other sites
40 minutes ago, Bert Pieke said:

Tried it in my Baytower RV7, RealAir Duke, and Carenado T210..

They all used to work - no more after this update..

I had same issue of AP not tracking GPS course with 2.3.9 in P3D 4.1. Rolled back to 2.3.8 and is working. Haven't tested in P3D 4.2.

Share this post


Link to post
Share on other sites
5 minutes ago, bills511 said:

I had same issue of AP not tracking GPS course with 2.3.9 in P3D 4.1. Rolled back to 2.3.8 and is working. Haven't tested in P3D 4.2.

For others, how did you roll back?

Share this post


Link to post
Share on other sites
Just now, fppilot said:

For others, how did you roll back?

I have a habit of saving previous versions setups just in case.

Share this post


Link to post
Share on other sites
1 minute ago, bills511 said:

I have a habit of saving previous versions setups just in case.

I do as well but have not so far had to attempt to revert. I note they have the same consistent filename and the filedate is different.  So when it goes through the F1 wrapper, with the same filename,  how does it distinguish?

Share this post


Link to post
Share on other sites
Just now, fppilot said:

I do as well but have not so far had to attempt to revert. I note they have the same consistent filename and the filedate is different.  So when it goes through the F1 wrapper, with the same filename,  how does it distinguish?

I uninstalled 2.3.9 through windows control panel uninstall programs. Make sure to delete the GNS files in C:\ProgramData\Reality XP.

Share this post


Link to post
Share on other sites
3 minutes ago, Bert Pieke said:

Hold onto your V2.3.8. installer (for now)..  :happy:

No problem. I have the last 4 previous versions. Guess I'm too lazy to delete.

Share this post


Link to post
Share on other sites

Check your recycle bins for the filename(s).  If you have  not emptied it since mid December the previous update should be there, dated 12/20/2017 plus of minus a day or two.

Share this post


Link to post
Share on other sites
3 minutes ago, nightxpress said:

If somebody has the Installer for 2.3.8, please PM me. I just bought the Software yesterday....

That would be a big no no! Please be patient.  RXP has recently been quickly responsive.

Share this post


Link to post
Share on other sites

I just bought the program and new to ReaxityXp so nothing to rollback too. It has been very frustrating the last week trying to get this thing to work. Glad I'm not alone though. I hope this thing gets fixed. Looks like a nice program. Any idea how I can get an older version?

Share this post


Link to post
Share on other sites
5 minutes ago, fppilot said:

That would be a big no no! Please be patient.  RXP has recently been quickly responsive.

Hi Frank,

What is the problem with downgrading?  There is the exe and my lisense files in the setup directory. It was recommended to save that. So there should be no problem to reinstall with a older version?

Share this post


Link to post
Share on other sites
Just now, nightxpress said:

Hi Frank,

What is the problem with downgrading?  There is the exe and my lisense files in the setup directory. It was recommended to save that. So thee exe should be no problem to reinstall with a older version?

No issue with your or that action on your part if you retained the installer. But would be a big no no to provide an older installer to someone who states he just recently purchased.

Share this post


Link to post
Share on other sites

Maybe RealityXP can put the older version V2.3.8 up for download until they figure this thing out

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now