Wes Yin

Treat own plane as a traffic plane

Recommended Posts

I am running the latest version of RXP GTN 750 with Garmin Trainer 6.41.1.

In the Map mode, at my current location is always a diamond with 00, as if the GTN recognizes myself as a traffic. This occurs regardless of the aircraft in use as long as it is in the air. There is no TAWS warning.

Another minor issue is that AutoPilot Nav often has a 20-200 feet offset to the left of the GPS route, i.e., flying parallel to the GPS route, even several minutes after AP Nav has been flying on the current leg. This problem could be specific to the aircraft though. It is more apparent on Carenado's PC-12 than JustFlight's Arrow III.

Link to the screenshot: https://ibb.co/cPkMY7

JF_PA28_Arrow_1.png

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi,

This most likely is the new AI code which is now using 'heuristics' to gather the entire 19 MP datarefs slots, since it appears whenever using 3rd party traffic plugins, the X-Plane SDK fails to report the actual number of injected traffic.

You can restore previous versions mode with:

Settings | Gauge Options | Advanced | Use Simulator AI Traffic Count

Next update will reverse the logic, i.e. default using simulator AI count, and option labeled "Use Third Party AI traffic"

 

  • Upvote 1

Share this post


Link to post
Share on other sites
56 minutes ago, RXP said:

Hi,

This most likely is the new AI code which is now using 'heuristics' to gather the entire 19 MP datarefs slots, since it appears whenever using 3rd party traffic plugins, the X-Plane SDK fails to report the actual number of injected traffic.

You can restore previous versions mode with:

Settings | Gauge Options | Advanced | Use Simulator AI Traffic Count

Next update will reverse the logic, i.e. default using simulator AI count, and option labeled "Use Third Party AI traffic"

 

I confirm checking the box Use Simulator AI Traffic Count solves the problem. It is worth noting that this option applies to each aircraft separately. Thank you.

I fly on PilotEdge, which injects AI traffic. I hope they will still be shown on the GTN. I haven't had time testing it though.

Share this post


Link to post
Share on other sites
41 minutes ago, Wes Yin said:

I fly on PilotEdge, which injects AI traffic.

Please let me know how if disabling the option works best on PilotEdge or not.

As a matter of fact, the latest update added this option (was standard before), and the standard is now 'any AI'.

The purpose is that many customers flying with 3rd party traffic injected in the simulation used to set their X-Plane AI count to 0, which was in fact telling our plugin there is no AI to display. The trick used to be to set XPlane AI count to whatever you prefer so that the GTN/GNS V2 pick it up, and let the 3rd party AI traffic injects data into the datarefs slots. However, doing so, it seems X-Plane is computing AI traffic for nothing.

Nevertheless, we'll add a few more heuristic to prevent 'ghost' aircraft like this one.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now