MattDavies

PTA 2.61 now available (P3D v4.2 compatibility)

Recommended Posts

7 hours ago, badwolfx said:

How come my activation code says 'Wrong code'?? I installed 2.61. The last install I had was 2.52.

Press "Show" when you paste the code in, make sure there are no spaces or incorrect characters.

7 hours ago, nerd1146 said:

I'm having trouble getting the pta tool to run http://prntscr.com/if6tpf

 

http://prntscr.com/if6tyt

 

 

any help appreciated

Delete PTA, reinstall the P3D client module only, re download & run PTA.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

6 hours ago, nerd1146 said:

this will be the 6th reinstall of p3d I'm clueless and know nothing

You don't need to reinstall EVERYTHING - just the "Client" part of P3D. In the P3D download you'll find a client.msi, you can just run that once you've uninstalled it and it'll sort your issues. A client reinstall takes literally seconds. 

Share this post


Link to post
Share on other sites

Hello all,

 

Was wondering if anyone else has run into error issues while running PTA 2.61?

 

I have applied various numbers of presets and all keep ending with same outcome.

 

I keep getting these errors: 

 

Applying preset C:\Users\Josh\Desktop\FLIGHT SIM FILES\PTA 2.6\MattDavies1.3.ini...
   Applying [Reduce cloud brightness at dawn/dusk/night] to C:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\Cloud.fx
   Applying [Clouds shadows extended size] to C:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\Cloud.fx
ERROR applying tweak [Clouds shadows extended size]  Problem with patch #0 - Patched block not found.
   Applying ["No popcorn" modifier] to C:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\Cloud.fx
ERROR applying tweak ["No popcorn" modifier]  Problem with patch #0 - Patched block not found.
   Applying [Turn off clouds directional lighting] to C:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\Cloud.fx
ERROR applying tweak [Turn off clouds directional lighting]  Problem with patch #1 - Patched block not found.
   Applying [Clouds Fog tuning] to C:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\Cloud.fx
   Applying [Cirrus lighting] to C:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\General.fx
   Applying [Objects lighting] to C:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\General.fx
   Applying [Autogen emissive lighting] to C:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\General.fx
   Applying [Sky saturation] to C:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\General.fx
   Applying [Terrain lighting] to C:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\GPUTerrain.fx
   Applying [Urban areas lighting at night] to C:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\GPUTerrain.fx
   Applying [Terrain saturation] to C:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\GPUTerrain.fx
   Applying [Water surface tuning] to C:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\GPUTerrain.fx
   Applying [Waves size] to C:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\GPUTerrain.fx
   Applying [Rayleigh scattering effect] to C:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\FuncLibrary.fxh
ERROR applying tweak [Rayleigh scattering effect]  Problem with patch #1 - Patched block not found.
   Applying [Sky Fog tuning] to C:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\FuncLibrary.fxh
ERROR applying tweak [Sky Fog tuning]  Problem with patch #2 - Patched block not found.
   Applying [Waves speed] to C:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\GPUTerrain.fxh
   Applying [Turn off HDR luminance adaptation effect] to C:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\PostProcess\HDR.hlsl
   Applying [Alternate tonemap adjustment] to C:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\PostProcess\HDR.hlsl
   Applying [FXAA quality] to C:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\PostProcess\FXAAResolve.hlsl
   Applying [Tweak main config (prepar3D.cfg)] to Main config file
Preset has been applied with errors. See log above
Shaders cache cleared
 

 

On top of that, I try to start the sim (P3D v4.1) with these errors and all I get is a black screen.

 

Does anyone have any ideas? Any help would be much appreciated.

 

If this is due to 2.61 being only for P3D 4.2 how to do I roll back to 2.6? 

Thanks in advance,

Josh 

Share this post


Link to post
Share on other sites

thanks matt I did end up doing a full reinstall which solved the issue still I have no idea what caused it thanks for the help keep going with the great streams. alex

Share this post


Link to post
Share on other sites
On ‎13‎-‎2‎-‎2018 at 0:14 PM, MattDavies said:

Hi all,

We recently just made v2.61 of PTA available for users that have upgraded to Prepar3D v4.2.

You can find the download via your order page on the SimTweaks website. 

Please note: Due to shader structure change within Prepar3D v4.2, some of the tweaks in PTA v2.61 will NOT work in previous versions of Prepar3D. If you are not planning on upgrading from Prepar3D v4.1, you do NOT need to upgrade PTA. There isn't any new functionality in PTA v2.61, just compatibility with Prepar3D v4.2.

Thanks,

Matt.

What about users who just bought PTA as me and uses 4.1?  I got "patch block not found" errors on the popcorn and scattering effects tweaks. Can I download version 2.60 some where?

Share this post


Link to post
Share on other sites
1 hour ago, Ryback said:

What about users who just bought PTA as me and uses 4.1?  I got "patch block not found" errors on the popcorn and scattering effects tweaks. Can I download version 2.60 some where?

Yes if possible Matt this would be a huge help. I'm reluctant to upgrade to 4.2 just yet. With that being said I have pta 2.61 which keeps giving me errors since I'm on v4.1. 

Share this post


Link to post
Share on other sites

Matt,

I have just installed P3Dv4.2 and want to upgrade from PTA 2.60 to 2.61.

Forgive my ignorance but is it just a case of removing/uninstalling the 2.60 folder and replacing it with 2.61 or is it a bit more tricky than this?

A basic guide would be useful for those of us challenged by such matters! 

Thanks.

Rod

 

Share this post


Link to post
Share on other sites

Hello,

 

for the very first time, I am totally unable to make PTA working with 4.2 !

I have to each time activate PTA and totally unable to apply any kind of preset.

I have tried several time with 2.61 and even back to 2.60 but nothing is working here: errors, errors and errors.

I'm a bit lost and I've seen I'm not alone in this case...

Any kind of help is highly welcome...

apologize for my poor english: I try to do my best....

 

BugDani.

Share this post


Link to post
Share on other sites

PTAissue.jpgHello,

A never ending story: Activate, activate, activate, etc ......

BugDani.

Share this post


Link to post
Share on other sites

Resolved !!!

Not able to tell you what happened, but it seems to work from now :huh: , so....

Anyway, thank you...

BugDani.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now