Jump to content
Sign in to follow this  
James95

Help Required! Freezing and lagging.

Recommended Posts

Evening all,

Me again!

So I finally bit the bullet and went from FSX to P3DV4. However, after messing around with the settings and reading some old forum posts about lagging and freezing I still haven't perfected the sim to be lag and freezing free.Don't get me wrong, it is a lot better than when I first started off. I haven't made any changes to the CFG apart from within the Sim. 

In the Sim, initially it lags a bit, then after a couple of minutes its okay with the occasional couple of second lag, then after a few more minutes it just keeps freezing for about 15 seconds at a time.

I have downloaded Nvidia Inspector, but that hasn't really made a difference.

My set up is:

- Standard 1080P Asus Monitor 

- Intel I7 6700K Processor

- ASUS Z170 Pro Gaming Motherboard

- Geforce GTX 970

- G SKILL Ripjaw V Series 16GB Ram

 

During my testing I have been using the default raptor at various airports, and then the new maddog x at EGBB (UK2000. The addons I have running are ORBX Global, England, Wales, Scotland, Ireland, Open LC Europe, Vector and HD Trees. In the background I am also running VPilot and Active Sky. I have tried turning these off too, but still not difference. 

Below are the settings of the sim currently :

40461234491_760c68db20_b.jpgP3DV4 Lighting by James Roberts, on Flickr

26590541998_0e6377b54a_b.jpgP3DV4 Weather by James Roberts, on Flickr

38650921250_cfddb615b1_b.jpgP3DV4 World by James Roberts, on Flickr

38650921170_8ceae5e1ed_b.jpgP3DV4 Display by James Roberts, on Flickr

 

Does anyone have any tips or suggestions on how to get rid of the stutters/lag, short of suggesting a new graphics card as I would like to try and save money for new addons if I can get it working!

 

Thanks,

 

James Roberts

 

 

Edited by James95

James Roberts

Share this post


Link to post
1 hour ago, James95 said:

Evening all,

Me again!

So I finally bit the bullet and went from FSX to P3DV4. However, after messing around with the settings and reading some old forum posts about lagging and freezing I still haven't perfected the sim to be lag and freezing free.Don't get me wrong, it is a lot better than when I first started off. I haven't made any changes to the CFG apart from within the Sim. 

In the Sim, initially it lags a bit, then after a couple of minutes its okay with the occasional couple of second lag, then after a few more minutes it just keeps freezing for about 15 seconds at a time.

I have downloaded Nvidia Inspector, but that hasn't really made a difference.

My set up is:

- Standard 1080P Asus Monitor 

- Intel I7 6700K Processor

- ASUS Z170 Pro Gaming Motherboard

- Geforce GTX 970

- G SKILL Ripjaw V Series 16GB Ram

 

During my testing I have been using the default raptor at various airports, and then the new maddog x at EGBB (UK2000. The addons I have running are ORBX Global, England, Wales, Scotland, Ireland, Open LC Europe, Vector and HD Trees. In the background I am also running VPilot and Active Sky. I have tried turning these off too, but still not difference. 

Below are the settings of the sim currently :

40461234491_760c68db20_b.jpgP3DV4 Lighting by James Roberts, on Flickr

26590541998_0e6377b54a_b.jpgP3DV4 Weather by James Roberts, on Flickr

38650921250_cfddb615b1_b.jpgP3DV4 World by James Roberts, on Flickr

38650921170_8ceae5e1ed_b.jpgP3DV4 Display by James Roberts, on Flickr

 

Does anyone have any tips or suggestions on how to get rid of the stutters/lag, short of suggesting a new graphics card as I would like to try and save money for new addons if I can get it working!

 

Thanks,

 

James Roberts

 

 

first turn off FXAA / also VSync off, Triple Buffering uncheck, Target frame limit unlimited

Share this post


Link to post

First, Try to uncheck some shadows cast: Vegetation, building, particules. The difference is visually less important than the FPS drop.

If no improvement, try to uncheck some reflection (unrealistic in my point of view): clouds, vegetations and buildings.

You can also try to reduce autogen distance one step left.

Shouldn't have an influence during the day, but you can uncheck dynamic lighting to test.

Go step by step to try to identify the guilty setting.

Do you have FSUIPC installed? If yes, is it the lastest version (which is known to freeze P3D) or do you have autosave enabled. If so, try to desactive it

Edited by orangina
Add FSUIPC

Orangina

Hardware: Intel 4770K / Geforce 1060 / Saitek X55 + Fighter Rudder / Saitek Switch Panel + Multi Panel + Radio Panel + BIP + 5 FIP (Drived by SPADNext) / Track IR 4 + TrackClip Pro

Software: W10 64bits, MSFS, LittleNavMap

Share this post


Link to post

- Your videocard isn't that strong to render all that shadows. What Orangina suggested.. 

-  Also when using autogen building, please set the distance for autogen at medium. Your cpu will spike at some locations.

- If possible set your monitor frequency rate at 30HZ or use nvidia configurator to set it on half adaptive synchronisation, when u use the card for synchronisation turn of v-sync in prepar3d.

- To minimize those micro stutter use fiber_frame_time_fraction between  0.01 and 0.16 in your config under main.

- Set your target frame at unlimited, or at 30fps 

- U could push those terrain sliders to the max and use high resolution terrain textures checked, it will run fine in most cases. 

- Also u can crank op the texure resolution to 2048 in p3d v4. It had no fps impact.

-FXAA to off.

- If u get stutters at specific airports or addons, u may uncheck "sim objects" or "buildings" at the reflection settings. 

 

 

Share this post


Link to post

Also, dunamic vegitation off. Lots of fps lost for a minor visual improvement.

the effect of dynamic lights at night is an entire separate issue in its own right but for starters make sure you’re getting fluid performance during the day. 

Now, fluid performance isn’t just about fps.

Share this post


Link to post

FSUIPC removed cured my freezes and stutters which like yours were huge.

 

I removed fsuipc from modules and it ran perfect, although the arrow keys don't work for some reason, but track ir  over comes that

Share this post


Link to post

Thanks for all your suggestions and help! Seems to be running a lot smoother now!

 

I have come across a new issue however, I don't be able to be able to see undockable windows, e.g PFD, FMS etc.

 

I can see them if i guess where they are and click 'undock window'?

 

Any ideas?


James Roberts

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    53%
    $13,405.00 of $25,000.00 Donate Now
×
×
  • Create New...