Recommended Posts

I am running P3D v4.1 with PTA 2.51, and would like to download PTA 2.60, but am unable to find it at SimTweaks.

I have pta_2.60.zip, which I would've assumed is version 2.60, but when unzipped, the PTA.exe version details indicate it is 2.5.1.0.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

2.6x is no longer freeware. You need to purchase it.

  • Like 1

Share this post


Link to post
Share on other sites

As indicated, I already OWN PTA v2.51 which was not freeware either.

Share this post


Link to post
Share on other sites

I need PTA 2.60 as well I have a couple of apps that I run with P3D 4.1 and I cannot upgrade to 4.2... I accidentally upgraded to PTA 2.61 and now I get errors when trying to apply a preset since I run P3D 4.1 not 4.2... 

A link to download PTA 2.60 would be nice! Previous versions should be on the website in case something like this happens

Share this post


Link to post
Share on other sites

Interestingly, I have discovered that the version I have installed is 2.60. When I check properties on the .exe, the details say that it is version 2.5.1.0, but when I launch PTA and look at the "Setup info" it says it's version 2.60. I am using the Thopat preset for PTA 2.60 (with my own tweaks), and it works fine with no errors.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now