Jump to content

Sign in to follow this  
wazooda

RXP 530W not responding to OBS inputs from sim

Recommended Posts

Took the plunge and purchased the 530W.  Added it to the panel and everything seems to be working perfectly.... except for OBS mode in GPS.

If I turn the OBS in VLOC mode, all works well.

However, if GPS mode is selected, when I press OBS on the GPS, the course line appears from the waypoint, but turning the OBS knob in the sim, while correctly rotating the course card in the sim, there is no movement of the course on the GPS and thus the needle nor ambiguity indicator move on the VOR receiver.

I've selected all the settings in Panel Instruments but still can't get the GPS to recognize OBS movement.

I'm sure I'm missing something obvious here.

Thanks,

Paul


CPU: Windows 10 i7-4770k @ 4.3ghz - 16GB

Graphics: Nvidia 980 GTX (x2/SLI) - Planar SA2311W 3D Monitors (x3)

Flight Controls: Brunner FFB Yoke, Thrustmaster HOTAS Warthog, CH Products Rudders, TrackIR 5

Prepar3D v3.3

Share this post


Link to post
Share on other sites

Hi Paul, we'll review this and report back later.


Jean-Luc | reality-xp.com
This message from Reality XP is protected by a disclaimer: reality-xp.com/aboutrealityxp/email.html

Share this post


Link to post
Share on other sites

Here's a link to a video capture I made of the problem: 

 

I have ELB set as the Direct To WP.  In GPS mode when I select OBS, you'll notice that turning the OBS course selector has zero effect in the GPS unit.  In addition, each time I select/deselect OBS, the OBS course seems to jump about 1 degree in the GPS which is reflected on the CDI.  I also, as mentioned above, have all the selections checked in the Panel Configuration settings.

Hope this helps to diagnose.

 

Edited by wazooda
correction

CPU: Windows 10 i7-4770k @ 4.3ghz - 16GB

Graphics: Nvidia 980 GTX (x2/SLI) - Planar SA2311W 3D Monitors (x3)

Flight Controls: Brunner FFB Yoke, Thrustmaster HOTAS Warthog, CH Products Rudders, TrackIR 5

Prepar3D v3.3

Share this post


Link to post
Share on other sites

UPDATE:  So I think I'm able to confirm that this is an incompatibility with the RXP 530 v2 and the stock C172. 

If I load the Airfoil Labs 172 or the stock Cirrus, the OBS works as it should.

This is a major bummer as I'm currently getting my IFR IRL in a 172 and I've read here that the AFL 172 is wonky with the autopilot.

Can you guys confirm this is a stock C172 issue and, if so, will you be working to fix it?

Thanks. 


CPU: Windows 10 i7-4770k @ 4.3ghz - 16GB

Graphics: Nvidia 980 GTX (x2/SLI) - Planar SA2311W 3D Monitors (x3)

Flight Controls: Brunner FFB Yoke, Thrustmaster HOTAS Warthog, CH Products Rudders, TrackIR 5

Prepar3D v3.3

Share this post


Link to post
Share on other sites

Hi,

Unfortunately we've been unable to specifically test in the default C172, it was too short a time while working on the v2.3.11 update release.

Nevertheless, the 1deg stepping when toggling mode is due to a rounding error between reading and setting the OBS value to X-Plane. We are yet to find out if this is an X-Plane rounding issue, or a RXP plugin rounding issue (still investigating).

As for the OBS mode, this makes me wonder if this is related to the way the aircraft system are configured in Aircraft Maker, and a probable limitation/bug in X-Plane: It seems you can configure aircraft with VOR only and no HSI subsystems but the OBS mode requires an HSI otherwise it won't activate.

Even if in the C172, what about enabling 'Link to HSI' in the settings panel?

We'll review if there are any consistent mean to read the VOR indicator OBS independently of the HSI OBS in such aircraft, i.e. are these the same dataref or are they separate, and if so, we'll try to provide a solution in the next update.


Jean-Luc | reality-xp.com
This message from Reality XP is protected by a disclaimer: reality-xp.com/aboutrealityxp/email.html

Share this post


Link to post
Share on other sites

Thanks for the reply.

I tried Link to HSI and even cycled through each setting individually to see if any combination is causing the problem but no joy.

I need to confirm that the OBS is, in fact, working in VLOC mode. I was trying so many iterations trying to isolate the problem that I want to make sure... but I'm out of town till Friday so I'll post results when I return.

Paul


CPU: Windows 10 i7-4770k @ 4.3ghz - 16GB

Graphics: Nvidia 980 GTX (x2/SLI) - Planar SA2311W 3D Monitors (x3)

Flight Controls: Brunner FFB Yoke, Thrustmaster HOTAS Warthog, CH Products Rudders, TrackIR 5

Prepar3D v3.3

Share this post


Link to post
Share on other sites

Returned from vacation and can confirm that the OBS does NOT work in VLOC mode either.

Hopefully, you guys can solve this problem.

Thanks!

Paul


CPU: Windows 10 i7-4770k @ 4.3ghz - 16GB

Graphics: Nvidia 980 GTX (x2/SLI) - Planar SA2311W 3D Monitors (x3)

Flight Controls: Brunner FFB Yoke, Thrustmaster HOTAS Warthog, CH Products Rudders, TrackIR 5

Prepar3D v3.3

Share this post


Link to post
Share on other sites

Hi,

We've not found anything relevant in regard to this yet, and it has been working fine on our end as well, but I just wanted to let you know we're releasing the next update tomorrow and hopefully, with the many changes, it might solve the issue you are reporting as well!


Jean-Luc | reality-xp.com
This message from Reality XP is protected by a disclaimer: reality-xp.com/aboutrealityxp/email.html

Share this post


Link to post
Share on other sites
13 hours ago, RXP said:

Hi,

We've not found anything relevant in regard to this yet, and it has been working fine on our end as well, but I just wanted to let you know we're releasing the next update tomorrow and hopefully, with the many changes, it might solve the issue you are reporting as well!

Thanks for the followup.

Just to confirm, you're saying that you cannot replicate the problem in the C172 or that it works everywhere BUT the C172?

Paul


CPU: Windows 10 i7-4770k @ 4.3ghz - 16GB

Graphics: Nvidia 980 GTX (x2/SLI) - Planar SA2311W 3D Monitors (x3)

Flight Controls: Brunner FFB Yoke, Thrustmaster HOTAS Warthog, CH Products Rudders, TrackIR 5

Prepar3D v3.3

Share this post


Link to post
Share on other sites

Well in fact it was a little late yesterday when I've answered and now further looking into our internal tickets, I see where the confusion is.

the OBS input is working from the HSI OBS, which you can cross check with data ref editor. It is not taking inputs from the VOR OBS data refs, which are different.

It might be a little late to add these now since we are about to release the update though.


Jean-Luc | reality-xp.com
This message from Reality XP is protected by a disclaimer: reality-xp.com/aboutrealityxp/email.html

Share this post


Link to post
Share on other sites
1 hour ago, RXP said:

Well in fact it was a little late yesterday when I've answered and now further looking into our internal tickets, I see where the confusion is.

the OBS input is working from the HSI OBS, which you can cross check with data ref editor. It is not taking inputs from the VOR OBS data refs, which are different.

It might be a little late to add these now since we are about to release the update though.

Ah... and since the C172 does not have an HSI and only a VOR OBS that explains why it doesn't work in the C172.

Thanks for the clarification and can't wait for an update as I *love* your product.

-Paul


CPU: Windows 10 i7-4770k @ 4.3ghz - 16GB

Graphics: Nvidia 980 GTX (x2/SLI) - Planar SA2311W 3D Monitors (x3)

Flight Controls: Brunner FFB Yoke, Thrustmaster HOTAS Warthog, CH Products Rudders, TrackIR 5

Prepar3D v3.3

Share this post


Link to post
Share on other sites

In the meantime, I'm wondering how difficult would it be to script a LUA that would sync back and forth the VOR and the HSI OBS datarefs. Is there anyone LUA-fluent who could help with this?

Edited by RXP

Jean-Luc | reality-xp.com
This message from Reality XP is protected by a disclaimer: reality-xp.com/aboutrealityxp/email.html

Share this post


Link to post
Share on other sites

Hi, a quick update to let you know we've officially released v2.4 which now connects the OBS source either to the HSI if 'LinkHsi' is true, otherwise to the VOR1/2 OBS if 'LinkVor' is true (1 or 2 depending on the AutoNavSource setting)!

Edited by RXP

Jean-Luc | reality-xp.com
This message from Reality XP is protected by a disclaimer: reality-xp.com/aboutrealityxp/email.html

Share this post


Link to post
Share on other sites

Fantastic! Can't wait to give it a try. 

Thanks so much for fixing this.

Much appreciated!


CPU: Windows 10 i7-4770k @ 4.3ghz - 16GB

Graphics: Nvidia 980 GTX (x2/SLI) - Planar SA2311W 3D Monitors (x3)

Flight Controls: Brunner FFB Yoke, Thrustmaster HOTAS Warthog, CH Products Rudders, TrackIR 5

Prepar3D v3.3

Share this post


Link to post
Share on other sites

Thank you for your feedback which helps us better our products!


Jean-Luc | reality-xp.com
This message from Reality XP is protected by a disclaimer: reality-xp.com/aboutrealityxp/email.html

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    28%
    $7,170.00 of $25,000.00 Donate Now
×
×
  • Create New...