Recommended Posts

On a clean install of Prepar3d V4.2 and fresh out of the box PTA 2.61, while trying to apply a preset I am getting repeated errors along the lines of:

Applying preset C:\Users\Morgan\Desktop\Presets\MattDavies1.3.ini...
   Applying [Reduce cloud brightness at dawn/dusk/night] to C:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\Cloud.fx
   Applying [Clouds shadows extended size] to C:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\Cloud.fx
   Applying ["No popcorn" modifier] to C:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\Cloud.fx
   Applying [Turn off clouds directional lighting] to C:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\Cloud.fx
   Applying [Clouds Fog tuning] to C:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\Cloud.fx
ERROR writing destination shader file C:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\Cloud.fx
   Applying [Cirrus lighting] to C:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\General.fx
   Applying [Objects lighting] to C:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\General.fx
   Applying [Autogen emissive lighting] to C:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\General.fx
   Applying [Sky saturation] to C:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\General.fx
ERROR writing destination shader file C:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\General.fx
   Applying [Terrain lighting] to C:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\GPUTerrain.fx
   Applying [Urban areas lighting at night] to C:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\GPUTerrain.fx
   Applying [Terrain saturation] to C:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\GPUTerrain.fx
   Applying [Water surface tuning] to C:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\GPUTerrain.fx
   Applying [Waves size] to C:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\GPUTerrain.fx
ERROR writing destination shader file C:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\GPUTerrain.fx
   Applying [Rayleigh scattering effect] to C:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\FuncLibrary.fxh
   Applying [Sky Fog tuning] to C:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\FuncLibrary.fxh
ERROR writing destination shader file C:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\FuncLibrary.fxh
   Applying [Waves speed] to C:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\GPUTerrain.fxh
ERROR writing destination shader file C:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\GPUTerrain.fxh
   Applying [Turn off HDR luminance adaptation effect] to C:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\PostProcess\HDR.hlsl
   Applying [Alternate tonemap adjustment] to C:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\PostProcess\HDR.hlsl
ERROR writing destination shader file C:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\PostProcess\HDR.hlsl
   Applying [FXAA quality] to C:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\PostProcess\FXAAResolve.hlsl
ERROR writing destination shader file C:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\PostProcess\FXAAResolve.hlsl
   Applying [Tweak main config (prepar3D.cfg)] to Main config file
Preset has been applied with errors. See log above

Prior to reinstalling P3D completely, PTA had been working just fine with no errors, which has me stumped as to why all of a sudden it's spitting out these errors repeatedly, help would be much appreciated!
 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Posted (edited)

I am having similar issues - I have read that I am to restore shader and config files and then delete the main PTA directory, but am having issues locating PTA files to remove.

 

ERROR applying preset: source file C:\Users\Chuck\Desktop\SHADERS_BACKUP\Cloud.fx not found

ERROR applying preset: source file C:\Users\Chuck\Desktop\SHADERS_BACKUP\General.fx not found

ERROR applying preset: source file C:\Users\Chuck\Desktop\SHADERS_BACKUP\GPUTerrain.fx not found

ERROR applying preset: source file C:\Users\Chuck\Desktop\SHADERS_BACKUP\FuncLibrary.fxh not found

ERROR applying preset: source file C:\Users\Chuck\Desktop\SHADERS_BACKUP\GPUTerrain.fxh not found

ERROR applying preset: source file C:\Users\Chuck\Desktop\SHADERS_BACKUP\PostProcess\HDR.hlsl not found

ERROR applying preset: source file C:\Users\Chuck\Desktop\SHADERS_BACKUP\PostProcess\FXAAResolve.hlsl not found

Preset has been applied with errors. See log above

Edited by Chuck Steinmetz

Share this post


Link to post
Share on other sites

Got it to work - here's what I did.  Deleted the P3D V4.2 Client file.  When it asks if you want to deactivate P3D click on 'no'.  Reload the Client file - this should reload your shaders as original.  Run the PTA and it will find the original shaders.  If they aren't original they will be bypassed.

The first post has an error message relating to a 'destination shader file'.  I don't know enough about what the Client file reinstalls, but if there is an issue w/ the C:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\ path it may get reset w/ a Client reinstall and could solve this error.  Another option is to delete the path, but again, I can't guarantee that it gets rebuilt when you run P3d.

Note - from a previous post I learned that the shader files in C:\Users\*name*\AppData\Local\Lockheed Martin\Prepar3D v4\Shaders can be deleted and are rebuilt just like the config file when you reopen P3D.  So if your issues reside in this folder you can get the original shader files back by deleted the folder and opening up P3D.  I also have read that PTA impacts some of the files in ShadersHLSL so unless you have saved off the original files as a back up you may need to reinstall the Client and it might reinstall the original ShadersHLSL files in that folder.  Again, PTA needs to see the original shader files for it to work.

Hope this helps.

Chuck

Share this post


Link to post
Share on other sites

Did anyone simply try running as ADMIN?

 

Share this post


Link to post
Share on other sites
Posted (edited)

I do run as admin - one additional note to my last post - if you delete the ShadersHLSL path it will not be rebuilt when you reopen P3D.  You need to uninstall and reinstall the Client.  Chuck

Edited by Chuck Steinmetz

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now