him225

Vsync without triple buffering and fps

Recommended Posts

Posted (edited)

I have a 60hz monitor and get 40-45 fps in a scenario but with micro stutters. If I lock the internal fps limiter to 30 I get a very smooth sim. So I decided to only enable vsync which should lock the frame rate to 60, 30 or 20 as performance allows, but it didn't happen so and fps still linger in the 40s. The fps usually locks to the multiples in games when used without enabling triple buffering, so why it is not in p3d?

Edited by him225

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

I think vsync syncs to the refresh rate of your monitor, so a 60hz monitor will sync to 60fps. You’ll see stutters below this figure. 

I solved this by getting a monitor that supports 30hz (hence a 30fps rate) resulting in a very smooth sim. 

I believe that you can force a 60hz monitor to 30hz with nvidia inspector these days, but I can’t say I’ve tried it. 

Share this post


Link to post
54 minutes ago, Airline2Sim said:

I believe that you can force a 60hz monitor to 30hz with nvidia inspector these days, but I can’t say I’ve tried it. 

I think that depends on your monitor: you can give it a try and see for yourself. My monitor didn't like it at all: I only got a black screen. :happy:

Share this post


Link to post

Experiment with fast sync yet?

  • Like 1

Share this post


Link to post

Triple buffering is nowadays forced in the nVidia drivers (even if there are still some people claim otherwise...). Triple buffering has the effect that the FPS do not drop down to 30 anymore if your monitor uses 60Hz and 60FPS are not reached. Those times are gone.

Share this post


Link to post

I change my monitor's refresh rate using nvidia control panel and then lock the internal fps to that refresh rate. (i use 24 or 30 depending on the plane i am flying); I also have vsync enabled.

I get very smooth and perfect performance as long as my rig can can maintain the fps that i set; which is about 99% of the time.

 

 

Share this post


Link to post

I read a few times VSync doesn't work with windowed applications (which is the case of P3D v4, since it doesn't run true fullscreen). I was one who used to set the screen to 30 Hz and enabled VSync inside P3D and it worked nicely except for two things: the mouse pointer always felt sluggish and whenever the FPS fell below 30 the stutterers were massive.

Nowadays I set the refresh rate back to 60 Hz and set 30 FPS inside NVidia Inspector, which gives me a very smooth experience, even when the FPS falls bellow 30 and the mouse pointer is also very smooth to deal with. Inside P3D the FPS is unlimited, no signs of distracting blurring.

Share this post


Link to post
5 hours ago, Wanthuyr Filho said:

I read a few times VSync doesn't work with windowed applications (which is the case of P3D v4, since it doesn't run true fullscreen). I was one who used to set the screen to 30 Hz and enabled VSync inside P3D and it worked nicely except for two things: the mouse pointer always felt sluggish and whenever the FPS fell below 30 the stutterers were massive.

Nowadays I set the refresh rate back to 60 Hz and set 30 FPS inside NVidia Inspector, which gives me a very smooth experience, even when the FPS falls bellow 30 and the mouse pointer is also very smooth to deal with. Inside P3D the FPS is unlimited, no signs of distracting blurring.

After much experimentation I concur with the above solution. Also turn off that FPS counter....very smooth flight without that worry of "why can't I just try and get 55FPS smooth with one more tweak...". :cool:

Shez

  • Like 1

Share this post


Link to post

Same here monitor set to 60HZ and frames locked in inspector at thirty is the magic for me.

  • Like 1

Share this post


Link to post
On 4/16/2018 at 7:22 PM, Wanthuyr Filho said:

I read a few times VSync doesn't work with windowed applications (which is the case of P3D v4, since it doesn't run true fullscreen). I was one who used to set the screen to 30 Hz and enabled VSync inside P3D and it worked nicely except for two things: the mouse pointer always felt sluggish and whenever the FPS fell below 30 the stutterers were massive.

Nowadays I set the refresh rate back to 60 Hz and set 30 FPS inside NVidia Inspector, which gives me a very smooth experience, even when the FPS falls bellow 30 and the mouse pointer is also very smooth to deal with. Inside P3D the FPS is unlimited, no signs of distracting blurring.

What do you set in p3d? Unlimited or 30 frames ? Or do you set 30 in both inspector and sim?

Thanks,

Tom

Share this post


Link to post
6 minutes ago, nocaltom said:

What do you set in p3d? Unlimited or 30 frames ? Or do you set 30 in both inspector and sim?

Thanks,

Tom

Unlimited. But it may be 60 if you start seeing scenery blurries. In my previous rig I used to have, but not the current one (so unlimited).

Share this post


Link to post

Thanks!!

12 minutes ago, Wanthuyr Filho said:

Unlimited. But it may be 60 if you start seeing scenery blurries. In my previous rig I used to have, but not the current one (so unlimited).

Thanks!!!

Share this post


Link to post
Posted (edited)

With P3D "Vertical Synchronisation" of the Monitor is controlled by Windows Desktop.

P3D is a desktop window, and when in full-screen (we use the Windows key combination command ALT+ENTER) is a maximised desktop window with the caption and border removed.

The VSync in P3D display settings causes P3D to obtain the monitor refresh frequency as a guide to output frames computed for the time of the scene to be displayed at the next frame. This does not control tearing.

VSync-On and Unlimited on the slider means the fps is not capped at the monitor refresh frequency. The resulting frames wobble around that frequency.

Adding the Triple Buffer does not alter the fps it only enables the next frame drawn to be more accurate according to what the scene will be when it is finally displayed.

Limiting: Using the Nvidia controls to limit fps at just below the intended frequency is better than just above as is recommended elsewhere. This is because the GPU is always throwing away a frame. When setting the limit correctly just below the monitor frequency or division of that frequency, each frame only ever waits a small time, and at 30fps 29fps saves 4% throughput as well. A common mistake is to set it at 31 and intend to sync at 30, use 29. In the NVidia settings it's 28.5, 29.5, 30.5 and so on for the purpose.

Setting the monitor behaviour to become a lower refresh type can result in blank screens, the settings are confusing and the timings must be correct - have another go.

 

 

 

Edited by SteveW

Share this post


Link to post

This story is still not entirely clear to me, let me explain where I have issues to understand:

1. I use a 144Hz Monitor with G-Sync. All those tipps and tricks I can read online are in regard to 60Hz Monitors. I tried to adapt with no luck (using 1/4 refresh rate instead of 1/2 etc.)

2. In the nVidia Profile Inspector, I get two different frame limiter options. One is not "precise", means all I can select are values like "~36.7FPS" and so on. The other one is precise, called "Framelimiter v2" and offers distinct values such as "36FPS". Which one should I use?

3. The stories about blurries. In earlier versions of P3D, I observed blurries when using "unlimited" in P3D and an external limiter (I used the unprecise ~36.7 limit). Currently, I use 36FPS inside P3D and no limiter in the nVidia Profile Inspector.

So, no, still not entirely clear what to do with my 144Hz setup...

Share this post


Link to post
Posted (edited)
16 minutes ago, AnkH said:

This story is still not entirely clear to me, let me explain where I have issues to understand:

1. I use a 144Hz Monitor with G-Sync. All those tipps and tricks I can read online are in regard to 60Hz Monitors. I tried to adapt with no luck (using 1/4 refresh rate instead of 1/2 etc.)

2. In the nVidia Profile Inspector, I get two different frame limiter options. One is not "precise", means all I can select are values like "~36.7FPS" and so on. The other one is precise, called "Framelimiter v2" and offers distinct values such as "36FPS". Which one should I use?

3. The stories about blurries. In earlier versions of P3D, I observed blurries when using "unlimited" in P3D and an external limiter (I used the unprecise ~36.7 limit). Currently, I use 36FPS inside P3D and no limiter in the nVidia Profile Inspector.

So, no, still not entirely clear what to do with my 144Hz setup...

1. 60Hz is just a number can be divided into 60/2=30, 20, 15,10 very nicely. 144 can be divided into 36 as 144/4, 29 as 144/5, and even as low as 144/6=24 should be just good enough for slow flying.

You are not referring to 1/2 vsync in NPI? That would not work - the Desktop controls vsync.

2. If you want to add-in a limiter use the framelimit in NPI. Your desired output fps should be just below that not just above.

3. Blurriness is due to the failure to load a complete texture in time for the display. This could be one of many things, your addons, your dlls, your simconnect addons, your monitor setup is probably not at fault.

 

Start with thinking what fps you desire for the intended simulation. Experiment to find what you want.

 

Say you want only 24fps. Lock at 24fps in Display settings. Leave your monitor at 144.

 

 

Edited by SteveW

Share this post


Link to post
4 minutes ago, SteveW said:

2. If you want to add-in a limiter use the framelimit in NPI. Your desired output fps should be just below that not just above.

Ok, but this still does not resolve the question if I should use the unprecise frame limiter in the nVidia Profile inspector or the "Framelimiter v2" that offers precise limits. I guess this does not really matter, no?

  • Like 1

Share this post


Link to post

Have you tried those and compared? I've only used the Framelimiter.

Share this post


Link to post

Hi Steve,

Now I am pretty confused as well :). Can you please tell me if my current settings are alright? I have a 60Hz monitor, in NVidia Inspector I have set the framerate limiter to ~29.5, vertical sync in NVI is set to 1/2 refresh rate and triple buffering in NVI is set to on. In P3D vsync is set to off as is triple buffering. The target framerate in P3D is set to unlimited.

Would this be the best way to go or should I use a different setting?

Thanks,
Hans

  • Upvote 1

Share this post


Link to post
Posted (edited)
20 minutes ago, SteveW said:

Have you tried those and compared? I've only used the Framelimiter.

Yes, I tried both, I do not see any difference. Scroll down further in the dropdown menue inside nVidia Profile Inspector under "Framelimiter", I am sure you will also have those precise numbers listed...

Edited by AnkH

Share this post


Link to post
Posted (edited)
37 minutes ago, hvw said:

Hi Steve,

Now I am pretty confused as well :). Can you please tell me if my current settings are alright? I have a 60Hz monitor, in NVidia Inspector I have set the framerate limiter to ~29.5, vertical sync in NVI is set to 1/2 refresh rate and triple buffering in NVI is set to on. In P3D vsync is set to off as is triple buffering. The target framerate in P3D is set to unlimited.

Would this be the best way to go or should I use a different setting?

Thanks,
Hans

 

P3D VSync is interpreted by P3D simply for organising the time of the next frame it is not a limiter. So with P3D "VSync"=ON + Unlimited we get roughly the fps of the monitor refresh if the fps can be maintained.

Monitor "vertical sync" is controlled by the desktop so 1/2 vsync in NPI on the P3D profile is ignored.

Settings like those can confuse profiles - always start with profiles set to factory defaults - a big source of errors to not do this. Restore Apply and then make any change to the profile to create a file for NPI to read and will display those with the house icon button.

Instead, if we want a slower P3D VSync we can slow down the monitor.

Or we don't use P3D VSync we use Locked fps on the slider.

The NPI Framelimit will hold back the fps by capping the framerate - P3D VSync=Off Unlimited.

Problems arise with the NPI Framelimit as this can cause half fps or worse conditions with undocked panels and GPS units. These errors can be retained in the Profile so always Restore factory defaults. Don't have NPI active when testing - Apply and close it first.

If the monitor frequency is too high for the P3D VSync, we can try a lower frequency in the Monitor profile but it's tricky to do and also means the mouse pointer drifts around without such immediacy as usual.

 

21 minutes ago, AnkH said:

Yes, I tried both, I do not see any difference. Scroll down further in the dropdown menue inside nVidia Profile Inspector under "Framelimiter", I am sure you will also have those precise numbers listed...

Yes, scroll down to v2 exactly the same results.

 

 

 

 

 

Edited by SteveW
  • Upvote 1

Share this post


Link to post
Posted (edited)
55 minutes ago, hvw said:

Hi Steve,

Now I am pretty confused as well :). Can you please tell me if my current settings are alright? I have a 60Hz monitor, in NVidia Inspector I have set the framerate limiter to ~29.5, vertical sync in NVI is set to 1/2 refresh rate and triple buffering in NVI is set to on. In P3D vsync is set to off as is triple buffering. The target framerate in P3D is set to unlimited.

Would this be the best way to go or should I use a different setting?

Thanks,
Hans

NVI framelimiter 29.5FPS

P3D vsync ON

P3D Triple buffering ON

P3D framerate UNLIMITED

Two more items which may not relate to your setup.

* I have a high end GPU (GTX1080Ti) and CPU (i7 8700K) so I also set NVI SSGS 2X. It just seems to improve the clouds transparency and the whole scene is amazing.

* I have a 4K 28" monitor so in P3D I only use MSAA 4X. I get beautiful anti-aliasing with no impact on FPS and the clouds are amazing.

The only thing I have to watch is the CPU temp even with water cooling. I use a self generated Process Lasso profile which maximizes the cores for P3D and minimizes other processes so it does stress the cores...but hey that is what it was for right...

That GPU :biggrin:, with the 4X MSAA you can throw everything at it and it sits at 40% with low temps.

Shez

Edited by ShezA

Share this post


Link to post

This Vsync information is particular to P3D because it's not using the game mode or "exclusive mode" used by mainstream games. Instead it makes DX11 viewports in desktop windows.

 

4 minutes ago, ShezA said:

* I have a 4K 28" monitor so in P3D I only use MSAA 4X. I get beautiful anti-aliasing with no impact on FPS and the clouds are amazing.

 

Anti-Aliasing and Pixellation in P3D:

The problems of pixelated views is also a concern amongst users of P3D, and has not been addressed correctly in any of the P3D guides I've seen.

The way shaders work was altered in DX10 from DX9 and can be seen in FSX DX10 Preview mode.

This has very little impact, if none, to the pixellation seen in P3D images. DX10 and DX11 use a different arrangement in stenciling transparency - not to be confused with rendering see-through objects.

The problems arise from models scaling within these transparency passes of the renderer. This can be seen by zooming-in to the affected VC dials and controls, they become nicely AA’d then.

Other aircraft for example the B58 (specifically designed with FSX DX10+ in mind) shows a better view of the VC for that reason.

Share this post


Link to post
25 minutes ago, SteveW said:

P3D VSync is interpreted by P3D simply for organising the time of the next frame it is not a limiter.

Thanks a lot, Steve.

 

Best,

Hans

  • Like 1

Share this post


Link to post
51 minutes ago, SteveW said:

...always start with profiles set to factory defaults - a big source of errors to not do this. Restore Apply and then make any change to the profile to create a file for NPI to read and will display those with the house icon button...

Exactly how this works changes slightly from version to version. If the profile still appears in NPI delete it with x button to be sure of starting with a clean plate.

Share this post


Link to post

Hi,

Someone asked what to do if they have a G-SYNC monitor that refreshes at 144Hz.

I stumbled on the fact that best results are in fact achieved globally by reducing the monitor’s refresh rate to 120Hz (using the monitor’s dedicated control) and ensuring that this is matched by the setting in the NCP. 

All fast FPS games/flight sims (except P3D) have VSync and G-SYNC = ON in their respective NCP Profiles and, where available, VSync = OFF in their in-game settings.

I do not use G-SYNC in P3D as it doesn’t work properly when frame rates drop below 30. Instead, I use the Fixed refresh setting in NCP with a frame rate lock of 30fps in-sim. This seems to be producing very fluid results for most of the time providing GPU frame rendering rate output stays at or above 30fps. VSync and TB are both = OFF.

30fps being 120/4 is why I see frame display matching more often than not with my monitor’s refresh cycles and thus produces that much sought after sensation of performance smoothness (fluidity). There is no mouse lag. The added bonus, of course, is far less stress on an expensive GPU which will help ensure its longevity and trouble-free operation.

Edit: in light of what has been discussed I’m thinking of trying the effect of locking at 29.5fps. 

Mike

 

 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now