him225

Vsync without triple buffering and fps

Recommended Posts

4 minutes ago, SteveW said:

2. If you want to add-in a limiter use the framelimit in NPI. Your desired output fps should be just below that not just above.

Ok, but this still does not resolve the question if I should use the unprecise frame limiter in the nVidia Profile inspector or the "Framelimiter v2" that offers precise limits. I guess this does not really matter, no?

  • Like 1

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Have you tried those and compared? I've only used the Framelimiter.

Share this post


Link to post

Hi Steve,

Now I am pretty confused as well :). Can you please tell me if my current settings are alright? I have a 60Hz monitor, in NVidia Inspector I have set the framerate limiter to ~29.5, vertical sync in NVI is set to 1/2 refresh rate and triple buffering in NVI is set to on. In P3D vsync is set to off as is triple buffering. The target framerate in P3D is set to unlimited.

Would this be the best way to go or should I use a different setting?

Thanks,
Hans

  • Upvote 1

Share this post


Link to post
Posted (edited)
20 minutes ago, SteveW said:

Have you tried those and compared? I've only used the Framelimiter.

Yes, I tried both, I do not see any difference. Scroll down further in the dropdown menue inside nVidia Profile Inspector under "Framelimiter", I am sure you will also have those precise numbers listed...

Edited by AnkH

Share this post


Link to post
Posted (edited)
37 minutes ago, hvw said:

Hi Steve,

Now I am pretty confused as well :). Can you please tell me if my current settings are alright? I have a 60Hz monitor, in NVidia Inspector I have set the framerate limiter to ~29.5, vertical sync in NVI is set to 1/2 refresh rate and triple buffering in NVI is set to on. In P3D vsync is set to off as is triple buffering. The target framerate in P3D is set to unlimited.

Would this be the best way to go or should I use a different setting?

Thanks,
Hans

 

P3D VSync is interpreted by P3D simply for organising the time of the next frame it is not a limiter. So with P3D "VSync"=ON + Unlimited we get roughly the fps of the monitor refresh if the fps can be maintained.

Monitor "vertical sync" is controlled by the desktop so 1/2 vsync in NPI on the P3D profile is ignored.

Settings like those can confuse profiles - always start with profiles set to factory defaults - a big source of errors to not do this. Restore Apply and then make any change to the profile to create a file for NPI to read and will display those with the house icon button.

Instead, if we want a slower P3D VSync we can slow down the monitor.

Or we don't use P3D VSync we use Locked fps on the slider.

The NPI Framelimit will hold back the fps by capping the framerate - P3D VSync=Off Unlimited.

Problems arise with the NPI Framelimit as this can cause half fps or worse conditions with undocked panels and GPS units. These errors can be retained in the Profile so always Restore factory defaults. Don't have NPI active when testing - Apply and close it first.

If the monitor frequency is too high for the P3D VSync, we can try a lower frequency in the Monitor profile but it's tricky to do and also means the mouse pointer drifts around without such immediacy as usual.

 

21 minutes ago, AnkH said:

Yes, I tried both, I do not see any difference. Scroll down further in the dropdown menue inside nVidia Profile Inspector under "Framelimiter", I am sure you will also have those precise numbers listed...

Yes, scroll down to v2 exactly the same results.

 

 

 

 

 

Edited by SteveW
  • Upvote 1

Share this post


Link to post
Posted (edited)
55 minutes ago, hvw said:

Hi Steve,

Now I am pretty confused as well :). Can you please tell me if my current settings are alright? I have a 60Hz monitor, in NVidia Inspector I have set the framerate limiter to ~29.5, vertical sync in NVI is set to 1/2 refresh rate and triple buffering in NVI is set to on. In P3D vsync is set to off as is triple buffering. The target framerate in P3D is set to unlimited.

Would this be the best way to go or should I use a different setting?

Thanks,
Hans

NVI framelimiter 29.5FPS

P3D vsync ON

P3D Triple buffering ON

P3D framerate UNLIMITED

Two more items which may not relate to your setup.

* I have a high end GPU (GTX1080Ti) and CPU (i7 8700K) so I also set NVI SSGS 2X. It just seems to improve the clouds transparency and the whole scene is amazing.

* I have a 4K 28" monitor so in P3D I only use MSAA 4X. I get beautiful anti-aliasing with no impact on FPS and the clouds are amazing.

The only thing I have to watch is the CPU temp even with water cooling. I use a self generated Process Lasso profile which maximizes the cores for P3D and minimizes other processes so it does stress the cores...but hey that is what it was for right...

That GPU :biggrin:, with the 4X MSAA you can throw everything at it and it sits at 40% with low temps.

Shez

Edited by ShezA

Share this post


Link to post

This Vsync information is particular to P3D because it's not using the game mode or "exclusive mode" used by mainstream games. Instead it makes DX11 viewports in desktop windows.

 

4 minutes ago, ShezA said:

* I have a 4K 28" monitor so in P3D I only use MSAA 4X. I get beautiful anti-aliasing with no impact on FPS and the clouds are amazing.

 

Anti-Aliasing and Pixellation in P3D:

The problems of pixelated views is also a concern amongst users of P3D, and has not been addressed correctly in any of the P3D guides I've seen.

The way shaders work was altered in DX10 from DX9 and can be seen in FSX DX10 Preview mode.

This has very little impact, if none, to the pixellation seen in P3D images. DX10 and DX11 use a different arrangement in stenciling transparency - not to be confused with rendering see-through objects.

The problems arise from models scaling within these transparency passes of the renderer. This can be seen by zooming-in to the affected VC dials and controls, they become nicely AA’d then.

Other aircraft for example the B58 (specifically designed with FSX DX10+ in mind) shows a better view of the VC for that reason.

Share this post


Link to post
25 minutes ago, SteveW said:

P3D VSync is interpreted by P3D simply for organising the time of the next frame it is not a limiter.

Thanks a lot, Steve.

 

Best,

Hans

  • Like 1

Share this post


Link to post
51 minutes ago, SteveW said:

...always start with profiles set to factory defaults - a big source of errors to not do this. Restore Apply and then make any change to the profile to create a file for NPI to read and will display those with the house icon button...

Exactly how this works changes slightly from version to version. If the profile still appears in NPI delete it with x button to be sure of starting with a clean plate.

Share this post


Link to post

Hi,

Someone asked what to do if they have a G-SYNC monitor that refreshes at 144Hz.

I stumbled on the fact that best results are in fact achieved globally by reducing the monitor’s refresh rate to 120Hz (using the monitor’s dedicated control) and ensuring that this is matched by the setting in the NCP. 

All fast FPS games/flight sims (except P3D) have VSync and G-SYNC = ON in their respective NCP Profiles and, where available, VSync = OFF in their in-game settings.

I do not use G-SYNC in P3D as it doesn’t work properly when frame rates drop below 30. Instead, I use the Fixed refresh setting in NCP with a frame rate lock of 30fps in-sim. This seems to be producing very fluid results for most of the time providing GPU frame rendering rate output stays at or above 30fps. VSync and TB are both = OFF.

30fps being 120/4 is why I see frame display matching more often than not with my monitor’s refresh cycles and thus produces that much sought after sensation of performance smoothness (fluidity). There is no mouse lag. The added bonus, of course, is far less stress on an expensive GPU which will help ensure its longevity and trouble-free operation.

Edit: in light of what has been discussed I’m thinking of trying the effect of locking at 29.5fps. 

Mike

 

 

Share this post


Link to post

For those that might be interested, here are my current settings:

NVidia Control Panel

Global Settings:

Ambient Occlusion: Off
Anisotropic filtering: Application-controlled
Antialiasing - FXAA: Off
Antialiasing - Gamma correction: On
Antialiasing - Mode: Application-controlled
Antialiasing - Setting: Application-controlled             (entry greyed out)
Antialiasing - Transparency: Off
CUDA - GPUs: All
DSR - Factors: 2.00x (native resolution   
DSR - Smoothness: 33%    
Maximum pre-rendered frames: Use the 3D application setting
Monitor Technology: G-SYNC
Multi-Frame Sampled AA (MFAA): Off
OPenGL rendering GPU: Auto-select                        
(Multi-display/mixed-GPU acceleration: Single display performance mode)
Power management mode: Optimal power
Preferred refresh rate (Ancor Communications Inc ROG PG278Q): Highest Available
Shader Cache: On
Texture filtering - Anisotropic sample optimisation: Off
Texture filtering - Negative LOD bias: Allow
Texture filtering - Quality: Quality
Texture filtering - Trilinear Optimisation: On
Threaded optimisation: Auto
Triple buffering: Off
Vertical sync: Use the 3D application setting
Virtual Reality pre-rendered frames: 1

Prepar3D:

Antialiasing - Mode: Enhance the application setting
Antialiasing - Setting: Use global setting (Application-controlled)    (entry greyed out)
Monitor Technology: Fixed Refresh  (N.B. GSYNC - Application Mode = OFF in NVIDIA INSPECTOR)
(Multi-display/mixed-GPU acceleration: Single display performance mode)
Maximum pre-rendered frames: Use global setting (Use the 3D application setting)
Preferred refresh rate (Ancor Communications Inc ROG PG278Q): Use global setting (Highest available)
Power management mode: Prefer maximum performance
Texture Filtering - Anisotropic sample optimisation: Off
Texture filtering - Negative LOD bias: Clamp
Texture filtering - Quality: High Quality
Texture filtering - Trilinear optimisation: Use global setting (On)
Triple buffering: Use global setting (Off)
Vertical sync: Use the 3D application setting

 

NVIDIA Profile Inspector (Ver 2.13)

Prepar3D:

SLI compatibility bits (DX10 + DX11) - 0x080040F5 (Daylight, Evolve, Monster Hunter Online Benchmark, Ryse: Son of Rome...)

Frame Rate Limiter: Off                        
G-SYNC - Application Mode: Off
Maximum pre-rendered frames: Use the 3D application setting)
Preferred Refreshrate: Highest available
Triple buffering: OFF
Vertical Sync: Use the 3D application setting
Antialiasing - Mode: Enhance the application setting
Antialiasing - Transparency Multisampling: Disabled            
Antialiasing - Transparency Supersampling: Off/Multisampling (8xMSAA in P3D)
Enable Maxwell sample interleaving (MFAA): Off                
Texture filtering - Negative LOD bias: Clamp
Texture filtering - Quality: High quality
Multi-display/mixed-GPU acceleration: Single display performance mode
Power management mode: Prefer maximum performance

Mike

 

 

  • Upvote 1

Share this post


Link to post

Hi,

is there a way possible to turn off vsync in NCP

and just use the one in P3d v4.3

ive tried and does not work 

doesnt keep my FPS at the refresh rate of 25hz 

Share this post


Link to post

You can think of P3D Vsync=On as simply obtaining the refresh frequency of the monitor and makes frames averaged around that rate - it doesn't control Vertical Synchronization of the image that's handled by the Desktop process that's the Vertical Sync in NCP so that's not doing anything in P3D.

Share this post


Link to post
On 4/16/2018 at 10:22 PM, Wanthuyr Filho said:

Nowadays I set the refresh rate back to 60 Hz and set 30 FPS inside NVidia Inspector, which gives me a very smooth experience, even when the FPS falls bellow 30 and the mouse pointer is also very smooth to deal with. Inside P3D the FPS is unlimited, no signs of distracting blurring.

Problem with this is the autogen issue on arrival. I used to have this setup but now set 30fps (29 actually based on @SteveW findings) internally to allow the autogen to load properly at arrival. Still smooth as well. 

Share this post


Link to post
13 minutes ago, SteveW said:

You can think of P3D Vsync=On as simply obtaining the refresh frequency of the monitor and makes frames averaged around that rate - it doesn't control Vertical Synchronization of the image that's handled by the Desktop process that's the Vertical Sync in NCP so that's not doing anything in P3D.

Hi Steve 

thanks for the reply,

i am a little confused , lol I’m. Not sharpest tool in the shed.

when I set my monitor 4K to 25hz and the vertical sync is on in ncp

p3d vsync on tripple buffer on and unlimited FPS

its at 25 FPS in sim

when I switch off vertical sync in 

ncp and with same setting in P3d 

my frames are way up to 50

shouldnt P3d vsync work 

sorry if it is a stupid question 

 

regards

mike

 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now