pippin1811

Speech recognition training not working

Recommended Posts

Hi Dave,

I've just installed Pilot2ATC and everything is working as I would expect, but the speech recognition could do with a bit more training. I tried the process described in pages 66-67 of the manual, but clicking the "train" button does nothing. I do see that the current version has some more options than the manual, I have tried each one. I've gone through 2.5, 2.5.0.1 and just now 2.5.0.2 with the same effect. I have done the 2 standard windows speech training sessions and in those cases the "Welcome to speech recognition voice training" window popped up and the following traingin windows did their usual thing of working through the phrases.

The built in practice phrases in grammer help work well, just the odd P2A specific phrase (or part of) that doesn't always trigger.

I've read the manual carefully to see if I need to enable something to get windows training working - I can't see anything but feel free to correct me.

Thanks for your help and the great program.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Do you have multiple languages installed on your PC?

If so, when you go to Control Panel -> Language, English-US should be at the top as the primary language.

 

One user was having trouble getting the training to work and was able to resolve it by going to

Control Panel -> Language -> Advanced Settings

At the bottom of that page, he unchecked Language for web content option "Don't let websites access my language list."

That option is checked on my system and the training works, but apparently his security settings required him to uncheck it to get it to work.

Dave

 

Share this post


Link to post
Share on other sites

Hi Dave,

 

Thanks for the quick resoponse. While I have several SAPI voices installed, US English is the primary default language at the top of the list.

I tried your advanced settings ideas with no joy, i have even tried running the P2A language trainer directly. Clicking the button does nothing, not even an error popup so not easy to debug. I tried a bunch of other settings in windows voice recognition, did the standard training sessions again with no change. I've run out of ideas ! However since it works on your system it must be something on my setup - Windows 10 Pro fully updated.

I've found the training scripts and have been loading them into notepad and making copies, correcting as I go along. I believe that WSR learns as you correct so that may help a little with some of the phrases.

Share this post


Link to post
Share on other sites

Do you have 11 Speech Training scripts in the Grammar Folder?  An older version had 7 and they were too long for the Trainer and didn't work.

Also, did you try all the different controller types and use the Train button in the Left Hand box of the Language Trainer...not the right hand one?

Are you running the program as Admin (Right click the icon or exe file and select Run as Administrator).  There may be an access issue.

If I think of any other possibilities I'll let you know.

Dave

Share this post


Link to post
Share on other sites

Hi Dave,

Thanks for responding. I do have the 11 scripts, and I have been clicking the training button in the LH box. I tried running the trainer as administrator and pretty much everytning else I could think of. Absolutely no joy. P2A is working and generally the interaction is right first time, just a few phrases where my pronounciation/accent is clearly not what WSR is expecting ! If you think of anything else or can add a debug mode in a future update that might identifiy the problem please let me know.

Great program overall.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now