Recommended Posts

Okay been reading a lot trying to figure this out, but im missing a direct answer, I dont have a backup of my shadersHLSL so am i out of luck with pta??? here are my errors and the files i cant use, I use p3dv4.1

 

Preset C:\PTA\adam_pta261_03_vc_on.ini loaded
Prepar3D 4.1.7 build 22841 detected as target verson
Shaders cache directory found at C:\Users\Sim\AppData\Local\Lockheed Martin\Prepar3D v4\Shaders\
Prepar3D main configuration file found at C:\Users\Sim\AppData\Roaming\Lockheed Martin\Prepar3D v4\Prepar3D.cfg
ERROR: shader file C:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\Cloud.fx is not original Prepar3D shader and can't be used
ERROR: shader file C:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\General.fx is not original Prepar3D shader and can't be used
ERROR: shader file C:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\GPUTerrain.fx is not original Prepar3D shader and can't be used
ERROR: shader file C:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\FuncLibrary.fxh is not original Prepar3D shader and can't be used

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I think the simplest solution is to uninstall then reinstall the P3D *Client*. You may need to reapply any cloud, sky or ground textures (REX or whatever you've used) - so make a note of what your texture sets (or themes) are before the P3D update. The client reinstall won't touch anything else - so all your add-ons, aircraft etc. should remain.

Then try a fresh install of PTA. It should prompt you to create a backup of the shaders folder. It may even do it automatically (it's been ages, so I can't remember).

See how you get on!

Adam.

Share this post


Link to post
Share on other sites

Thanks Adam. I will give it a try. May aswell update to 4.2 while I'm at it. 😊

Share this post


Link to post
Share on other sites
Posted (edited)

Got the same errors after updating to 2.61.  Will uninstall and then download the client.

This is for 4.2.

EDIT:  New client took care of the problem.  Thank you!!

 

Edited by RDY
For P3D type

Share this post


Link to post
Share on other sites

Yep all is fine with me to. Thanks again😊

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now