Recommended Posts

Having trouble using Ortho4XP, have made sure I have downloaded the latest version and tried to make one tile for Lincoln area to see how good it is but not having any joy at all.

 

Have watched You Tube videos on using it and also from here, I am hoping that someone could tell me where this is going wrong.


Firstly tried batch build with build masks and build overlays checked but stops at: Done. The zip archive will now be extracted in the Elevation_Data.Dir

In the DOS Directory it reads FileNotFoundError [Errno 2] No such file or directory ..\\tmp\\N30.zip.

Equally when trying to build just one tile for Lincolnshire I go through:

Step 1 Build Vector Data; that works

Step 2 Build base mesh that works

Step 2.5 Build masks it then says you must first construct the mesh.

Can anyone help as I am really becoming frustrated at not being able to do this!

 

Regards

Nigel.

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Glen, OK I downloaded the area that I require (UK) but how do I use them in relation to Orth4XP.  I am totally new to this platform and this has been my first attempt at using Ortho4XP so would very much appreciate a step by step guide on how to use elevation Data in Ortho4XP.

That is maybe from step one after selecting the Tile I wish to use and also whether to use Batch Mode or go through steps 1 - 3.

Please bear in mind that I am getting on in years and may need simple instructions!!

Many thanks in advance.

 

Regards

Nigel.

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, Nigel said:

Hi Glen, OK I downloaded the area that I require (UK) but how do I use them in relation to Orth4XP.  I am totally new to this platform and this has been my first attempt at using Ortho4XP so would very much appreciate a step by step guide on how to use elevation Data in Ortho4XP.

That is maybe from step one after selecting the Tile I wish to use and also whether to use Batch Mode or go through steps 1 - 3.

Please bear in mind that I am getting on in years and may need simple instructions!!

Many thanks in advance.

 

Regards

Nigel.

.hgt files need to be unzipped to \Ortho4XP\Elevation_data. Ortho4XP will look there for the elevation data. For 1 tile you can go through the steps one by one. For multiple tiles best to use batch but you can use the batch build button for a single tile no problem.

You will also need to build Overlays so that the roads are placed on top of the Ortho.

So I use HD Mesh 

Example of my Ortho4xp.cfg file

Then I just run 

  1. Start Ortho4XP
  2. Click Earth Tile Map button
  3. Select left Shift +left mouse click on area (tile) you want to build
  4. Click Batch build button

full.png

###############################################################################
#                                                                             #
#                  GLOBAL CONFIGURATION FILE FOR ORTHO4XP                     #
#                    for v 1.19, September 12th 2016                          #
#                                                                             #
###############################################################################


##################################################
# Directory location (ADAPT to your settings !!!)
##################################################

# I : To use the build overlay function 
# Should be a level of directory just above Earth nav data
# and without trailing slash.
# For example, on Linux/Mac (remove the next # if applicable)
# default_sniff_dir = '/home/oscarpilote/XP10/Custom Scenery/zzz_HD_v3'
# or on Windows (remove the next # if applicable)
default_sniff_dir = 'F:\HD Mesh 4\zzz_hd_global_scenery4'


# II : The interface "Earth tile map" with right-clic allows you to add/remove 
# symbolic link to tiles in your Custom Scenery dir. 
# For that you need to tell me where it is located !
# For example under windows(remove the next # if applicable)
Custom_scenery_dir="C:\X-Plane-11\Custom Scenery"
#or on Linux/Mac (remove the next # if applicable)
#Custom_scenery_dir="C:\X-Plane-11\Custom Scenery"

# III : if you still wish to rely on gimp for masks (no longer required) otherwise leave as is
use_gimp=False
# use_gimp=True
# If so then indicate its path
# The next could be a good bet for Windows
#gimp_cmd="c:\\Program Files\\GIMP 2\\bin\\gimp-console-2.8.exe "
#This one for OS X
#gimp_cmd="/Applications/GIMP.app/Contents/MacOS/GIMP " 
#And that one for Linux
#gimp_cmd="gimp "
# use_gimp=True
# If so then indicate its path
# The next could be a good bet for Windows
gimp_cmd="C:\Flightsim Applications\GIMP\bin\gimp-console-2.8.exe "


##############################################################################
# To have the interface appear with other default parameters at start up
##############################################################################

build_dir           = "default"     
skip_downloads      = False
skip_converts       = False
verbose_output      = True
clean_tmp_files     = True
clean_unused_dds_and_ter_files = False
default_website     = 'BI'
default_zl          = 16

###############################################################################

min_area   =  0.01                                                            
sea_equiv  =  ['Étang de Berre','Estuaire de la Gironde','Lac Léman']
do_not_flatten_these_list = [] # e.g. ['LFPG','LFMN'] , these will be kept as computed from the elevation file (and probably a bit bumpy)

###############################################################################

curvature_tol       = 3  # Let us be on the very conservative side here, now that batch builders are out !                                                 
no_small_angles     = False

###############################################################################

water_overlay        = True
water_option         = 3       # 1 = X-Plane, 2 = Photoreal only, 3 = Mixed 
ratio_water          = 0.3      
masks_width          = 30      # one unit is approximately 10m
sea_texture_params   = []      # example ['GO2',16], if you wish to use a different provider for the orthos over the sea (zonephoto tiles of french britany were done with this option)
complex_masks        = True    # is set to True the build_masks process will be longer (because mesh from all nearby tiles will be used), but will not "suffer" from boundary effects
use_masks_for_inland = False   # if you want inland water to be treated like sea water (transparency based on a mask rather than fixed)

# This is really a matter of taste, this is just a sample 
# to show the syntax, adapt to your taste. NOTE that it requires 'convert' from Imagemagick (otherwise not needed anymore).
contrast_adjust     = {}   # example {'BI':0,'FR':5,'IT':5}                                                       
brightness_adjust   = {}   # example {'BI':0,'FR':-5,'IT':5}                                                     
saturation_adjust   = {}   # example {'BI':0,'FR':10,'IT':10}                                                      
full_color_correction = {} # example {'CH':' -channel R -level 0%,100%,1.05 -channel B -level 0%,100%,0.97 '}

cover_airports_with_highres = True  # If set to True then a high(er) ZL square zone around each airport (found at Step 1) will be added as a custom zoomlevel
cover_extent = 15                   # extent (km) of the highres zones (added to the bbox containing each airport) 
cover_zl = 17                       # the zoomlevel used for these zones 

###############################################################################

# Additionnal parameters for more experienced users, or if something goes wrong perhaps the answer is here...

meshzl                      = 18    # The maximum ZL which the mesh will support (you can put a lower number if you do not need such zl)
hmin                        = 20    # Smallest triangle side-length
hmax                        = 2000  # Largest triangle side-length
smallest_angle              = 5     # called min_angle in the graphical interface 
water_smoothing             = 2     # increase if you find the rivers are not smooth enough
tile_has_water_airport      = False # Put to True if an airport with a water boundary does not turn flat correctly
keep_old_pre_mask           = True  # If set to True, then old unblured masks (whole_tile.png) are used directly without being regenerated before the bluring is made  (speed increase if set to True)
use_additional_water_shader = False # remainder of a test, which was not that succesful
use_decal_on_terrain        = True  # if you want to use decal on top of the orthophoto, they can look good at small altitude
check_tms_response          = True  # Available as a checkbox in the interface, with it set to True some providers will lead to a dead loop of missed requests if data is not available. On the other hand with it set to False you may end up some times with a few corrupted textures with some white squares. 
use_bing_for_non_existent_data = False # when using providers with local coverage only, if you ask for a zone not covered then Bing will be used there instead
overpass_server_list={"1":"http://api.openstreetmap.fr/oapi/interpreter", "2":"http://overpass-api.de/api/interpreter","3":"http://overpass.osm.rambler.ru/cgi/interpreter"}
overpass_server_choice=str(random.randint(1,2)) # replace with "1" or "2" if you really wish a specific one, default is now to split the burden between "1" and "2" ("3" seems problematic)

 

 

 

 

 

Edited by Glenn_C

Share this post


Link to post
Share on other sites

Hi Glenn, very many thanks and will give it a go sometime this week when time allows.

 

Regards

Nigel.

Share this post


Link to post
Share on other sites
Posted (edited)

Hi Glenn, many thanks for your help and advice, Orth4XP now working.  My fault as I did not know that elevation data was required and also I had to create a folder for Elevation_data and put that into the Ortho folder.

This has made a significant improvement to my scenery and very pleased with it.

 

Again, many thanks.

Regards
Nigel.

 

 

Edited by Nigel

Share this post


Link to post
Share on other sites
On 5/29/2018 at 10:28 PM, Nigel said:

Hi Glenn, many thanks for your help and advice, Orth4XP now working.  My fault as I did not know that elevation data was required and also I had to create a folder for Elevation_data and put that into the Ortho folder.

This has made a significant improvement to my scenery and very pleased with it.

 

Again, many thanks.

Regards
Nigel.

 

 

Sorry I'm a bit late replying but I'm glad I could help. Ortho is fantastic once you get it all setup correctly.

Share this post


Link to post
Share on other sites
Quote

Sorry I'm a bit late replying but I'm glad I could help. Ortho is fantastic once you get it all setup correctly.

Hi Glenn, no problems.  Have been enjoying most of all flying over abandoned WW11 Airfields in Lincolnshire as well as my home.  Ortho certainly gives you a much better opportunity to fly VFR and do visual navigation without using any nav aids.  The towns and villages are all there as well as the roads.   Fantastic!!

Regards

Nigel.

Share this post


Link to post
Share on other sites

Hallo I have something very strange , I use orthoxp4 120b, and have made the tile +52+13 Berlin Germany in zl 18, all photos in the texture file look nice, I found EDDT airport, so I know it's the right scenery,  in the x-Plane log file I see that the scenery is loaded, but when I start X-Plane there is nothing to see of the newly created scenery,

I have tried it now 5 times, also in zl16, but the result is the same.

I have also made +53+12, and +52+ 11, 12, and 13, and they are beautiful, outside of these I have made tiles for large parts of Europa, America, the middle east and asia, one is better than the other, but all of which work well, so it is a mystery to me why +52+13 not want to work, do you have an idea?

best Regards

Peter

Share this post


Link to post
Share on other sites
2 hours ago, peterbuis said:

Hallo I have something very strange , I use orthoxp4 120b, and have made the tile +52+13 Berlin Germany in zl 18, all photos in the texture file look nice, I found EDDT airport, so I know it's the right scenery,  in the x-Plane log file I see that the scenery is loaded, but when I start X-Plane there is nothing to see of the newly created scenery,

I have tried it now 5 times, also in zl16, but the result is the same.

I have also made +53+12, and +52+ 11, 12, and 13, and they are beautiful, outside of these I have made tiles for large parts of Europa, America, the middle east and asia, one is better than the other, but all of which work well, so it is a mystery to me why +52+13 not want to work, do you have an idea?

best Regards

Peter

I've had these issues with certain areas in the US, in the end I just deleted all my Ortho4XP files due to disk space issues, and that I like Xplane11's default scenery and have photoreal scenery in P3DV4 when I want to fly over photoreal.  It is just an odd thing that happened to me sometime with an otherwise excellent program, and it might be a source issue.

John

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now