madfred

Error when attempting to activate PTA

Recommended Posts

I purchased PTA the other day.

When I try to activate it, the log shows a server error.

I use the serial# provided in the email from SimTweaks.

Installed PTA version 2.61
Sim: P3Dv4.2
OS: Windows 10

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

 I've just downloaded PTA 2.61 but I get "Activation Failed" - "Access denied" when I try to enter my serial.

Any ideas?

 

Share this post


Link to post
Share on other sites
7 hours ago, DeeJay06 said:

 I've just downloaded PTA 2.61 but I get "Activation Failed" - "Access denied" when I try to enter my serial.

Any ideas?

 

My problem's solved now - works as normal.  Temporary server issue maybe?  

Share this post


Link to post
Share on other sites

Yes, I was finally able to activate PTA Tool.

There must have been a server issue.
Would have been nice if someone at SimTweaks had responded to my thread here and/or my reported issue through "contact us".

This is the second time I contacted SimTweaks regarding an issue (first one was not being able to complete a purchase).
No matter how good a product is, customer service is certainly the decisive factor on future purchases for me.

Not a good customer service experience at all. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now