Elsmoko

RAAS Quit Working

Recommended Posts

Not sure but I suspect this happened following aircraft update(s) via the Operations Center.

How can RAAS be re-enabled ?  I have the T7, 744 V3, and others.

Thank you,

Ken Boardman

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

First thing is to ensure that the livery you are using has RAAS enabled in the options.  Not all aircraft do.  Then, you can check your dll.xml file in the program data folder to verify you have the RAAS installed.  The entry for it should look like this:

	<Launch.Addon>
		<Name>RAASPRO</Name>
		<Disabled>False</Disabled>
		<Path>.\RAASPRO\RAASPRO.dll</Path>
		<DllStartName>module_init</DllStartName>
		<DllStopName>module_deinit</DllStopName>
	</Launch.Addon>

If it still fails to show up in the P3D menu then submit a trouble ticket and they will get you fixed up.

  • Like 1

Share this post


Link to post
Share on other sites

Thank you for the fast reply Dan; and for helping.  Below is a section of my current DLL.XML file, showing the RAAS lines >

  <Launch.Addon>
    <Name>RAASPRO</Name>
    <Disabled>False</Disabled>
    <ManualLoad>False</ManualLoad>
    <Path>.\RAASPRO\RAASPRO.dll</Path>
    <DllStartName>module_init</DllStartName>
    <DllStopName>module_deinit</DllStopName>
  </Launch.Addon>

Below is a "Dropbox" link to a screen cap showing my FMC Options setting for RAAS:  
 https://www.dropbox.com/s/68mst1nqnqohk6i/MG_156.jpg?dl=0

Below is link to a screen cap showing the pop up for RAAS Pro that is available via the Add-ons pull down menu in my FSX  Accel.

The "Master Switch (On/Off)" block will not remain checked.  And to be honest, I do not know if this "RAAS Pro" is even related

to The PMDG planes,  but I cannot find anything else (RAAS related) to "play with".  I don't believe I have purchased RAAS Pro

at any time and, RAAS Pro may have been installed by another add-on software (ie. Aerosoft Airbuses, etc).

https://www.dropbox.com/s/x4on0nqy0ta70eu/MG_155.jpg?dl=0

I only know that until recently RAAS functioned as normal for my PMDG planes,  and I'd like to fix it (for the PMDG planes ~:)

Best regards,

Ken

Share this post


Link to post
Share on other sites
1 hour ago, Elsmoko said:

Thank you for the fast reply Dan; and for helping.  Below is a section of my current DLL.XML file, showing the RAAS lines >

  <Launch.Addon>
    <Name>RAASPRO</Name>
    <Disabled>False</Disabled>
    <ManualLoad>False</ManualLoad>
    <Path>.\RAASPRO\RAASPRO.dll</Path>
    <DllStartName>module_init</DllStartName>
    <DllStopName>module_deinit</DllStopName>
  </Launch.Addon>

Below is a "Dropbox" link to a screen cap showing my FMC Options setting for RAAS:  
 https://www.dropbox.com/s/68mst1nqnqohk6i/MG_156.jpg?dl=0

Below is link to a screen cap showing the pop up for RAAS Pro that is available via the Add-ons pull down menu in my FSX  Accel.

The "Master Switch (On/Off)" block will not remain checked.  And to be honest, I do not know if this "RAAS Pro" is even related

to The PMDG planes,  but I cannot find anything else (RAAS related) to "play with".  I don't believe I have purchased RAAS Pro

at any time and, RAAS Pro may have been installed by another add-on software (ie. Aerosoft Airbuses, etc).

https://www.dropbox.com/s/x4on0nqy0ta70eu/MG_155.jpg?dl=0

I only know that until recently RAAS functioned as normal for my PMDG planes,  and I'd like to fix it (for the PMDG planes ~:)

Best regards,

Ken

Ken,

 

You should have the master swtitch to ON in order for it to work. If this does not remain ON better check on the RASS forum here in Avsim as they are the developers of that product,

  • Like 1

Share this post


Link to post
Share on other sites

Hi Chris,

  Was hoping since the RAAS was part of the PMDG package (I believe) that PMDG could straighten

this out or suggest a course of action.  I have uploaded a message to FS2Crew / RAAS. 

  Was the RAAS version installed with the PMDG plane for use only with the PMDG plane(s).

Was it a version of RAAS other than the RAAS Pro;  or was it RAAS Pro that was locked  for

aircraft other than PMDG or ...... ? 

Ken

Share this post


Link to post
Share on other sites
3 hours ago, Elsmoko said:

Hi Chris,

  Was hoping since the RAAS was part of the PMDG package (I believe) that PMDG could straighten

this out or suggest a course of action.  I have uploaded a message to FS2Crew / RAAS. 

  Was the RAAS version installed with the PMDG plane for use only with the PMDG plane(s).

Was it a version of RAAS other than the RAAS Pro;  or was it RAAS Pro that was locked  for

aircraft other than PMDG or ...... ? 

Ken

The RAAS usued by PMDG is a locked version of RAAS bind to our aircrafts only. we just install it along side with our planes (777 and 744) any support on issues from that is done by the RAAS developer as it's their own program.

  • Like 1

Share this post


Link to post
Share on other sites
On 6/10/2018 at 4:31 PM, Elsmoko said:

Not sure but I suspect this happened following aircraft update(s) via the Operations Center.

How can RAAS be re-enabled ?  I have the T7, 744 V3, and others.

Thank you,

RAAS might not be detecting runways properly if you haven't run Makerunways after a scenery change.  After you run makerunways, delete ARPT_RWY.dat found in top level PMDG folder/Navdata.  It will rebuild the next time you load the 777 or (new) 747. 

Mike

 

  • Like 1

Share this post


Link to post
Share on other sites

Hi Mike,

   I ran makerunways.exe and deleted the file you suggested.  Tested with the B777 at default DFW airport and still no RAAS.

By switching my Realtek audio / speaker system  from 7.1 to stereo I was (finally) able to get RAAS to pass it's audio

self test,  but it cost me the T7's cockpit warning sounds ~:(  and still no RAAS.   RAAS worked great before with audio

configured to 7.1.  Makes no sense.  FYI, not for sure, but I think the loss of RAAS occurred following updates I performed via

the PMDG Ops Center several weeks ago to multiple aircraft.

  Is RAAS tied to a specific aircraft package,  or if the B777 is installed (including RAAS) will RAAS function with other PMDG

packages also (ie. B744 v3 and NGX) ?

  Also when switching aircraft, does RAAS Pro automatically switch to the correct profile,  or must the profile be manually

switched via the FSX Add-ons pull down menu,  RAAS Pro pop-up?

  It all worked seamlessly before with the B777 and B744 v3 with none of the above ever considered >> very perplexing and frustrating.

Can't remember if it worked with the NGX.  Perhaps it wasn't part of that package.

  Thinking ahead (as a last resort),  if I needed to reinstall any of the packages must my current installation be uninstalled first ?

Or is there a repair option ? Or is it acceptable to install overwriting the current installation ?

Thank you,

Ken

 

Share this post


Link to post
Share on other sites
19 minutes ago, Elsmoko said:

Thinking ahead (as a last resort),  if I needed to reinstall any of the packages must my current installation be uninstalled first ?

Or is there a repair option ? Or is it acceptable to install overwriting the current installation ?

Hi Ken,

In reading your posts over, I have to wonder whether you installed your updates correctly.  AFAIK there may have been one or two updates for the 747 that could be done through the Op Center, but I am almost certain that for the 777 all recent updates have involved uninstalling the previous version (after running the OC to preserve the liveries), downloading a complete installation file, and then reinstalling.  For the most part this has been the procedure for the 747 as well.  So I think you would do better to download the latest versions and then uninstalling/reinstalling.  Even if a "repair" option shows up, I wouldn't count on it working.

I don't remember ever having to fiddle with any separate RAAS settings -- just have to make sure this option is selected for the particular livery.  But I don't have P3D, just FSX, so something might be different there.

Mike

 

  • Like 1

Share this post


Link to post
Share on other sites

Thank you Mike.  I was hoping to avoid a reinstall but I think I will take your suggestion.  And Thank you for

the tips regarding reinstallation procedure.

Ken

Share this post


Link to post
Share on other sites

Hi Mike,

  Do you think I should also uninstall RAAS Pro?   If I do this, I would assume that the fresh reinstall of the T7 or 744 v3 will

also automatically reinstall RAAS Pro also.  Or am I off on this ?

Ken

 

Share this post


Link to post
Share on other sites
3 hours ago, Elsmoko said:

Do you think I should also uninstall RAAS Pro?   If I do this, I would assume that the fresh reinstall of the T7 or 744 v3 will

also automatically reinstall RAAS Pro also.  Or am I off on this ?

I'm not completely sure about this.  Why not try uninstalling the 777 & 747 and see if that removes RAAS in Uninstall Programs as well?  I have never uninstalled RAAS as a separate action.  Something might be different in P3D though.

Mike

  • Like 1

Share this post


Link to post
Share on other sites

OK Mike.  Thank you for the suggestion.  I ask because I looked for (and found) RAAS Pro in my Win 7-64, Control Panel, Programs and Features

list.     I will try what you suggest.

Best regards,

Ken 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now