HansMatthijssen

GTN750 not picking up GS on RNAV/LPV approach (resolved)

Recommended Posts

4 hours ago, ibgregr said:

I'm happy to hear that Reality XP is working directly with Carenado on this.  Or at least that's what it sounded like you were saying a bit earlier????

I do appreciate the effort Reality XP and Carenado is making. Thank you for the temporary fix. I've just been following the glideslope with the VS tab, not real difficult to do, just as accurate!

Edited by golfpilot

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi,

thank you for your understanding!

We've just released GTN v2.5.13 which might prove to further help with the autopilot (or not). Just let me know how it goes this time!

Share this post


Link to post
Share on other sites
11 hours ago, RXP said:

Hi,

thank you for your understanding!

We've just released GTN v2.5.13 which might prove to further help with the autopilot (or not). Just let me know how it goes this time!

Just installed this update. Will get back in a couple hours if it worked or not. I really appreciate your guy's fast response in trying to resolve these issues. It might be on Carenado's end but you guys keep trying and its really awesome!

Share this post


Link to post
Share on other sites

Just installed the new update with the carenado citation and the gtn750 xplane. STILL THE SAME. Nav will not go to On and stays Armed until you disable gtn750 and then re-enable it.

Share this post


Link to post
Share on other sites

Thank you for your kind words and enduring patience. We're actively working with Carenado indeed and I'm trying to setup a similar setup with the same aircraft to further track this down.

Share this post


Link to post
Share on other sites

Thank you Jean-Luc. Whatever you're doing does seem to be improving. I used to have to reset xplane to get gtn750 to work. Now it's just a matter of #1. start xplane and gtn750, #2 imput at least starting point and 1st fix in flightplan #3 Make sure CDI is on GPS #4 Hit the NAV button on autopilot. If it comes up ARM then GTN won't work right. If it comes up ON then everything works OK. If it comes up ARM, then I just have to disable the GTN750 and re-enable it and this has worked for me 100% of the time. I'm sure you'll get it. Keep up the good work.

  • Like 1

Share this post


Link to post
Share on other sites
2 hours ago, sjed said:

Thank you Jean-Luc. Whatever you're doing does seem to be improving. I used to have to reset xplane to get gtn750 to work. Now it's just a matter of #1. start xplane and gtn750, #2 imput at least starting point and 1st fix in flightplan #3 Make sure CDI is on GPS #4 Hit the NAV button on autopilot. If it comes up ARM then GTN won't work right. If it comes up ON then everything works OK. If it comes up ARM, then I just have to disable the GTN750 and re-enable it and this has worked for me 100% of the time. I'm sure you'll get it. Keep up the good work.

This isn't working for me. I can't get it to work at all. No Nav mode for me. It sends info to the HSI but I can't get it out of ARM mode no matter what I do. 

Seems to be isolated to the S550. Works fine in the PC-12. I'm going to reinstall the S550 and see if that gives me any love

Edited by golfpilot

Share this post


Link to post
Share on other sites

It works all the time for me.  When you disable the GTN750, are you going to the RealityXP plugin menu and disabling the gtn750 there?

Share this post


Link to post
Share on other sites
2 hours ago, golfpilot said:

Seems to be isolated to the S550. Works fine in the PC-12. I'm going to reinstall the S550 and see if that gives me any love

Understand that the settings you choose in the RXP configuration menu are aircraft model specific, and that choices may need to vary based on the methods of design chosen by the XP airplane model developer. That is expressly why RXP defines so many of the changes as aircraft model specific. Know it may be frustrating, but try choosing different settings for the aircraft in question.  And solicit help from licensees of the same aircraft.  Avsim provides us with a fantastic user-to-user exchange.  Use it to the max, with reasonable filtering of responses! It pays off!

  • Like 1

Share this post


Link to post
Share on other sites

 I wasn't been able to make any Carenado connect to the AP with 2.15.13.0.  By eliminating the following line in the RealityXP,GTN.ini per aircraft, they all work great now.

[GTN]
; comma separated list of gauges
gauges = GTN_750_1----- (Eliminated this line.)

Share this post


Link to post
Share on other sites
12 hours ago, fppilot said:

Understand that the settings you choose in the RXP configuration menu are aircraft model specific, and that choices may need to vary based on the methods of design chosen by the XP airplane model developer. That is expressly why RXP defines so many of the changes as aircraft model specific. Know it may be frustrating, but try choosing different settings for the aircraft in question.  And solicit help from licensees of the same aircraft.  Avsim provides us with a fantastic user-to-user exchange.  Use it to the max, with reasonable filtering of responses! It pays off!

Ok so everything works now. All I have to do is startup, disable the gtn as the master device, re enable it as the master device. I kept seeing people say they just disable and enable and I was processing that as remove it from the panel and put it back which wasn't working. 

Share this post


Link to post
Share on other sites

I went ahead and pulled the trigger and got the Carenado S340 for X-Plane.  It has the same exact issue as the Citation.  I have to go through the disable/restart flight/enable cycle for it to work properly.  I'm glad there's a workaround but this really needs to be fixed.

Share this post


Link to post
Share on other sites
On 2/18/2019 at 9:00 AM, Adrian123 said:

 I wasn't been able to make any Carenado connect to the AP with 2.15.13.0.  By eliminating the following line in the RealityXP,GTN.ini per aircraft, they all work great now.

[GTN]
; comma separated list of gauges
gauges = GTN_750_1----- (Eliminated this line.)

If I remove that line it gets put right back in there after I load the aircraft...and did not change any functionality for me.

Share this post


Link to post
Share on other sites

I have the same problem with the plane PA28R Arrow III, it does not follow the route in GPS navigation mode.  I have tried several configurations in the options and I can not get it to work well.

 

The same thing happens to me with the Just Flight PA28R Arrow III, it does not follow the flight path in gps mode. I have tried to configure different parameters GTN 750 and it does not work. Sorry to repeat this message in another thread, but I see that I am not the only one who has this problem, I will uninstall GTN for the time being until it is resolved. 

Share this post


Link to post
Share on other sites
18 hours ago, ibgregr said:

If I remove that line it gets put right back in there after I load the aircraft...and did not change any functionality for me.

There has been some discussion on this. Yes, it rewrites it. I apologies.

Share this post


Link to post
Share on other sites
20 hours ago, ibgregr said:

If I remove that line it gets put right back in there after I load the aircraft...and did not change any functionality for me.

Interesting! This line is modified by our plugin only when you select or unselect a GTN in the plugin menu. It tells the plugin which device to automatically open when you load the aircraft.

However if you change this while a GTN device is already open and change/reload aircraft, the plugin with update the file with the then already opened device so that the next time (which in case of reload is immediately after) the same aircraft opens with the same devices again.

This shouldn't have any impact whatsoever with the original topic, but I'll make sure this only gets updated to the ini file when there is a user action (menu) as I think it also saves this setting again when shutting down (i.e. closing a device) but I'm not sure though.

Edited by RXP

Share this post


Link to post
Share on other sites

None of my GTN 750 equipped aircraft are following the flight plan. Until a couple of days ago they were fine, now when I engage autopilot and Nav modes the planes just fly in a straight line, I cannot even select a direct to type waypoint. HDG works fine but Nav / GPS does nothing. Planes include Aerobask 550, Carenado Citation II and the new Carenado S340. 

Share this post


Link to post
Share on other sites

Same here.  I updated the 750 and know the gps will not follow the flight plan at all.  What is going on lol.  Jerome

Share this post


Link to post
Share on other sites

same here. Default baron. Can't even activate the aircraft's AP "NAV"

Share this post


Link to post
Share on other sites

Same here, now FlyJSim 727 V3 and 732 V3 follow route only if try insert some route to default FMS. I think its after RXP update to newest version. 

Share this post


Link to post
Share on other sites

Hi, can you please all confirm which X-Plane version you are running?

Share this post


Link to post
Share on other sites

Hi Jean-Luc. I am using Xplane 11.32r2. RXPGTN 2.5.13

Edited by Adrian123

Share this post


Link to post
Share on other sites

Thank you Adriana. Do you have by any chance an older version of X-Plane like 11.26 to compare?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now