Help! fsx is not installing nethier on steam edition nor default

Recommended Posts

When I try to install FSX steam edition/default they both failed to install due to some type of error. I tried to install the steam edition, but it says that I need steam running, THEN I tried to install the standard It too has problems, this time when I inserted disc 1 this time with some red x error. Can anyone help me?☹️ I'm frustrated that my windows 7 computer keeps acting up and newer versions of windows are not the same.😡

I wish that Microsoft will continue releasing more flight simulators but instead, we were stuck with acceleration for 11 years now since they don't have new versions of flight simulator anymore and they are not compatible on any new version of windows (8, 10 etc.). 🙄

Share this post

Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Posted (edited)

FSX-SE runs fine on Windows 8 and 10. I've installed and flown it on both operating systems.

If I were you, I would reinstall Windows, do a full Windows update, and try FSX-SE again. 

PS you do have to have Steam running to install and use FSX-SE.

Good luck with your travails.

Edited by Henry Street

Share this post

Link to post
Share on other sites

It would help if you told us what exactly the error messages say!

FSX & FSX:SE run on Windows 7, 8, 8.1 & 10!

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now