unc1rlm

Seems P3dv4..2 and 3 doesn't Shut Down

Recommended Posts

I noticed in at least 4.2 and 4.3...that it's not shutting down...Reason I know is when I boot up to latest windows 10 that the start up screen  for P3dv4.3 comes up automatically and chase plane and stb data and UTLive all start there rounds.

Anyone else have this issue? I always give it time before shutting down.the computer. Who wants to run the task manager everytime to make sure something is not running before finally getting to the shut down button..what a drag 😦

Thanks for any helpful advice.

BobM.

 

Edited by unc1rlm

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

I have the exact same issue.

Last night I closed P3D and waited a couple of minutes before shutting off the computer. That helped.

I haven't checked, but it seems like the process continues to run in the background for a while...

Share this post


Link to post

Head into Windows' power options, click the "Choose what the power buttons do", click the "Change settings that are currently unavailable" and then untick "Turn on fast start-up". Microsoft just had a brainfart when they decided people wanted that on by default, restoring applications that weren't shut down when you boot back up. With the above option unticked, it should work as Windows always has.

Share this post


Link to post

I have "Turn on fast start-up" unticked, so that didn't do it for me... But It might have something to do with the file Windows creates. It wasn't that long ago that I diabled it.

I haven't really looked any further into it as it normally isn't a problem. Usually I don't power off the computer immediately after closing P3D... 

Share this post


Link to post

Will try and see what happens...will monitor here to see if any other suggestions. Thanks  RocketDuck!!

BobM.

 

Share this post


Link to post

You're welcome 🙂

If it works, please let us know, because then I have a different problem... Or maybe my computer are just getting so old that it can't even close P3D with a decent framerate....

Share this post


Link to post
21 minutes ago, Sethos1988 said:

Head into Windows' power options, click the "Choose what the power buttons do", click the "Change settings that are currently unavailable" and then untick "Turn on fast start-up". Microsoft just had a brainfart when they decided people wanted that on by default, restoring applications that weren't shut down when you boot back up. With the above option unticked, it should work as Windows always has.

what I used for now...see how it does 🛩️

BobM.

Share this post


Link to post

P3D takes a minute or two to shut down in my experience. Really nothing you can do about it for as far as I know. So, taking into account the title of this thread: No, P3D is shutting down, you're just not giving it enough time before you shutdown the computer.

Share this post


Link to post

I gave up on even using the close program button. I just go right for process explorer and close it that way. Very few things work right on this sim as far as I can tell. I spend 1-6 hours or even more daily just trying to fix things to make a flight. Things work one day, I change absolutely nothing, and the next day, something new is broken. Hoping MSFS 2020 is better but I am not getting my hopes up.

Share this post


Link to post

I suffer the identical problem of P3D not shutting down, and then automatically restarting itself whenever I power on the computer and boot up Windows 10. P3D is NOT in my automatic start-up items.

Since I can't depend on P3D to shut itself down reliably, I always go to the Task Manager and manually shut down P3D myself. Then, when I power on my computer and boot up again, P3D won't automatically start itself.

 

Share this post


Link to post

David that is a bad technique as if you had made any changes to  the P3D settings they may not be correctly saved and then cause a CTD or other problems ,..

 

Jorge

  • Like 1

Share this post


Link to post

Those of you terminating P3D via Task Manager need to sort out your PCs as the problem lies there and not with P3D. In any case this topic was created 15 months ago for an earlier build. I’ve never had a problem closing down P3D although I accept it does take a while to shut down.

Share this post


Link to post

I have a Task Manger pined to start and after shutting down I check that it`s shut, as you can sometime cause a problem by restarting P3D if it`s not fully shut down. also other programmes you may have it will shut down on it`s own.

Edited by rjfry
  • Like 1

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now