n697dt

Joystick doesn't work completely

Recommended Posts

I have a Sidewinder joystick that has worked fine with PMDG in 4.2.  However, since doing a clean install of windows 10 on my SSD and fresh install of P3D 4.3 and PMDG, I can't get my joystick to work other than to pan around and change views.  The flaps will go down one notch and no more.  The throttle doesn't work as well.  I've uninstalled 737NGX and reinstalled with the same problems.  Any ideas out there?  All other planes work fine.  Thanks.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Have you configured the joystick in windows game controller ? If not, that's probably your problem.

Share this post


Link to post
Share on other sites
1 hour ago, n697dt said:

Any ideas out there?

I think you've fallen victim to the "common sim wisdom" out there that asserts that "clean" installs are the Holy Grail of computing and simming, but the reality is that they can cause more issues than they're worth.

Case in point: you removed every setting, calibration, device driver, and so on that your computer ever had, but you seem to be somewhat surprised that you can't just pick right back up with a new sim install like nothing ever happened.

You'll need to go back through all of the steps to install all of your peripherals, the software that comes with them (if it comes with it - my Saiteks, for example, have software to assist in button programming and so on), and then go through all of the menus to set which axis does what. Chances are, you have conflicting axes, as the sim (when you first run it) will attempt to assign axes to all of your interfaces. My old push to talk switch, for example, would activate the brakes if I didn't remove the key binding, because its only button was Button 1, which the sim will assign to the brakes, no matter what the controller is.

Full names in the forum, please: first and last.

Share this post


Link to post
Share on other sites

The thing that is weird is that my default aircraft plus an A2A aircraft work perfect.  It's just the 737NGX that it doesn't work with.  I have a new SSD card, thus the reason for "fresh install."

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, n697dt said:

The thing that is weird is that my default aircraft plus an A2A aircraft work perfect.  It's just the 737NGX that it doesn't work with.  I have a new SSD card, thus the reason for "fresh install."

What are you running besides our aircraft? Camera add-ons? FSUIPC?

EDIT: Again - full names - first and last, please.

Edited by scandinavian13

Share this post


Link to post
Share on other sites

I've installed all of my payware, including A2A Accusim 172, Active Sky for P3D 4.3, Rex soft clouds, and a lot of ORBX scenery.  I haven't installed any freeware or any other aircraft yet.  Everything was working fine.  Then, when I initially installed the PMDG 737NGX, I didn't have my license number saved, and I'm not sure what I initially did when the activation box popped up.  But I did do an uninstall of the 737 with the installer and then installed again.  The only payware I have left to install is the FSFX Immersion.  I do have the latest FSUIPC installed.  I'm wondering if I didn't screw something up when I continued to install without my license number initially.  One thing I just noticed is that I can't find the PMDG Operations Center installed on my computer.  Could it be a corrupt download?

Share this post


Link to post
Share on other sites

Figured it out.  I was downloading the old FSX file and license number instead of my P3D license number.  Everything appears to work now.  Thanks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now