KNOSSOS

xVision for X-Plane 11 : looking for beta testers

Recommended Posts

To Julian, I have only Runways follow terrain contours and Draw per pixel lighting checked in the Misc/Random section. Everything else there is unchecked. Under World Objects, I set Number of cloud puffs 01 and Size of each to 1 (since you can’t specify zero). These are the only areas where I guess there could be a possibility of conflict with Xenviro.

To Julian and onurair, I’ll try to provide a complete list of personal settings in Rendering Options over the weekend and publish it here. Bear in mind, though, that my system surely won't be the same as yours and so copying the settings may not have the same effect.

  • Upvote 2

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Posted (edited)
1 hour ago, Brian Mackie said:

To Julian, I have only Runways follow terrain contours and Draw per pixel lighting checked in the Misc/Random section. Everything else there is unchecked. Under World Objects, I set Number of cloud puffs 01 and Size of each to 1 (since you can’t specify zero). These are the only areas where I guess there could be a possibility of conflict with Xenviro.

To Julian and onurair, I’ll try to provide a complete list of personal settings in Rendering Options over the weekend and publish it here. Bear in mind, though, that my system surely won't be the same as yours and so copying the settings may not have the same effect.

Thank you Brian, very much appreciated. My system runs on coal, i72600K 🙂

Edited by ZKOKQ

Share this post


Link to post
Share on other sites

I was using the Impressive preset for now, and now I'll start using the Impressive for Lua version.

I just want to know, is there more things tweaked using the for Lua version ? I can't find much info on what the lua version does more.

Is this version more heavy on FPS than the other ones ?

Share this post


Link to post
Share on other sites
16 minutes ago, raptor2003 said:

I was using the Impressive preset for now, and now I'll start using the Impressive for Lua version.

I just want to know, is there more things tweaked using the for Lua version ? I can't find much info on what the lua version does more.

Is this version more heavy on FPS than the other ones ?

Yes, *_Lua version of solutions have more tweaks. These adjustments contain in "xV_Impressive - summary script" resource. The script adjusts various private datarefs affecting clouds, lights, shadows, scattering and water.

Keep in mind that solutions with "_Lua" suffix may be used only with FlyWithLua Complete edition or FlyWithLua NG (Next Generation) Edition. (Not FlyWithLua Core edition).

If *_Lua solution significantly drops your FPS, please refer to para #7 of xVision F.A.Q. http://x-vision.pro/faq.html

 

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

vipOI5.jpg

 

For ZKOKQ and onurair, and maybe others, these are my personal settings in the Rendering Options plugin, which is running alongside XEnviro 1.07, XPRealistic and XVision.

We have XP11.25 under Windows 7 Pro on a slightly overclocked i7-6700, with 32GB DDR gaming RAM, ASUS Strix 1080ti, Z170 Gaming 5 motherboard and Samsung 2TB SSD (not the M2), a 34-inch ASUS ROG curved display and only using ortho scenery. Max fps is currently 60 (on a clear XEnviro day). It rarely goes below 30fps, and looks to be averaging about 40. XEnviro with any significant weather is always the major hit. Anecdotally and without any detailed evidence, running XVision seems to have improved the average frame rates. The major point is that the view is now much better.

Road density could probably go to zero, since we're usuing ortho scenery, and don’t need any autogen forests either, so that is all set to zero. I have no idea of the science behind Fade start, Tile LOD bias or Composite far distance bias

An interesting setting has been Shadow cockpit near proxy, now set at 9. At this level, there are no more jaggy unrealistic shadows in the cockpit, and with no fps hit. Pushing Fading of ground textures in the distance beyond 0.9 causes a total loss of scenery and a black, no-instruments cockpit in my Aerobask 550 Eclipse - although (subsequent to taking this screenshot) I found that 0.9 works fine, with no apparent fps hit and clearer scenery.

We’re getting slightly off-topic, and every system is different, but I hope this info is helpful. Most important thing to note is that XVision and the Rendering options plugin seem to live happily together. Reaching your personal balance will take time and tweaking. Advice: Keep careful and constant notes, tweak methodically and always save your last good LUA Rendering scripts somewhere safe as backups.

Now, if some genius can come up with ideas about how to improve the terrible night-lighting when you’re using ortho scenery, I would be a happy chappy. Oh, and some info about the bewildering scientific bits I mentioned earlier...

Edited by Brian Mackie
Fixed missing screenshot issue.

Share this post


Link to post
Share on other sites
11 hours ago, KNOSSOS said:

Yes, *_Lua version of solutions have more tweaks. These adjustments contain in "xV_Impressive - summary script" resource. The script adjusts various private datarefs affecting clouds, lights, shadows, scattering and water.

Keep in mind that solutions with "_Lua" suffix may be used only with FlyWithLua Complete edition or FlyWithLua NG (Next Generation) Edition. (Not FlyWithLua Core edition).

If *_Lua solution significantly drops your FPS, please refer to para #7 of xVision F.A.Q. http://x-vision.pro/faq.html

 

Thank you for the awnser. I switched the clouds to 2048 and will see how it goes.

One thing for sure, I’ll be amazed 🙂

Share this post


Link to post
Share on other sites
5 hours ago, Brian Mackie said:

For ZKOKQ and onurair, and maybe others, these are my personal settings in the Rendering Options plugin, which is running alongside XEnviro 1.07, XPRealistic and XVision

Many thanks Brian. Very much appreciated. Have bookmarked this page so I can refer too it when I upgrade my pc, very soon.

 

Cheers

Julian

Share this post


Link to post
Share on other sites
12 hours ago, Brian Mackie said:

  For ZKOKQ and onurair, and maybe others, these are my personal settings in the Rendering Options plugin, which is running alongside XEnviro 1.07, XPRealistic and XVision.

 

Thank you very much Brian. I'm going to try your settings. We have almost an identical system in CPU, GPU and MoBo wise, so these settings should work out for me too.

Share this post


Link to post
Share on other sites
Posted (edited)

Hello... I want x-vision works with Ultra weather XP 2.4. The faqs say that both are compatibles, but i don't now which options check in each plugin.

Can anyone help me please?

Edited by gonvise

Share this post


Link to post
Share on other sites
5 hours ago, gonvise said:

Hello... I want x-vision works with Ultra weather XP 2.4. The faqs say that both are compatibles, but i don't now which options check in each plugin.

Can anyone help me please?

Hello,

It depends on what parts of plugins you want to use together. I've sent you an e-mail to your request.

Share this post


Link to post
Share on other sites

I am late to the party and have just got xvision…… I cant get it to activate as it says the KEY is incorrect......

 

Share this post


Link to post
Share on other sites
Posted (edited)
On 8/25/2018 at 4:10 PM, Shand359 said:

I am late to the party and have just got xvision…… I cant get it to activate as it says the KEY is incorrect......

 

Did you install the v11.26 beta? If so go back to v11.25, or pay $18. 

http://x-vision.pro/get.html

Edited by deetee

Share this post


Link to post
Share on other sites

Hi,

I am late to the party too. Thanks for your great work!

I am using FSEnhancer package, I was wondering if I could use Xvision in parallel without having the 2 interfering? I was wondering if FSE lua file might modify the same things as xVision?

I mainly want to use the post process effect to get rid of Reshade.

best regards,

Pierre

Share this post


Link to post
Share on other sites
2 hours ago, Pochi said:

Hi,

I am late to the party too. Thanks for your great work!

I am using FSEnhancer package, I was wondering if I could use Xvision in parallel without having the 2 interfering? I was wondering if FSE lua file might modify the same things as xVision?

I mainly want to use the post process effect to get rid of Reshade.

best regards,

Pierre

The two are compatible. FSEnhancer alters datarefs (via LUA files) and includes sky, cloud, and water textures, as well as lighting file modifications. xVision alters shaders and has the option for you to also install cloud, sky,and lighting mods. You can de-select the xVision's texture/lighting mods and just install the shaders to ensure the mod compatibility with FSE, or you can install some of xVision's texture/lighting mods, or mix and match the two however you like (or even use other texture and lighting mods you find). Once you start the program and give the manual a quick read it should be pretty clear. Bottom line is that xVision alters shaders while FSE does not. 

Right now I have a Flight Sim cocktail of xVision shaders and clouds, FSE water and sky Lua mods, 'Cloud Art' LUA files for clouds, and sky textures that are half UltraweatherXP and half default. It all plays nicely together and looks superb IMO. Once you understand the remarkably simple XP file structure it's easy to pick and choose the resources you like the best to make your sim look great. 

rz5BKo5.png

Edited by hmn434

Share this post


Link to post
Share on other sites

Thank you very much, it’s pretty clear for me now.

Best regards,

Pierre

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now