Jump to content
Sign in to follow this  
GSalden

P3Dv4.3 : my observations

Recommended Posts

Guest
26 minutes ago, GSalden said:

And without AI no drop , even after 3h.

As I wrote in my former post , it is like the Sim is up to a certain max level and then drops the framerate

I guess I don't understand this, your statements seem to contradict each other?  Or are you saying you only have FPS problems when your AI traffic add-on is running?  What does "max level" mean?

Cheers, Rob.

Share this post


Link to post
Guest
18 minutes ago, Chris Bell said:

line up has continues errors,
is it possible that "error reporting" is effecting some of the test results as data being collected?

Error reporting caps out a 9999 entries (or is it 999 entries), either way that type of I/O is not significant enough to cause any performance issues.  A SimConnect issue can, a chatty add-on for example (this has happened in the past with several add-on vendors that ultimately got corrected).

I do wish Add-On vendors would stop telling end users to just turn Error reporting off.  I have 999+ entries and they are mostly very simple fixes that the add-on vendor should be doing, not the end user.  Reason why I care about these mostly innocuous Error log entries is that with so many it can mask a real problem and/or make it much harder to find a real problem.  Don't really care if LM's own "aircraft" trigger some of these entries also, two wrongs don't make a right.  LM didn't add Scenery and Content error reporting just to piss off 3rd party vendors, it's exists for their benefit.

It's not like fixing these content errors requires some extensive developer time, 99% of them don't.

Cheers, Rob.

Share this post


Link to post

@Rob Ainscough
i don't think there's mal intent behind third party vendor advising to turn off error reporting,
its a logical step when optimizing a platform; yes its a small IO footprint but every bit counts when optimizing,

just a thought...
even if error reporting log caps at some point;
i doubt error reporting stops as well; nor the missing element call!  
i'd actually anticipate even more chatter when log gets capped :unsure:

does it actually gets capped or goes into FIFO mode?

Edited by Chris Bell

Share this post


Link to post
23 minutes ago, Rob Ainscough said:

I guess I don't understand this, your statements seem to contradict each other?  Or are you saying you only have FPS problems when your AI traffic add-on is running?  What does "max level" mean?

Cheers, Rob.

No contradictions.

Summary :

1 no fps drop without AI traffic

2 no fps drop with 1 screen and AI traffic

3 fos drop with 3 screens and AI traffic

 

Steve explained that if core 0 is at 100% , but needs 110% the framerate drops to compensate. That I understand ; only why is it not happening instantly with AI traffic but happening over a longer time ( see my test results. And why with this version ?

 

Edited by GSalden

Gerard

7940x ( 14 cores ) : 14 cores @ 4.7 - Gigabyte X299 Gaming 7 - 32 Gb G.Skill Trident Z 3200Mhz Cl 14 - Inno3D RTX3090 X4 iCHILL 24 Gb - 1x SSD M2 1800/1800 2TB - 2x  Sata 600 SSD 500 Mb - Thermaltake Level 10 GT case - EKWB Extreme 240 liquid cooling set push/pull - 2x 43” Sony 4K tv's in NVSurround

8700K : all 6 cores @ 5.0 GHz - Asus ROG 370 - 16 Gb 4000 MHz @ 3600 Mhz - Inno3D RTX 3090 X3 iCHILL 24 Gb  - 1x SSD M2 1800/1800 2TB - 2x  Sata 600 SSD 500 Mb - 1x 55” Sony 4K tv

My flightsim vids :  https://www.youtube.com/user/fswidesim/videos?shelf_id=0&sort=dd&view=0

 

Share this post


Link to post

@Rob

In your vid I noticed that you are using Vsync On and probably your monitor is at 30 Hertz. Therefore a framerate of 28-29 continuously.In this way you will never see the fps drop caused by AI.

If you try with Unlimited without Vsync then you will notice the drop over time. Now you are staying below the minimum fps that occurs in the 2 hours time you shot the vid..  

From the moment I started using SLI my framerate went up by 60%, so if I use 24 or 25 Hrtz icw Vsync I probably won't see a fps drop either.

My point however is that AI traffic is causing a fps drop over time and by using a triple view setup I found out. And if the Locked framerate or Unlimited Vsync value is lower than the lowest fps there is in the time the Sim is running , you won't see it...

So people who were using a Locked framerate or Unlimited Vsync that were just below the lowest framerate value with earlier P3D versions , like myself, now see it as the lowest framerate value has become lower by a larger drop..

Solutions :

  • use a lower AI traffic setting
  • set a lower framerate lock
  • use a lower Vsycn/monitor frequency value
  • use lower settings in overall  

 

Regards,

Gerard 

Edited by GSalden

Gerard

7940x ( 14 cores ) : 14 cores @ 4.7 - Gigabyte X299 Gaming 7 - 32 Gb G.Skill Trident Z 3200Mhz Cl 14 - Inno3D RTX3090 X4 iCHILL 24 Gb - 1x SSD M2 1800/1800 2TB - 2x  Sata 600 SSD 500 Mb - Thermaltake Level 10 GT case - EKWB Extreme 240 liquid cooling set push/pull - 2x 43” Sony 4K tv's in NVSurround

8700K : all 6 cores @ 5.0 GHz - Asus ROG 370 - 16 Gb 4000 MHz @ 3600 Mhz - Inno3D RTX 3090 X3 iCHILL 24 Gb  - 1x SSD M2 1800/1800 2TB - 2x  Sata 600 SSD 500 Mb - 1x 55” Sony 4K tv

My flightsim vids :  https://www.youtube.com/user/fswidesim/videos?shelf_id=0&sort=dd&view=0

 

Share this post


Link to post
3 hours ago, GSalden said:

My point however is that AI traffic is causing a fps drop over time and by using a triple view setup I found out. And if the Locked framerate or Unlimited Vsync value is lower than the lowest fps there is in the time the Sim is running , you won't see it...

No, its not. I use a tripple view set up with unlimited frames and without Vsyn checked. As is stated earlier my framerates drops only around 1-2 fps, sometimes it drops at FRA to 20/21 but i comes back again to at least 28 where i started at 30.


System: i9 9900k@4.9 - 32 GB RAM - Aorus 1080ti --- Sim/Addons: P3D v5 + ProSim737
Signature3.png

Share this post


Link to post

Five other cockpit simmers have tested for me and everyone has experienced the framerate drop. No one has seen a drop of 10 fps and then back up by 10 fps.

What addons do you use and what are your settings ?

Why would Unlimited drop to 20 and come back to 30 with you standing at the same spot ? And how come your Unlimited is round number ( 30 ) .

If the Vsync is on and you have monitors at 60 hertz than the drop is 30,20,15. You write from 30 to 20 and back to 30. That looks like what you describe.  You don’t use NVI with Vsync at 1/2 refresh by accident ?

Edited by GSalden

Gerard

7940x ( 14 cores ) : 14 cores @ 4.7 - Gigabyte X299 Gaming 7 - 32 Gb G.Skill Trident Z 3200Mhz Cl 14 - Inno3D RTX3090 X4 iCHILL 24 Gb - 1x SSD M2 1800/1800 2TB - 2x  Sata 600 SSD 500 Mb - Thermaltake Level 10 GT case - EKWB Extreme 240 liquid cooling set push/pull - 2x 43” Sony 4K tv's in NVSurround

8700K : all 6 cores @ 5.0 GHz - Asus ROG 370 - 16 Gb 4000 MHz @ 3600 Mhz - Inno3D RTX 3090 X3 iCHILL 24 Gb  - 1x SSD M2 1800/1800 2TB - 2x  Sata 600 SSD 500 Mb - 1x 55” Sony 4K tv

My flightsim vids :  https://www.youtube.com/user/fswidesim/videos?shelf_id=0&sort=dd&view=0

 

Share this post


Link to post
   On 8/9/2018 at 7:38 PM,  Insurrection_and_Stupiditysaid: 

Hi Gerard

I too have noticed this behaviour but only since upgrading to P3D V4.3 from V4.2.  I still use the same UTL for AI.  It has been driving me crazy.  I´ve disabled each and every addon to do with scenery/texture and still the issue persists.  Now that I have read all the previous replies I am going to disable UTL and see what happens.  Maybe something in V4.3 changed how the sim looks at AI textures.

 

So I disabled UTL and still the same issue.  I did find out that if you use a drop down menu and then come back out then the frame rates increase again but only for about 30 seconds.

Using a GTX760 with the latest drivers.

 

 

now solved, dirty and clogged Video card was dangerously hot, 96C+.  When P3D initially launched my graphic card temp would hover  around the high 70's.  After around a minute my frame rates would drop to ten or less.  Selecting a drop down menu and then going back into the game would give an almost instant rise in frame rates.....but only momentarily.

i started to monitor the graphics card temp and noticed that increasing above 95C would cause this drop in frame rates   I dismantled the PC and found the graphics card fan  as well as the whole interior thick with dust  the graphics card fan was barely moveable.   Good thorough clean and now my graphics card is cooler with no frame rate loss.

 Ken


Complete and utter insurrection

Share this post


Link to post

Addons are in my  sig and the no. were estimates. Watching ai traffic from FRA tower for 2 hours w/o ASP4, airport from AS and traffic from utl


System: i9 9900k@4.9 - 32 GB RAM - Aorus 1080ti --- Sim/Addons: P3D v5 + ProSim737
Signature3.png

Share this post


Link to post
Guest
7 hours ago, GSalden said:

In your vid I noticed that you are using Vsync On and probably your monitor is at 30 Hertz. Therefore a framerate of 28-29 continuously.In this way you will never see the fps drop caused by AI.

FPS ranged from 26-29, averaged about 28 ... this is below my 30Hz Vsync so my CPU/GPU are processing as much as they can, unlimited will always process as much as it can regardless of the Vsync signal from the monitor or via the driver/NI.  If my FPS were pegged solid at 30 FPS then I might agree with you in that I would not be able to determine since I would not know my max potential FPS, but in my test it was always below 30 from start to finish.

Cheers, Rob.

Share this post


Link to post
30 minutes ago, Rob Ainscough said:

FPS ranged from 26-29, averaged about 28 ... this is below my 30Hz Vsync so my CPU/GPU are processing as much as they can, unlimited will always process as much as it can regardless of the Vsync signal from the monitor or via the driver/NI.  If my FPS were pegged solid at 30 FPS then I might agree with you in that I would not be able to determine since I would not know my max potential FPS, but in my test it was always below 30 from start to finish.

Cheers, Rob.

If I use Vsync icw 30 hrtz I see 28.9-29.8 .

With Vsync and 25 Hrtz I see 23.6-24.8..

If you find the time you could try with Uimited without Vsync....

Regards,

Gerard


Gerard

7940x ( 14 cores ) : 14 cores @ 4.7 - Gigabyte X299 Gaming 7 - 32 Gb G.Skill Trident Z 3200Mhz Cl 14 - Inno3D RTX3090 X4 iCHILL 24 Gb - 1x SSD M2 1800/1800 2TB - 2x  Sata 600 SSD 500 Mb - Thermaltake Level 10 GT case - EKWB Extreme 240 liquid cooling set push/pull - 2x 43” Sony 4K tv's in NVSurround

8700K : all 6 cores @ 5.0 GHz - Asus ROG 370 - 16 Gb 4000 MHz @ 3600 Mhz - Inno3D RTX 3090 X3 iCHILL 24 Gb  - 1x SSD M2 1800/1800 2TB - 2x  Sata 600 SSD 500 Mb - 1x 55” Sony 4K tv

My flightsim vids :  https://www.youtube.com/user/fswidesim/videos?shelf_id=0&sort=dd&view=0

 

Share this post


Link to post
Guest
1 hour ago, GSalden said:

If I use Vsync icw 30 hrtz I see 28.9-29.8 .

With Vsync and 25 Hrtz I see 23.6-24.8..

I don't, my setup locks solid to 30 (as it should) with no variation (on my main FS PC with 30Hz monitor) ... assuming I can attain more than 30 FPS which wasn't possible with my graphic settings and add-ons and add-on configurations in the video I made from the same(ish) view point.  But again, I'm running a single monitor with a single GPU (for this test, I do have a 3 Monitor PC I can test with but it sounds like you have more variables that I don't have).

If you run an artificial frame rate limit via NI (say 29.5) then you might get more variants in FPS because it's an artificially "timed" signal via driver so will not be as accurate/consistent as a true Vsync signal coming from the monitor.

I'm not entirely sure how many GPUs you are testing with and how they are configured by monitor(s) and how you managed to test FPS per GPU if not running in surround?  Also, don't you have another variable, ProSim737 software?  Maybe you can provide more details on exactly (skip nothing) your hardware/software is setup?

Cheers, Rob.

Share this post


Link to post

Normal use :

Framerate locked at 24

SSAA 4x

SLI  : 2x 1080 Ti OC 

Views : 2 monitor surround 3925x1080 ( bezel corr ) + 1 seperate view 1920 x 1080 = total 2 views on 3 monitors

7940x : core 0 @ 4.8 Ghz / core 1 @ 4.7 Ghz / core 2-13 @ 4.4 Ghz

Prosim Cockpit suite : Prosim737 + ProsimMCP + ProsimSystems

Gigabyte Aorus Graphics software

Gigabyte Aorus Game Booster

 

Regarding AI software :

Either PSXseeconTraffic or

Traffic Global Early Acces

 


Gerard

7940x ( 14 cores ) : 14 cores @ 4.7 - Gigabyte X299 Gaming 7 - 32 Gb G.Skill Trident Z 3200Mhz Cl 14 - Inno3D RTX3090 X4 iCHILL 24 Gb - 1x SSD M2 1800/1800 2TB - 2x  Sata 600 SSD 500 Mb - Thermaltake Level 10 GT case - EKWB Extreme 240 liquid cooling set push/pull - 2x 43” Sony 4K tv's in NVSurround

8700K : all 6 cores @ 5.0 GHz - Asus ROG 370 - 16 Gb 4000 MHz @ 3600 Mhz - Inno3D RTX 3090 X3 iCHILL 24 Gb  - 1x SSD M2 1800/1800 2TB - 2x  Sata 600 SSD 500 Mb - 1x 55” Sony 4K tv

My flightsim vids :  https://www.youtube.com/user/fswidesim/videos?shelf_id=0&sort=dd&view=0

 

Share this post


Link to post
Guest
9 minutes ago, GSalden said:

SLI  : 2x 1080 Ti OC 

Views : 2 monitor surround 3925x1080 ( bezel corr ) + 1 seperate view 1920 x 1080 = total 2 views on 3 monitors

Prosim Cockpit suite : Prosim737 + ProsimMCP + ProsimSystems

Enough variance there for me to NOT be able to do any Apples to Apples diagnostics.

I've not run SLI surround in a long time ... my understanding is that SLI surround will apply to all "active" monitors (in your case 3).  I'm assuming you aren't using something like ImmersaView?  Or can you assign SLI surround to just two monitors?  If not, then I assume you're assigning SLI surround to 3 monitors and setting up two views, one view covers two monitors the other view covers just one monitor?

Cheers, Rob

Share this post


Link to post

Middle + right monitor is one surround view. Right monitor is a seperate view. So 2 views with 3 monitors .

Both views use the LM Wideview correctiin ( elimination of the fisheye effect )

All 3 monitors connected to the same 1080 Ti . The second 1080 Ti is connected via the SLI bridge. SLI enabled in NC Control panel.


Gerard

7940x ( 14 cores ) : 14 cores @ 4.7 - Gigabyte X299 Gaming 7 - 32 Gb G.Skill Trident Z 3200Mhz Cl 14 - Inno3D RTX3090 X4 iCHILL 24 Gb - 1x SSD M2 1800/1800 2TB - 2x  Sata 600 SSD 500 Mb - Thermaltake Level 10 GT case - EKWB Extreme 240 liquid cooling set push/pull - 2x 43” Sony 4K tv's in NVSurround

8700K : all 6 cores @ 5.0 GHz - Asus ROG 370 - 16 Gb 4000 MHz @ 3600 Mhz - Inno3D RTX 3090 X3 iCHILL 24 Gb  - 1x SSD M2 1800/1800 2TB - 2x  Sata 600 SSD 500 Mb - 1x 55” Sony 4K tv

My flightsim vids :  https://www.youtube.com/user/fswidesim/videos?shelf_id=0&sort=dd&view=0

 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    53%
    $13,405.00 of $25,000.00 Donate Now
×
×
  • Create New...