Jump to content

Sign in to follow this  
John_Cillis

Xplane 11.25 CTD over the High Sierra

Recommended Posts

I find I am getting a CTD in the exact same spot, eastbound and westbound, as I fly a route from Napa to Las Vegas, roughly 20 miles past Yosemite.  I can fly other routes just fine, for hours upon hours.  The log reveals the precise location of the crash:

0:49:53.866 D/ATC: dump_to_log: at: KMMH : Mammoth Yosemite
0:49:53.866 D/ATC: dump_to_log: natc mode: flying_course_true
0:49:53.866 D/ATC: dump_to_log: cmd psi: 246
0:49:53.866 D/ATC: dump_to_log: cmd alt: 17998
0:49:53.866 D/ATC: dump_to_log: cmd kts: 189 (start=0, limit=1.00 thermo=1.01 N1=100 KTAS=175)
0:49:53.866 D/ATC: ==============================================
--=={This application has crashed because of the plugin: [XPLM_PLUGIN_XPLANE]}==--


I am flying the Aerobask Eclipse when the crash happens.  I will try the flight in the Cirrus jet, see if I get the same grief at the same spot and post back to the forum here, just wondering if anyone has seen this.  Xplane11's crash reporter dialog does not even come up.

John

Share this post


Link to post
Share on other sites

Hi John:

Although CTDs are extremely rare with my current FSX-SE setup (compared to "often" in FSX), I have observed very recently that with one Orbx scenery and a specific aircraft, I saw CTD at almost exactly at the same spot (say, left side of the valley at a certain spot). When I changed track to right side of the valley (still between the same mountains), there was no CTD. However, I could not conclude definitively if it was due to a specific aircraft, but indications are that all aircraft do the same at that exact spot.

Yes, let us see if you get this CTD with another aircraft with your setup? Are you using any add-on scenery?

Share this post


Link to post
Share on other sites

Cactus it seems to me that is a problem with the scenery at KMMH the "This application has crashed because of the plugin: [XPLM_PLUGIN_XPLANE]" doenst refer to nothing in particular can be XP itself or any plugin or scenery, do you have any custom scenery at that location...airport? orthos? HD mesh? etc...


Marques

I7-8700k@4.7Ghz | Corsair H110i GTX| MSI GTX 1080 TI | 32GB Ram @3000MHZ| Crucial MX 200 M.2 500GB |Crucial MX200 SATA 500GB | HTC Vive | Samsung 40" 4k TV | Acer Predator 27" G-Sync

Share this post


Link to post
Share on other sites
42 minutes ago, dmarques69 said:

Cactus it seems to me that is a problem with the scenery at KMMH the "This application has crashed because of the plugin: [XPLM_PLUGIN_XPLANE]" doenst refer to nothing in particular can be XP itself or any plugin or scenery, do you have any custom scenery at that location...airport? orthos? HD mesh? etc...

No custom scenery nearby, I have custom scenery for SFO, San Diego, Phoenix, Portland, New York and LAX, tried with the default aircraft too, same crash.  Today I tried the same flight, tried to route myself to Vegas via Fresno, to the west of Yosemite, but as soon as I am past it, ready to crest the Sierras, the crash happens.  Today it happened closer to Mt. Whitney, near Kings Canyon.  One thing I recently did was enabled elevation changes on the runways, do not know if that is a contributor or not.  I've disabled that and will try the flight again.  I can cruise in other places without any real issues.  The crash is consistent with the 11.25 update, it did not happen in previous versions of Xplane11.  I put in a text message to Xplane support and I am waiting to hear back on it, for now I am back to P3DV4 so I can complete long haul flights over the Sierras.

John

Share this post


Link to post
Share on other sites

I was able to get past the crash point, repeated the flight from Fresno to Vegas.  I did two things, either one might have helped.  First I flattened the runways, so that they do not follow the mesh, I turned that option off.  Second, I reduced the data rate that Xplane was sending data out on, to a fraction of a second, in case that was the real culprit on longer flights.  I don't look at the data anyway, have no use for it other than to examine where the crashes were happening.  I wish I could stop disk writes altogether, I don't like a sim thrashing my hard drive while I am flying, reading is enough wear and tear.  Granted hard drives are more robust but data errors still happen and can still cause issues.

John

Share this post


Link to post
Share on other sites
17 hours ago, Cactus521 said:

I was able to get past the crash point, repeated the flight from Fresno to Vegas.  I did two things, either one might have helped.  First I flattened the runways, so that they do not follow the mesh, I turned that option off.  Second, I reduced the data rate that Xplane was sending data out on, to a fraction of a second, in case that was the real culprit on longer flights.  I don't look at the data anyway, have no use for it other than to examine where the crashes were happening.  I wish I could stop disk writes altogether, I don't like a sim thrashing my hard drive while I am flying, reading is enough wear and tear.  Granted hard drives are more robust but data errors still happen and can still cause issues.

John

I repeated the Fresno-Vegas flight from the replay I recorded and it once again went fine, so my problem with the Sierra crash is apparently resolved, will try the Vegas-Napa flight later to confirm since that goes just to the east of Yosemite valley on a direct gps route.  I tend to prefer flying the Aerobask Eclipse since I have live airport charts I created on it using Skyvector to printscreen them and using MSPaint to import them into Xplane11, makes for a realistic looking cockpit with its Aerobask avionics.  The Eclipse is a fine add-on aircraft, fps friendly, intuitive avionics where entering a flightplan with multiple waypoints is a breeze.  They include the avionics suite on their other add-on aircraft, only requires the import of an Xplane10 database to program the avionics with the proper waypoints.

John

Share this post


Link to post
Share on other sites

Hi John,

what exactly are you talking about when you say " I wish I could stop disk writes altogether... "? Why would X-Plane write anything to disk, unless you specify it to do so in the data tab?

As far as I know, my copy of X-Plane isn´t writing anything to disk while I fly...

Cheers, Jan

 

Share this post


Link to post
Share on other sites
10 hours ago, Janov said:

Hi John,

what exactly are you talking about when you say " I wish I could stop disk writes altogether... "? Why would X-Plane write anything to disk, unless you specify it to do so in the data tab?

As far as I know, my copy of X-Plane isn´t writing anything to disk while I fly...

Cheers, Jan

 

Xplane writes out to a log file on the disk during the flight into Xplane's Output folder, where screenshots and videos are stored, and a dump file as well.  If a crash happens, the last snippets of the log can be sent out to Xplane support.  I believe the problem might be with my controller, because I can create the crash at a certain point if I try to pan around.  Under Xplane's settings you can set the data rate that writes are sent at.  I imagine it is useful for support, also there are some metrics written regarding performance of the aircraft and nearby AI.  You really have to dig into Xplane, there is alot of interesting things going on in the background monitoring your flights.

John

  • Upvote 1

Share this post


Link to post
Share on other sites
4 hours ago, Cactus521 said:

I can create the crash at a certain point if I try to pan around

This is exactly what makes my X-Plane crash as well. If I pan around a lot, I'll get a CTD for no apparent reason. It happens anywhere, even over default scenery. 

I've reported this as a bug, but it's pretty hard since I can't really give enough information about it


Hardware: i7-6700HQ, 32GB DDR4,NVIDIA GTX 1070, 1TB 7200 HDD, 1TB SSD, Oculus Rift.

My sims in order of use: X-Plane 11, P3D v4.4, Aerofly FS 2, DCS World).

 

Share this post


Link to post
Share on other sites
11 hours ago, tonywob said:

This is exactly what makes my X-Plane crash as well. If I pan around a lot, I'll get a CTD for no apparent reason. It happens anywhere, even over default scenery. 

I've reported this as a bug, but it's pretty hard since I can't really give enough information about it

Just today I managed to fly from Salt Lake City to Phoenix in the Eclipse.  I love the route, as it overflies the Grand Canyon.  I did not have a CTD, I avoided panning around a lot with my joystick.  I have always suspected that Xplane's system is hard on flight gear, I bought cheap joysticks which did not work well, they were jittery, the polling was different vs. P3D where my joystick is always an extension of my thoughts, ease of use.  My Logitech works better, is a hefty stick, feels quite like the stick in the Allegro trainer I used to fly in real life.  Logitech makes a good flight product, and you can map the buttons for trim and flaps, it's wonderful.  I hope this can be looked at, I do not like it when Xplane gets twitchy and hammers my external devices, luckily that does not happen often and I can fly some hours in the sim, in real time, like today.

John

Share this post


Link to post
Share on other sites

I was able to hone in on my CTD issue--simply the AI, or quantity I had of it.  Ground traffic and static AI is not an issue, just AI in flight, especially in the flight levels I believe.  I am going to try to fly with reduced AI, no jets, just low level props, and see how this plays out.   Performance spiked quite a bit in the sim, whereas I would see stutters when panning before, they were all gone and P3D fluid.

John

Share this post


Link to post
Share on other sites

Cactus, its good to see your thoughtful , systematic , troubleshooting reports .

Sometimes when posters report problems there is little in the way of follow up information and its unclear if the problem is fixed or remains . 

Share this post


Link to post
Share on other sites
5 hours ago, fireone said:

Cactus, its good to see your thoughtful , systematic , troubleshooting reports .

Sometimes when posters report problems there is little in the way of follow up information and its unclear if the problem is fixed or remains . 

Thank you, and the problem is fixed, it was indeed the quantity of AI I had, probably causing a memory problem when I panned and too much AI came into view.  I am back to hour upon hour of flying with less AI, but more than adequate to add realism and immersion to my flights.  Took a two hour flight from Seattle to Reno this morning in the Eclipse, was a fine flight and I saved the recording of it so I can replay it again.  Love the route, watching the Cascade volcanoes and the transition from mountain scenery, to farmland over California's central valley, back to mountains for the descent into Reno.  I am happy I switched from Ortho back to Xplane's extremely accurate landclass, autogen and mesh, as compared to what I see when I fly P3D, where I do use MSE's photoscenery so I have that option when I wish to see it.  Both sims offer the best of both worlds, although the Aerobask Eclipse for Xplane11 is my favorite add-on between both sims with its great autopilot and avionics.

John

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...