Jump to content
Sign in to follow this  
Sky Prince

FSX Error 1722 and 1603. What is the solution?

Recommended Posts

Can somebody help me, please?

I did a factory reset and tried to reinstall FSX. I am, however, unable to install it. I keep getting error 1722 and roll back 1603. I have spent hours looking for a solution online and nothing worked. I thought I would ask here for help as a last resort.

MicrosoftKB928080 cannot be found anywhere. None of the files can be found online; download links do not work. I do not know what else to do.

Share this post

Link to post
Share on other sites

Jude Bradley
Beech Baron: Uh, Tower, verify you want me to taxi in front of the 747?
ATC: Yeah, it's OK. He's not hungry.

X-Plane 11 X-Plane 12 and MSFS2020  🙂

System specs: Windows 11  Pro 64-bit, Ubuntu Linux 20.04 i9-9900KF  Gigabyte Z390 RTX-3070-Ti , 32GB RAM  1X 2TB M2 for X-Plane 12,  1x256GB SSD for OS. 1TB drive MSFS2020

Share this post

Link to post
Share on other sites

Since "Hey Jude's" download link is deader than a doornail,  here is a link to one that works. I did not see this anywhere in our File Library.


Charlie Aron

Awaiting the new Microsoft Flight Sim and the purchase of a new system.  Running a Chromebook for now! :cool:



Share this post

Link to post
Share on other sites

Resetdll did not work for me, so....I installed using compatibility mode (Vista), uninstalled FSX only (not Acceleration), reinstalled FSX (Disk 1 & 2 only), prompted for license key and tested that it worked.

I then installed Acceleration, it did not ask for license key.

I did the following Regedit, rebooted, restarted FSX and everything worked fine.

This was after a factory reset "uninstalled" most of my programs (apps).

Okay. It seems like this did the trick:

1. run regedit (Windowskey +R)
3. After you find the folder, double-click Upperfilters on the right side.
4. Change the value from 0 to PartMgr and/or remove any other settings and then click OK.
5. Close Registry Editor
6. Start FSX/Accel and you should get the registration wizard.

The next time you launch FSX, you'll have the prompt to enter the ACCELERATION product key.

Closed/Opened a few times, and all seems well.


Bob "roadwarrior" Werab

Config: ASUS Prime Motherboard, RYZEN 5, 32 GB Ram, Radeon RX5700 XT, 2 TB SSD

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online

  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Create New...