Sudden network issue between two Win10 machines

Recommended Posts

I have two computers both running Win10 Pro on my home network.  One computer is named FS-COMP (Gigabyte) and the other is named Gauges (Asus).  They are both home built and work well.  I have several shared locations on both FS-COMP and Gauges and all shared locations were accessible without issue on each computer until a week ago.  The event that seemed to trigger the problem was putting a powered USB 3.0 PCIE card into FS-COMP, but I can’t imagine why.  The PCIE card loaded the same drivers as other USB HID’s in Device Manager.  I removed it as it did not solve a USB problem I was having with a piece of flight sim hardware.

The Issue:

On FS-COMP:  Via Windows Explorer, \\Gauges shows on the network and all \\Gauges shared locations are selectable via FS-COMP.

On Gauges:  Via Windows Explorer, \\FS-COMP shows on the network but shared location are not accessible by selecting \\FS-COMP.  I apparently don't know how to attach a pdf nip from the web, but the Network Error reads Windows Cannot Access \\FS-COMP.

However, if I type the \\FS-COMP network location into Windows Explorer as \\ then that location shows on the network And I Can access shared \\FS-COMP locations via the \\

So, \\Gauges can access \\FS-COMP via \\ but cannot access \\FS-COMP via the \\FS-COMP icon that shows in the network section of Windows Explorer.  There appears to be a name resolution problem but I can’t identify it.  I have been through all the standard debugging steps without luck (drive sharing, permissions, network discovery etc etc.)

I would be thankful for any suggestions.  Thanks.



Share this post

Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Bruce,

I had a similar issue between a work laptop and my home network that 'just started happening' but i assume it was an update somewhere along the line.

After searching i came across the following windows forum post:

The solution that worked for me was the services suggestion at the bottom of page 2, namely to start the Function Discovery Provider Host and Function Discovery Resource Publication services. I dont know if these were previously active or what the effect of leaving then enabled is.


Share this post

Link to post
Share on other sites

This what seems to be working for me...


This will most likely remedy your issue as it did for me. If not I wish you all the best.

1) Open "Control Panel"

2) Open "Network and Internet"

3( Open "Network and Sharing Center"

4) Open "Advanced sharing settings"

In your current network "profile" look for "Turn On Automatic Setup Of Network Connected Devices" and REMOVE the check from it.

5) Save the change and disable the network adapter and re-enable it.

Look for the change in File Manager.

Share this post

Link to post
Share on other sites


My problem is solved thanks to a kind fellow at the forum. He suggested the issue was with the Lmhost file in C:\Windows\System32\drivers\etc.

I first looked at the Host file in the same location as Lmhost and both computers were listed in the file, however, the IP address for FS-Comp was wrong. I can only guess that for some reason a couple weeks ago FS-Comp was dynamically allocated a new LAN address (didn't have a fixed IP) and that’s when things came to a screeching halt. So I deleted all my router fixed ip’s (I do run in dhcp mode) and re-added them with the correct names and addresses. Then I changed one digit in the FS-Comp DNS address in the Host file and I was instantly up and running. Both computers talking, WideFS connected and the JET45 gauges were up and running.

Of all the postings I made about the issue, and after reading countless articles and trying the same old things over and over, this simple and elegant fix did the job. I would have never figured it out.



Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now