eslader

Graphics are smooth, except when I move the camera in VC.

Recommended Posts

Pretty much what the title says. Everything's smooth externally, but if I "turn my head" in the VC the motion is jerky. If I'm using mouselook, it's jerky enough that I tend to overshoot where I'm trying to point at. If I'm using TrackIR, it's very annoying.

Doesn't matter what plane I'm flying - it's just as jerky in a PMDG high-res cockpit as it is in a default plane. Is this normal behavior - i.e. is it harder on system resources to look around in the cockpit than it is to just fly around without playing with the camera - or is there something wrong? Of possible relevance, if I switch to an external view, I can pan around completely smoothly.

 

 

Edited by eslader

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Yea you're dealing with updates on all the instruments so that makes sense that you can get some frame drops in the vc. What are your system specs?

Share this post


Link to post

Ryzen 7 2700X OC'd to 4.1ghz, 16g ram, GTX760. 

 

I know, the vidcard is bad - A 1080Ti is on the way, but I'm guessing prices are going to come down more as the 2x series cards hit stores, so I'm holding off for a couple more weeks.

 

 

Share this post


Link to post

If you are using a 60HZ monitor, look at your FPS.  If in VC your FPS is lower than 60 and in outside view the FPS in higher than 60 (higher than your monitor refresh rate), that's why you are having jerky panning. It's because your FPS is lower than your monitor refresh rate.

Mike

Share this post


Link to post

To get a smoother experience it helps to try and match your framerate to that of the monitor. To do this, access your monitor's settings and customise the refresh rate by locking it to 30Hz. This may or may not be possible. Then lock your internal framerate to 30. You can do some testing, it may be better at 31. Tick Vsync internally. Don't use any external graphics settings like Nvidia Inspector, set all your graphics settings in P3D. Never use 8SSAA, either 4SSAA or 8MSAA. With you card it is likely to be best at 8MSAA or 4MSAA. A lot of this is going to be dependent on your monitor. Also if you are using Track IR, then there are settings in there which you can try changing too, but the main benefit will come from matching the refresh rate of your monitor 😊

Edited by Rockliffe
  • Like 1

Share this post


Link to post
3 hours ago, Rockliffe said:

To get a smoother experience it helps to try and match your framerate to that of the monitor. To do this, access your monitor's settings and customise the refresh rate by locking it to 30Hz. This may or may not be possible. Then lock your internal framerate to 30. You can do some testing, it may be better at 31. Tick Vsync internally. Don't use any external graphics settings like Nvidia Inspector, set all your graphics settings in P3D. Never use 8SSAA, either 4SSAA or 8MSAA. With you card it is likely to be best at 8MSAA or 4MSAA. A lot of this is going to be dependent on your monitor. Also if you are using Track IR, then there are settings in there which you can try changing too, but the main benefit will come from matching the refresh rate of your monitor 😊

I completely agree!

Greg

Share this post


Link to post

Thanks for the ideas - I'll try 'em tonight and report back!

 

Share this post


Link to post
6 hours ago, Rockliffe said:

Also if you are using Track IR, then there are settings in there which you can try changing too,

This is interesting.What  settings are you referring to ? I might have to test myself....

 

Thanks.

Share this post


Link to post
Just now, MindYerBeak said:

This is interesting.What  settings are you referring to ? I might have to test myself....

 

Thanks.

In the basic settings page > motion control > speed and smoothness

Share this post


Link to post
Just now, Rockliffe said:

In the basic settings page > motion control > speed and smoothness

I have speed at 0.7 and smooth at 50. Which one do you suggest I start playing with ? The motion gets also jerky here if i turn my head like the op.

Share this post


Link to post

I suggest you experiment. I have to say, I have not found a great deal of influence with these settings in regards to the stuttering, they only play a small part. The major part is affected by the hardware and P3D settings, as with any other aspect. Some people forget, you can have the greatest, fastest, most high performing PC, but with the wrong settings you'll still be chasing your tail. You could try adding Fiber_Frame_Time_Fraction=0.01 to the [MAIN] section of your cfg file, if you have not already done so. This could reduce stutttering greatly. However, it will be at the expense of scenery loading, but in my experience, it does not have any affect on scenery loading, only on fps and smoothness. This advice is being given purely based on my own experience, but it may be helpful to you.

Share this post


Link to post
4 hours ago, Rockliffe said:

In the basic settings page > motion control > speed and smoothness

That's set properly - it's totally smooth in the spherical holodeck thing TrackIR shows for calibration, so the motion tracking is working as it should.

I'm actually cheating on this thread now -  stumbled on a great open box deal for a new 1080Ti , so I suspect things will run much smoother once I throw the new card in tonight. 😉

 

 

Share this post


Link to post
1 hour ago, eslader said:

That's set properly - it's totally smooth in the spherical holodeck thing TrackIR shows for calibration, so the motion tracking is working as it should.

I'm actually cheating on this thread now -  stumbled on a great open box deal for a new 1080Ti , so I suspect things will run much smoother once I throw the new card in tonight. 😉

 

 

I too have the 1080ti. It is a wonderful beast 😄

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now