Sign in to follow this  
FSCockpit_eu

Simconnect setup problem

Recommended Posts

Hello,

 

Because I am not able to start PSXSeecon on main pc, I had to use Simconnect, but after editing simconnect.xml on main pc, I get this error:

FLIGHTPLANSFOLDER=flightplans
AI_FLIGHTPLAN=0
LATERAL_RANGE=40
GROUND_TRAFFIC=0
AUTO_MODE=0
MAX_LIVE_AIRCRAFT=200
COLLISION_DET_AIR=0
COLLISION_DET_GND=1
LOG_POSITIONING=0
LOG_TAKEOFF=0
LOG_LANDING=0
LOG_PARKING=0
**************************************************

09:25:06 Initializing server at port 10747
09:25:06 Waiting for FlightSimulator to connect ...
09:25:06 Waiting for RealTraffic to connect to PSXseeconTraffic ...
09:25:07 RealTraffic connected
09:25:30 Waiting for FlightSimulator to connect ...
09:25:53 Waiting for FlightSimulator to connect ...
09:26:16 Waiting for FlightSimulator to connect ...
09:26:39 Waiting for FlightSimulator to connect ...
09:27:02 Waiting for FlightSimulator to connect ...
09:27:25 Waiting for FlightSimulator to connect ...
09:27:49 Waiting for FlightSimulator to connect ...
09:28:12 Waiting for FlightSimulator to connect ...
09:28:35 Waiting for FlightSimulator to connect ...
09:28:58 Waiting for FlightSimulator to connect ...
09:29:21 Waiting for FlightSimulator to connect ...
09:29:44 Waiting for FlightSimulator to connect ...
09:30:08 Waiting for FlightSimulator to connect ...
09:30:31 Waiting for FlightSimulator to connect ...
09:30:34 Waiting for FlightSimulator to connect ...
09:30:37 Waiting for FlightSimulator to connect ...
09:30:40 Waiting for FlightSimulator to connect ...
09:30:43 Waiting for FlightSimulator to connect ...
09:30:47 Waiting for FlightSimulator to connect ...
09:30:50 Waiting for FlightSimulator to connect ...
09:30:53 Waiting for FlightSimulator to connect ...
09:30:56 Waiting for FlightSimulator to connect ...
Error: Exception in gf_connectToSim_as_thread
09:31:20 Flight Simulator no longer connected, PSXseeconTraffic will stop ...
Thu Oct 18 09:31:30 2018

 

What am I doing wrong?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

3 hours ago, FSCockpit_eu said:

Hello,

 

Because I am not able to start PSXSeecon on main pc, I had to use Simconnect, but after editing simconnect.xml on main pc, I get this error:

FLIGHTPLANSFOLDER=flightplans
AI_FLIGHTPLAN=0
LATERAL_RANGE=40
GROUND_TRAFFIC=0
AUTO_MODE=0
MAX_LIVE_AIRCRAFT=200
COLLISION_DET_AIR=0
COLLISION_DET_GND=1
LOG_POSITIONING=0
LOG_TAKEOFF=0
LOG_LANDING=0
LOG_PARKING=0
**************************************************

09:25:06 Initializing server at port 10747
09:25:06 Waiting for FlightSimulator to connect ...
09:25:06 Waiting for RealTraffic to connect to PSXseeconTraffic ...
09:25:07 RealTraffic connected
09:25:30 Waiting for FlightSimulator to connect ...
09:25:53 Waiting for FlightSimulator to connect ...
09:26:16 Waiting for FlightSimulator to connect ...
09:26:39 Waiting for FlightSimulator to connect ...
09:27:02 Waiting for FlightSimulator to connect ...
09:27:25 Waiting for FlightSimulator to connect ...
09:27:49 Waiting for FlightSimulator to connect ...
09:28:12 Waiting for FlightSimulator to connect ...
09:28:35 Waiting for FlightSimulator to connect ...
09:28:58 Waiting for FlightSimulator to connect ...
09:29:21 Waiting for FlightSimulator to connect ...
09:29:44 Waiting for FlightSimulator to connect ...
09:30:08 Waiting for FlightSimulator to connect ...
09:30:31 Waiting for FlightSimulator to connect ...
09:30:34 Waiting for FlightSimulator to connect ...
09:30:37 Waiting for FlightSimulator to connect ...
09:30:40 Waiting for FlightSimulator to connect ...
09:30:43 Waiting for FlightSimulator to connect ...
09:30:47 Waiting for FlightSimulator to connect ...
09:30:50 Waiting for FlightSimulator to connect ...
09:30:53 Waiting for FlightSimulator to connect ...
09:30:56 Waiting for FlightSimulator to connect ...
Error: Exception in gf_connectToSim_as_thread
09:31:20 Flight Simulator no longer connected, PSXseeconTraffic will stop ...
Thu Oct 18 09:31:30 2018

 

What am I doing wrong?

Could you please post your complete log file, not just part of it. Thank you.

Share this post


Link to post
Share on other sites
13 minutes ago, FSCockpit_eu said:

 

it is complete file.

Just made ctrl+a, ctrl+c then ctrl+v

No, it is not... It should start with

"Thu Oct 18 16:10:33 2018 (utc)"      (or something like that)

and so on...

 

Share this post


Link to post
Share on other sites

Ok,

Here we go:

Thu Oct 18 09:24:36 2018 (utc)
version 11.9
PSXseeconTraffic (64 bit)
for Prepar3D v4
9991 airports were read from airport_data\airports.xml

******************* Parameters *******************
VERSION_CHECKED_AT='1b '6ouzo
ALWAYS_ON_TOP=0
STATUS_LINE=1
LIVE=1
LIVE_IF_USER_AIRBORNE=0
UPS=25
VMRGENERATOR=FLAi
HEAVY_AIRCRAFT=1
MIDDLE_AIRCRAFT=1
LIGHT_AIRCRAFT=0
HELICOPTERS=0
PARKEDFOLDER=parked
PARKING_OVERRULED=0
PARKING_OVERRULED_PERC=0
PARKING_LIMITED=0
FLIGHTPLANSFOLDER=flightplans
AI_FLIGHTPLAN=0
LATERAL_RANGE=40
GROUND_TRAFFIC=0
AUTO_MODE=0
MAX_LIVE_AIRCRAFT=200
COLLISION_DET_AIR=0
COLLISION_DET_GND=1
LOG_POSITIONING=0
LOG_TAKEOFF=0
LOG_LANDING=0
LOG_PARKING=0
**************************************************

09:24:36 Initializing server at port 10747
09:24:36 Waiting for FlightSimulator to connect ...
09:24:36 Waiting for RealTraffic to connect to PSXseeconTraffic ...
Error: Exception in gf_connectToSim_as_thread
09:24:37 Flight Simulator no longer connected, PSXseeconTraffic will stop ...
09:24:37 RealTraffic connected
Thu Oct 18 09:24:46 2018
 

 

Hope this will help

Share this post


Link to post
Share on other sites

You should change parked into parked_default otherwise you will run into problems after you have solved your SimConnect problem.

It looks like you have not set up SimConnect correctly, study section 2.2 of the Manual carefully.

EDIT: and check that you have loaded an aircraft as vehicle, try one of the Beech Baron's  first.

Edited by kiek

Share this post


Link to post
Share on other sites

Hi,

 

I use PARKED Folder instead of PARKED_DEFAULT because I generated data with ParkPosGenerator.

We always use ProSim A320 or Jeehell FMGS A320 flight model

Below is Simconnect.cfg from pc running PSXSeecon Traffic

[SimConnect]
Protocol=IPv4
Address=192.168.1.152
Port=29764
MaxReceiveSize=8192
DisableNagle=1

 

This is simconnect.dll from pc runing P3D

<SimBase.Document version="1,0" Type="SimConnect">
  <Descr>SimConnect</Descr>
  <Filename>SimConnect.xml</Filename>
  <Disabled>False</Disabled>
  <SimConnect.Comm>
    <Disabled>False</Disabled>
    <Protocol>IPv4</Protocol>
    <Scope>global</Scope>
    <Address>192.168.1.178</Address>
    <MaxClients>64</MaxClients>
    <Port>9017</Port>
    <MaxRecvSize>4096</MaxRecvSize>
<DisableNagle>True</DisableNagle>
</SimConnect.Comm><SimConnect.Comm>
    <Disabled>False</Disabled>
    <Protocol>IPv4</Protocol>
    <Scope>local</Scope>
    <Address>127.0.0.1</Address><MaxClients>64</MaxClients>
    <Port>9017</Port>
    <MaxRecvSize>4096</MaxRecvSize>
    <DisableNagle>True</DisableNagle>
</SimConnect.Comm>
<SimConnect.Comm>
    <Disabled>False</Disabled><Protocol>IPv4</Protocol>
    <Scope>global</Scope>
    <Address>192.168.1.152</Address>
    <MaxClients>64</MaxClients>
    <Port>9017</Port>
    <MaxRecvSize>4096</MaxRecvSize>
    <DisableNagle>True</DisableNagle>
</SimConnect.Comm>
<SimConnect.Comm>
    <Disabled>False</Disabled>
    <Protocol>IPv4</Protocol>
    <Scope>global</Scope>
    <MaxClients>64</MaxClients>
    <Address>192.168.1.152</Address>
    <Port>29764</Port>
    <MaxRecvSize>8192</MaxRecvSize>
    <DisableNagle>False</DisableNagle>
  </SimConnect.Comm>
</SimBase.Document>

 

Do You see anything wrong in those settings?

Thank You for Your help.

I want to say one thing, I really love Your software, it brings a lot of 'life' to the cockpit, therefore I offer it to my customers as a free update (I mean, they do not pay me at all for it)

Share this post


Link to post
Share on other sites
5 hours ago, FSCockpit_eu said:

Do You see anything wrong in those settings?

I want to say one thing, I really love Your software, it brings a lot of 'life' to the cockpit, therefore I offer it to my customers as a free update (I mean, they do not pay me at all for it)

No, except you write simconnect.dll, i assume you meant SimConnect.xml.

Did you put Simconnect.cfg in the PSXseeconTraffic folder, as indicated in the Manual?

I really recommend to try the Beech baron first, your aircraft may cause problems (don't expect that), just to be sure.

 

About redistribution: Please do not do that!

I would like users to download my software fro my site. That gives me a better statistics about the number of downloads..

 

Share this post


Link to post
Share on other sites

Yes, it is xml.

I do not redistribute, I just tell them about Your software, so they know where to download it.

Sometime I only help during setup.

Anyway, they have to buy Real traffic license themselves

Share this post


Link to post
Share on other sites
5 minutes ago, FSCockpit_eu said:

Yes, it is xml.

I do not redistribute, I just tell them about Your software, so they know where to download it.

Sometime I only help during setup.

Anyway, they have to buy Real traffic license themselves

Aha, good thank you!

FYI , I have no commercial relationship with RealTraffic, we are completely seperate.

Edited by kiek

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this