Jump to content

Sign in to follow this  
Johnwag

Hat Switch panning

Recommended Posts

I've not found how to set up the hat switch on my Saitek Pro Flight yoke to pan like it did prior to installing Chase plane.

In P3D v4, I've unselected the hat switch for panning.

In CP Control Assignments next to pan left and pan right under axis, when I click on 'blank' in the window that comes up, it doesn't recognise when I move the hat switch on the yoke - it's not making the assignment. It will recognise

one of the Saitek throttle quadrant levers and it recognises if I turn the yoke (roll) but it can't recognise the hat switch.

The hat switch was working fine yesterday before I installed CP.

If I close CP or not load it when I start P3D, and assign the hat switch as previous then it still no longer works to pan the view.

Perhaps by chance the hat switch button has failed at the same time as I installed CP???

I've tried to find an answer but may have missed it in the documentation.

Help would be appreciated because now I don't think I can use the sim.

Thanks

John 

 

Share this post


Link to post
Share on other sites

I think I found what I needed to do....

It appears that CP didn't recognise my Saitek Pro Yoke until I had moved the control column - i.e. left/right/nose down/nose up.  After having done that I could assign the pan to the hat switch.

Next issue I'm trying to resolve is why the zoom level resets to 56% every now and then?  I normally operate on 70% and (I think) have set that up with the various presets ???

John 

 

  • Like 1

Share this post


Link to post
Share on other sites

Expect this topic will be helpful to other users here. Appreciate you coming back to post the resolution you found!


Frank Patton
MSI Z490 WiFi MOB;  i7 10700 3.8 Ghz CPU; Ripjaws 32 gb DDR4 3600; ASUS GTX 1070 TI Turbo 8GB; MasterCase H500M; Corsair H100i Pro cooler; Corsair RMX850X PSU; ASUS VG289 4K 27"; Former USAF meteorologist & ground weather school instructor; AOPA Member #07379126 
                        There is no limit to what a man can do or where he can go if he doesn’t mind who gets the credit! - Benjamin Jowett

 

Share this post


Link to post
Share on other sites
2 hours ago, Johnwag said:

I think I found what I needed to do....

It appears that CP didn't recognise my Saitek Pro Yoke until I had moved the control column - i.e. left/right/nose down/nose up.  After having done that I could assign the pan to the hat switch.

Next issue I'm trying to resolve is why the zoom level resets to 56% every now and then?  I normally operate on 70% and (I think) have set that up with the various presets ???

John 

 

Recheck the axis assignment for pan for your control column.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    28%
    $7,075.00 of $25,000.00 Donate Now
×
×
  • Create New...