Jump to content
Sign in to follow this  
Egbert Drenth

AI2UTL Injector - Public Beta

Recommended Posts

15 hours ago, onkelfrisko said:

What am i doing wrong ?

At first glance: nothing.

I will investigate this weekend.

  • Like 1

Location: Vleuten, The Netherlands, 15.7dme EHAM
System: P3D V4 - 80386 DX2 - 4MB RAM - 3dfx Voodoo5 - Windows 3.11

Share this post


Link to post
22 hours ago, Egbert Drenth said:

At first glance: nothing.

I will investigate this weekend.

It's a bug and fixed.
It occurs when 'model=' has no value in the aircraft.cfg, so it affects also other aircraft/repaints.

Tomorrow at the latest, and updated AI2UTL will be released.
Thanks for the hint!

  • Like 3

Location: Vleuten, The Netherlands, 15.7dme EHAM
System: P3D V4 - 80386 DX2 - 4MB RAM - 3dfx Voodoo5 - Windows 3.11

Share this post


Link to post

Version 1.0.0.5 available fixing bug AI2UTL not selecting a repaint when 'model=' has no value in the aircraft.cfg

Same link to OneDrive should work:
AI2UTL V1.0.0.5

 

  • Like 1

Location: Vleuten, The Netherlands, 15.7dme EHAM
System: P3D V4 - 80386 DX2 - 4MB RAM - 3dfx Voodoo5 - Windows 3.11

Share this post


Link to post
On 11/22/2018 at 8:10 PM, edpatino said:

Hello Egbert:

I was able to successfully inject a lot of FLAi repaints and then test in P3Dv4.3 without any issues. Apart of the changes you did for v1.0.0.4:

1. Reduced the number of FLAi repaints from the original downloaded zip file from 156 to 79. I deleted (or did not use) those which were not included in your original dhq.ai2utl.search-codes.json file and those which represents aircraft models I don't want to replace (either because they are not common or not seen in traffic very often, or are of no interest to me. All this help to reduce the load of AI traffic aircraft in the simulator, which I think was the root cause of a P3D hang-up the other time when I was testing changing airports to Milano-Linate (JetStream Design's very AI crowded scenery).

2. Edited the dhq.ai2utl.search-codes.json file to eliminate all entries related to the aircraft models that I'll not use according to point 1 before, and also to eliminate all entries like this "AiCode": "", (line "empty", see below, which is a typical one eliminated):

{
    "UtlCode": "143",
    "AiCode": "",
    "SearchIn": "FLai;MISC"
  },

I don't know if points 1 and 2 above would make sense to you, but the fact is that now everything seems to be working just fine here!.

If you have any comments or questions, please let me know.

Cheers, Ed

Thanks for this - I'm getting random ntdll crashes and I suspect it's also something to do with the same issues you're running into. Are the AICode blank ones basically unused? I'm not sure what that actually means.

I just grabbed 1.0.0.5, and I'm removing all those blanks. Hopefully that does the trick.

Share this post


Link to post
25 minutes ago, nabeel said:

Are the AICode blank ones basically unused

Hi, not sure about that, but my intention was to reduce the number of repaints being injected and this is a way to do it. Try by yourself and please let us know your findings.

I had an application hang, reported by the Windows App Crash Viewer and one sudden CTD with no further indication of errors in ACV. I did not get any ntdll crashes (yet...!).

Cheers, Ed

 


Cheers, Ed

MSFS Steam - Win10 Home x64 // Rig: Corsair Graphite 760T Full Tower - ASUS MBoard Maximus XII Hero Z490 - CPU Intel i9-10900K - 64GB RAM - MSI RTX2080 Super 8GB - [1xNVMe M.2 1TB + 1xNVMe M.2 2TB (Samsung)] + [1xSSD 1TB + 1xSSD 2TB (Crucial)] + [1xSSD 1TB (Samsung)] + 1 HDD Seagate 2TB + 1 HDD Seagate External 4TB - Monitor LG 29UC97C UWHD Curved - PSU Corsair RM1000x - VR Oculus Rift // MSFS Steam & P3Dv4.5hf3 - Win 10 Home x64 - Gaming Laptop CUK ASUS Strix - CPU Intel i7-8750H - 32GB RAM - RTX2070 8GB - SSD 2TB + HDD 2TB // Thrustmaster FCS & MS XBOX Controllers

Share this post


Link to post

Unfortunately, all my manual assignments I did before were gone after I run the injector. So it makes no sense for my set-up.


- Harry 

i7-7820X (@4.7 GHz), 64GB RAM (@3600, CL16) RTX 3090, 3.5 TB SSD (3x NVME M.2). MSFS 2020: Freeware & some Payware scenery add-ons, no larger airports so far. P3Dv5.2: FSGlobalNG (mesh), ORBX (Global+OLC, all FTX Regions, all TE products, many Airports), DDscenery (NYC, Chicago, SEA), Airports (FT, FB, FSDT, AS); PMDG (737, 747, 777), MJC DQ400, RA Piston Duke, A2A C172. Weather ASP5. RXP GTN 750, AI Traffic: AIG OCI.

 

 

 

Share this post


Link to post
2 hours ago, edpatino said:

Hi, not sure about that, but my intention was to reduce the number of repaints being injected and this is a way to do it. Try by yourself and please let us know your findings.

I had an application hang, reported by the Windows App Crash Viewer and one sudden CTD with no further indication of errors in ACV. I did not get any ntdll crashes (yet...!).

Cheers, Ed

 

So, I removed all the blank AiCodes - good news - no crashes. I picked up from a flight that had crashed, and the last 4 hours or so went fine. Bad news - no traffic. I'm guessing it's because UTL doesn't like the traffic levels in-sim being messed with 🙂 However, once I restarted, all of the United liveries were the old tulips. So I'll undo the blanks and see if the limit on the injections alone fixes it. The good part (??) is that I can leave the sim open and it'll just CTD

Edit: Hmm, I'm not seeing all of the repaints show up in the configuration tool

Edited by nabeel

Share this post


Link to post

I notice there are some things unclear about the (business) logic of AI2ATC.
I thought this was covered in the manual, but apparently not clear enough.

Search/collecting repaints for an aircraft type (B735, A321, B744, etc) can be disabled in 3 ways:

  1. In dhq.ai2utl.search-codes.json set the AICode: "" for the aircraft you would like to exclude.
    AI2ATC skips that aircraft, simply because it can't translate the UTL IATA code to an ICAO code.
  2. In dhq.ai2utl.search-codes.json set the "SearchIn": "" for the aircraft you would like to exclude
    If it is blank, AI2ATC will skipp it.
  3. In dhq.ai2utl.search-codes.json alternatively remove a whole section. Do not remove parts (like only AiCode)

Be advised: AI2UTL will skip the excluded aircraft type for all carriers/operators.


 

 

 


Location: Vleuten, The Netherlands, 15.7dme EHAM
System: P3D V4 - 80386 DX2 - 4MB RAM - 3dfx Voodoo5 - Windows 3.11

Share this post


Link to post
5 hours ago, nabeel said:

Edit: Hmm, I'm not seeing all of the repaints show up in the configuration tool

This implies that UTL most likely stores it's repaints information not only in repaints.xml but apparently also in another file/database?
If that is the case (and I don't know) AI2UTL pretty much is useless. 


Location: Vleuten, The Netherlands, 15.7dme EHAM
System: P3D V4 - 80386 DX2 - 4MB RAM - 3dfx Voodoo5 - Windows 3.11

Share this post


Link to post
1 hour ago, Egbert Drenth said:

This implies that UTL most likely stores it's repaints information not only in repaints.xml but apparently also in another file/database?
If that is the case (and I don't know) AI2UTL pretty much is useless. 

AI2UTL isn't useless!

In case of using FLAi aircraft only, you need to insert the FLAi aircraft path in the "simobjects.cfg" to see the assigned FLAi repaints in the UTL interface.

If it is not important for you to see the assigned repaints in the UTL interface, you do not need to edit the "simobjects.cfg", because the FLAi-installer uses the "addon.cfg" method to inject the aircraft in P3Dv4.

Patric

Edited by pscharff

Share this post


Link to post
8 hours ago, nabeel said:

and it'll just CTD

I had a CTD as well. SimConnect log shows a model (A320 IAE) was injected. Said model hat no separation lines before the [fltsim] entries in the aircraft.cfg. Not sure if that is relevant in this situation.


Best regards, Dimitrios

Share this post


Link to post
3 hours ago, Egbert Drenth said:

In dhq.ai2utl.search-codes.json alternatively remove a whole section. Do not remove parts (like only AiCode)

This is what I did when edited the mentioned codes.json file, not any parts but the complete section. It works.

My current repaints.xml file is working well in the sim. I'll continue testing with this file for now (it was created using v1.0.0.4).

Cheers, Ed

 


Cheers, Ed

MSFS Steam - Win10 Home x64 // Rig: Corsair Graphite 760T Full Tower - ASUS MBoard Maximus XII Hero Z490 - CPU Intel i9-10900K - 64GB RAM - MSI RTX2080 Super 8GB - [1xNVMe M.2 1TB + 1xNVMe M.2 2TB (Samsung)] + [1xSSD 1TB + 1xSSD 2TB (Crucial)] + [1xSSD 1TB (Samsung)] + 1 HDD Seagate 2TB + 1 HDD Seagate External 4TB - Monitor LG 29UC97C UWHD Curved - PSU Corsair RM1000x - VR Oculus Rift // MSFS Steam & P3Dv4.5hf3 - Win 10 Home x64 - Gaming Laptop CUK ASUS Strix - CPU Intel i7-8750H - 32GB RAM - RTX2070 8GB - SSD 2TB + HDD 2TB // Thrustmaster FCS & MS XBOX Controllers

Share this post


Link to post
2 hours ago, pscharff said:

because the FLAi-installer uses the "addon.cfg" method to inject the aircraft in P3Dv4.

That would apply only in case you used the installer. I chose to install the FLAi package manually, to avoid "confusion" inside P3D with the already existing UTLive. So far, I'm seeing Ok all the injected repaints inside the sim.

Cheers, Ed


Cheers, Ed

MSFS Steam - Win10 Home x64 // Rig: Corsair Graphite 760T Full Tower - ASUS MBoard Maximus XII Hero Z490 - CPU Intel i9-10900K - 64GB RAM - MSI RTX2080 Super 8GB - [1xNVMe M.2 1TB + 1xNVMe M.2 2TB (Samsung)] + [1xSSD 1TB + 1xSSD 2TB (Crucial)] + [1xSSD 1TB (Samsung)] + 1 HDD Seagate 2TB + 1 HDD Seagate External 4TB - Monitor LG 29UC97C UWHD Curved - PSU Corsair RM1000x - VR Oculus Rift // MSFS Steam & P3Dv4.5hf3 - Win 10 Home x64 - Gaming Laptop CUK ASUS Strix - CPU Intel i7-8750H - 32GB RAM - RTX2070 8GB - SSD 2TB + HDD 2TB // Thrustmaster FCS & MS XBOX Controllers

Share this post


Link to post

Hey guys.

 

I got this up and running and the new repaints show up in the sim but I keep getting a CTD "UCRTBase.dll" any ideas what I should look for?  Only using FLAI packThanks.

 

 

______EDIT______

 

I think I got this sorted by fixing the aircraft.cfgs in the error log

Edited by JasonW

Share this post


Link to post
On 11/25/2018 at 2:32 AM, Egbert Drenth said:

This implies that UTL most likely stores it's repaints information not only in repaints.xml but apparently also in another file/database?
If that is the case (and I don't know) AI2UTL pretty much is useless. 

Oh brother, this is in NO way useless. The thing that can mess people up the most (I think) is if they have actually installed FLAI. All I did was download FLAI , unzip it and point your program to the FLAI paints folder. Works perfect.


Intel(R) Core(TM) i7-10700F CPU @ 2.90GHz (8 cores) Hyper on, Evga RTX 3060 12 Gig, 32 GB ram, Windows 11, P3D v 5, and MSFS 2020 and a couple of SSD's

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    53%
    $13,405.00 of $25,000.00 Donate Now
×
×
  • Create New...