William516

GTN 750 will not go past start screen "PRESS TO CONTINUE"

Recommended Posts

So after going through and getting the corrected download software from the website and then doing a full reinstall.  I still am unable to use the software.

 

I went and got the downloader and ran it.  I had to then find my license key and then the last four of the card for it to continue.  I gave it the proper information and then allowed the installer to run.  It found and installed all the GTN trainers and completed the install.  Finally I though it was done and I could use it.  I was wrong.

 

I ran x plane 11 and started up an aircraft cold and dark.  Supplied power via GPU and then went to the pluggins tab.  Selected the 750 and after a few seconds got the 750 layout and a message press here to continue.  I pressed the screen using the mouse and got a screen stating I had a VALID registered copy with a large button labeled press here to continue.  I use the mouse and select the button and nothing happens.  I press it again nothing.  I close the screen and try it all over again and nothing.  Eventually causes x plane to freeze up.

Tried again a second time after restarting x plane 11 and same results.  I have a valid license, I had installed it correctly.  It is NOT PIRATED and i can PROVE it.  I'm sick of people suggesting that is is pirated.  If it is then that means I paid for fake software off of your site.

I'm looking for a solution, I would like to use this software.  I can download aircraft and never have issues but this software has been a nightmare from the start.  Bad installer and now this.

 

Thanks

Bill

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Bill,

I'm sorry for the unfortunate out-the-box experience.

Can you please post the content of the RXP log files? (see user's manual for file/path)

Share this post


Link to post
Share on other sites

Exceeded the number of attempts to log into so now i have to have me the thing reactivated.  Love this honestly.  Just tried a new install to a new drive after getting rid of the old files using add/remove programs.  Checked for updates and it says up to date.

Well now im back to nothing but a blank screen again.

I will post the logs when i get a second.

 

Thanks.

Bill

Share this post


Link to post
Share on other sites

rxgtn.xpl.log

18/11/29 01:18:20.525 19700 -    ] # win.xpl version 2.5.9.0
18/11/29 01:18:20.525 19700 INFO ] 
 

rxpgtnsim.dll.log

18/11/29 01:18:23.294 19700 -    ] # rxpGtnSim64.dll version 2.5.9.0
18/11/29 01:18:23.294 19700 INFO ] 
18/11/29 01:29:23.955 11628 INFO ] 
18/11/29 01:30:11.699 14040 INFO ] 
18/11/29 01:30:38.268 26864 INFO ] 
18/11/29 01:31:13.168 03424 INFO ] 
18/11/29 01:32:25.657 22984 INFO ] 
 

Here are the log files details.

Not much here to go on, got it to go past the continue button but just a blank screen after that.

 

Bill

Share this post


Link to post
Share on other sites

Thank you for the log files, they don't show anything unusual.

Can you please let me know:

  • Whether you've installed the Garmin trainer in the default folders?
  • Whether you've installed the Garmin trainer as admin? (shouldn't be)
  • Whether you're running the simulator as admin? (shouldn't be)
  • Whether you have 2 graphics card: an integrated graphics (typically Intel chipset) and a discrete graphics card (typically NVidia or AMD)?

If the later is true, then you must ensure the GTN Simulator.exe process is only using discrete graphics and not integrated because the Intel drivers exhibit bugs/black screens in this case (otherwise on systems with Intel only it works fine).

Edited by RXP

Share this post


Link to post
Share on other sites

Whether you've installed the Garmin trainer in the default folders?

I have installed it in D drive instead of C.  This is because the computer has a very small C drive and I thought maybe that was the problem.  X plane 11 and all other programs are installed on D as well

Whether you've installed the Garmin trainer as admin? (shouldn't be)

I shut down antivirus software and ran the installer as normal.  

Whether you're running the simulator as admin? (shouldn't be)

I have tried this both ways, same results.  Normally all programs i run under NORMAL user unless it is directed to run under ADMIN rights

 

Whether you have 2 graphics card: an integrated graphics (typically Intel chipset) and a discrete graphics card (typically NVidia or AMD)?

This one may be the problem and I will have to do some digging.  I have an alienware laptop and it has the built in INTEL graphics card and then also the NVidia graphics card as well.  I'm not sure how to force it to use on or the other but i will look into this problem and get back to you.  I'm assuming I can go to the EXE file and change properties there or would I need to look through the Nvidia graphics control panel?

If the later is true, then you must ensure the GTN Simulator.exe process is only using discrete graphics and not integrated because the Intel drivers exhibit bugs/black screens in this case (otherwise on systems with Intel only it works fine).

 

Thanks again 

Bill

 

Share this post


Link to post
Share on other sites

I had issue with the install when I changed from the default C drive to my D drive.  I reinstalled everything on C and it worked fine.

Share this post


Link to post
Share on other sites

Installing on D drive shouldn't be a problem at all.

Installing as admin and running as normal user is a problem, so is the reverse.

I doubt there is a 2nd running trainer process with the RXP GTN, but can you please open task manager like shown on the video (CTRL+SHIFT+ESC) and let me know if this is the case as well for you?

99% chances the problem is the Intel chipset:

Force App To Use NVIDIA Graphics Card

  1. Open the NVIDIA control panel. Right-click on an empty area on your desktop and select the ‘NVIDIA Control Panel’ option from the context menu.
  2. Go to the Desktop menu and enable the ‘Add “Run with graphics processor” to Context Menu’ option.
  3. Return to your desktop. Right-click the app you want to force to use the dedicated GPU. The right-click context menu will have a ‘Run with graphics processor’ option. Select ‘High-performance NVIDIA processor’ from the sub-options and the app will run using your dedicated GPU.

Force App To Use AMD Graphics Card

  1. Open the AMD Catalyst Control Center app by right-clicking on an empty area on your desktop. Select ‘Catalyst Control Center’ from the context menu. From the list of panels on the left, select ‘Power’. Under ‘Power’, select ‘Switchable application graphics settings’.
  2. Here you will see a list of apps that AMD already recognizes as needing better GPU support. On this panel is an ‘Add Application’ button. Click it and select the EXE of the app you want to force to use the AMD graphics card.
  3. After you add the application, open the dropdown next to it for setting graphics options. Select ‘High performance’ and you’re done. The app will always use AMD graphics card.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now