Jump to content

Sign in to follow this  
robert young

Little Navmap stuck on x plane connection/database

Recommended Posts

LNM is such an excellent programme for which I would like to thank Alex. However there is one complication that I cannot solve whatever I do. I am using P3dv4 but the scenery library in Navmap is stuck on X plane in the library dialogue. There are no other options and the reset option is greyed out, as is the dialogue for loading a scenery.cfg.

I suspect it is a simconnect issue. The KEY THING is which simconnect version is required on either or both computers? There is enormous confusion about this because there are so many different versions of simconnect.- specifically that there are two different Sp2 simconnect iterations, one being FSX SP2 simconnect (prior to FSX Acceleration), then there is simconnect Sp1, RTM, ESP, Sp2, then Xpack versions. The only way to really sort this out is to have clear and specific VERSION NUMBERS of the correct simconnect for P3dv4 on both computers. Quoting Sp2/Xpack/ESP etc doesn't properly identify the precise version numbers of the simconnect msi installer or dll files.

The clearest way to do this is for Alex to emphatically state EXACTLY which VERSION NUMBER (6.xx.xxx.xxx.) etc  of simconnect is required to successfully run the library options on the client computer, connected to a host computer running P3dv4. And to say whether multiple other version of SImconnect might interfere with the correct version working properly with LNM.  A further confusion is that within the various simconnect installer folders, there are different version numbers between the dll files and the msi installers within the same lib folders! I confirm I have thoroughly read the manual including the part about simconnect versions. However it is not made clear how to overcome this specifically P3dv4 anomoly.

If anyone could please explain precisely what I need to do I would be very grateful. Thank you!

Edited by robert young

Share this post

Link to post
Share on other sites

Hi Robert,

LNM needs the FSX SP2 SimConnect. This is 10.0.61259.0 which is the version number I use in the manifest file here. I load SimConnect dynamically to have full control over the process and I plan to load other versions too in the future to avoid the requirement of SP2: https://github.com/albar965/littlenavmap/issues/273. Had no time yet to implement this.

Different SimConnect versions don't interfere with each other. You can install all of them without problems.

Regarding the installation on the flying computer: You already read this in the manual. FSX SP2 is needed.

Regarding the installation on the client/remote/network computer: Neither SimConnect nor a Simulator is needed. See here: How to run a network Setup

Sorry about the version number mess but you should blame MS or LM for that. :wink:

SimConnect and its versions are in general a support intense mess IMO. For X-Plane, as usual, all is much easier.


Share this post

Link to post
Share on other sites

Hi Alex,

It's most kind of you to reply so quickly. Thanks so much and I'm sorry to trouble you. OK - so it is ----61259. I wonder whether my slight problem was that I did in fact install Simconnect cfg on the remote computer, and I also wondered why I was occasionally getting reverse connection messages on the host LNconnect app (it announced "connection FROM xx.xxx.xx.xx ip!) Maybe the unneeded simconnect file was causing x plane to be the only option?

Anyway - the programme still worked and I must say it is a work of great elegance and flare, so congratulations to you, and thanks again for the kind reply. I will check I have the correct simconnect installed.


Share this post

Link to post
Share on other sites

Thank you a lot for the kind words, Robert.

Installing SimConnect on the remote is not needed but should do no harm. X-Plane is always displayed in LNM because there is no reliable way to find an X-Plane installation on a computer.

Do not change the Simconnect.cfg . It can keep LNC/LNM and also other programs from connecting to the simulator. Already had such cases.
I do not use the simconnect remote network functionality. That's why I implemented LNC.


Share this post

Link to post
Share on other sites

Hi Alex,

First, thank you for this great piece of software. It's since the wonderful FSNavigator that ran on FS9 that i couldn't find a great flight planner tool and yours most definitely filled that gap. AND you have released it for free. For that alone, i feel bad in bothering you with this issue, but hope you can understand :-)

This is an old topic but i have the same issues stated above by Mr. Robert Young.
Here's my situation.

I am running FSX:SE on my Windows 10 desktop (the "flying PC"), with LittleNav Connect installed on the flying PC and LNM installed on my macbook pro (MacOS Catalina) that is on the same network as the fying pc.

LMN connects with FSX with no issues, the moving map works and the data transmitted from the flying PC to the macbook pro appear to be correct. However, LNM has "Little Navmap 2.4.5 - XP11 / N" on the top of the window and when i try to load the scenery library by clicking on the menu bar "Scenery Library" this happens:

1) I see "1 X-Plane 11" grayed out on top of the pull down menu, with a check mark in the front, before the "1"

2) When i click on "Load Scenery Library..." in the next window the "Simulator:" option is pre-determined as X-Plane 11 and when i click on it, there are no other options.  The "Reset Paths" button is grayed out.
3) I still attempted to point the "Filght Simulator Base Path" to my networked "Flying Computer" where FSX:SE is installed but it returns an error that it didn't find what it seems to be the X-plane scenery directory.  This leads me to think that while LMN gets the data feed from LM connect on my flying pc, it may still "think" that my simulator is X-plane and therefore when i attempt to load the sceneries, LMN expects to see X-plane sceneries and not FSX:SE ones.

I have tried to erase all the possible configuration files related to LMN on my mac, tried to reinstall several times, but it is always stuck in this situation.
Would you possibly be able and so kind to point me in the right direction to solve this issue?
Thank you. I really appreciate any help that you will be able to provide.

Kind Regards,


Share this post

Link to post
Share on other sites

Hi Mark,

thank your for the kind words! Appreciate it. And no need to feel bad for a question.🙂

You don't have to load the scenery library on the remote/mac. You simply copy the LNM scenery database from the flying computer to the remote and that's it. No need to load anything.
In your case you have to copy the file
from the Windows flying computer to
/Users/YOURUSERNAME/.config/ABarthel/little_navmap_db/little_navmap_db/little_navmap_fsxse.sqlite to the remote/mac.

You can open the database path in Windows Explorer or the Finder in main menu -> "Scenery Library" -> "Show Database Files" on both computers. This saves you searching through your home folder and the hidden ".config" folder.

See pinned thread here:



Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online

  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.

    $5,540.00 of $25,000.00 Donate Now
  • Create New...