Skywolf

Looks like F1 GTN 750 is updated for 4.4

Recommended Posts

See heading - looks like it is updated.  Just read on the forums

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

They are still apparently working on the further update to the new version of the GTN trainer which includes AIRAC 1803.

  • Like 1

Share this post


Link to post
14 minutes ago, jabloomf1230 said:

They are still apparently working on the further update to the new version of the GTN trainer which includes AIRAC 1803.

yes...that part is true.  i wish there was a way to get fully DB from some pilot who has G750 in real.  Do you know of any pilots who have that DB

Share this post


Link to post

I just re-installed GTN complete v. 206, ran the update tool which says I have the  version required (1.12 definitions) and I still get the GTN error. Pretty weird!

Share this post


Link to post
2 hours ago, jimcarrel said:

I just re-installed GTN complete v. 206, ran the update tool which says I have the  version required (1.12 definitions) and I still get the GTN error. Pretty weird!

Did it work in v4.4 though.? I went back to 4.3 until this is properly upgraded. Also have 1.12 but I'm not trying it until confirmed.

Share this post


Link to post

It works in 4.4 - it just show a pop up - which is weird but it is working in my 4.4

 

Make sure you run the update tool

Edited by Skywolf

Share this post


Link to post
2 hours ago, Skywolf said:

i wish there was a way to get fully DB from some pilot who has G750 in real. 

You would be lucky to find someone with a real worldwide database. As a real world owner, most would have a regional database like I do.

  • Like 1

Share this post


Link to post

Great News!

BTW :

You can get AIRAC 1803 by installing Garmin's GTN Trainer 6.50. You can install it without uninstalling the 6.2 version that F1 uses. It's a big improvement over the 1611 DB in the F1 GTN which is obsolete for many airports already that have new SIDS, STARS and Approaches.

Once installed browse to the database folder and copy the files over to your 6.2 GTN database and you'll have the August 2018 AIRAC installed in your F1 GTN.

Caveat is the FliteCharts in GTN 6.2 can't be updated since they are in an older format, but all else can be updated to 1803 including SafeTaxi display, Terrain DB and all the rest. The newer GTN trainer uses a new charts format since they regional-ized the DB for file size reasons.

If you want newer than 1803 you are out of luck unless you physically own a GTN on your airplane and can prove it to Garmin by providing your N# when buying the DB on their site after purchase. Interestingly though anyone can buy the database from their website (It's like 300 bucks), but they won't give you the download link without an N# so it's pointless to buy it unless you own your own airplane with a GTN. Ask me how I know! Tried buying it, they refunded me since I didn't have an N#, even if you say you'd like it for training purposes for the GTN Trainer they say you can't update it. Technically you can but without an N# they won't give you the DB even if you try buying it.

Edited by American 833 Heavy
  • Like 1

Share this post


Link to post
41 minutes ago, DavidP said:

You would be lucky to find someone with a real worldwide database. As a real world owner, most would have a regional database like I do.

I will buy you Beer for your real world database.  

Share this post


Link to post
1 hour ago, Skywolf said:

It works in 4.4 - it just show a pop up - which is weird but it is working in my 4.4

 

Make sure you run the update tool

Many of us have no autopilot steering... what did you do to make it work?

Share this post


Link to post
2 minutes ago, Bert Pieke said:

Many of us have no autopilot steering... what did you do to make it work?

yes...I was wondering why autopilot wasn't working.  It has been reporting in their forums.  Gonna test again in few minutes

Share this post


Link to post
1 hour ago, American 833 Heavy said:

Once installed browse to the database folder and copy the files over to your 6.2 GTN database and you'll have the August 2018 AIRAC installed in your F1 GTN.

So, you don't really install the GTN 6.50 over the 6.2?, you just point to install the 6.50 to another directory and just copy/paste and only use its updated DB?. Please clarify.

Thanks, Ed

Share this post


Link to post

Ed,

The Garmin 6.5 GTN Trainer uses different folders in the same ProgramData/Garmin and ProgramFiles/Garmin locations.

All you need to do is run the 6.5 install, leave the default install location and run the installer. When done browse to the new folder created in ProgramData/Garmin to extract the 6.5 1803 DB. After you get the 1803 DB you can uninstall the 6.5 trainer as it's not used by the F1 GTN.

All you need from the 6.5 install is located here by default :

C:\ProgramData\Garmin\Trainers\Databases\

Copy and Paste over only the files that have the same filenames here :

C:\ProgramData\Garmin\GTN Trainer Data\DB

And that's it you are done. Make a Back up of your 1611 DB just in case.

Edited by American 833 Heavy
Typo.
  • Like 1
  • Upvote 2

Share this post


Link to post

Thanks American. Downloading now!.

Cheers, Ed

  • Upvote 1

Share this post


Link to post

Just Updated to 1.13. Now works. did not work with 1.12.

 

Share this post


Link to post

You also need the updated V2.07 GTN gauges..

  • Like 1

Share this post


Link to post

Thanks you SIR!

Share this post


Link to post
52 minutes ago, Bert Pieke said:

You also need the updated V2.07 GTN gauges..

Excellent, just used 2.06 and uno joy to GPS tracking.. Thank you Bert.

Share this post


Link to post

2.07 works perfectly.  Just came from GTN forums.  And @Bert Pieke just mentioned it - Thanks

Share this post


Link to post

Hi:

When trying to install the v2.07 GTN gauges I'm getting the following error message about Visual C++ 2015 runtime that does not allow me to complete the installation. Any help, please?:

"An unknown error ocurred during the installation of the Visual C++ 2015 runtime. It's not recommended that you continue with the setup". Before all this I get a message that my Visual C++ 2015 runtime files were out of date.

Cheers, Ed

Share this post


Link to post
2 hours ago, Bert Pieke said:

You also need the updated V2.07 GTN gauges..

OK - no idea what I'm doing wrong. Update tool tells me I have 2.13 and keeps telling me on start up "we suggest you use the update tool bla bla bla". As a result, it does not follow the NAV route. And to add to that, not sure how to install this v2.07 gauge. Can you point me in the right direction?

Share this post


Link to post
3 hours ago, Bert Pieke said:

You also need the updated V2.07 GTN gauges..

How do do that?  Thanks

Bruceb

OK figured it out - looks like a full reinstall.

Edited by brucewtb
Additional info

Share this post


Link to post

Thanks, Gunther - I never can find the link to F1's GTN updates!

Share this post


Link to post

Just use the F1 Update tool.  The forum never works for me.

Cheers

bs

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now