MattDavies

Water Surface Tuning Error - Update

Recommended Posts

Hi all,

In the latest update of PTA (2.63), I introduced a bug with the "Water Surface Tuning" tweak.

This is due to LM changing some of the code within one of the shaders. 

When I purchased PTA & the source code, there was an immediate problem - it was written in Delphi (an age old programming language that I am absolutely not fluent in) & the source code was annotated in Russian. Up until this update, only minor changes have had to be made to PTA in order to make it compatible with the latest versions of P3D.

So, please bear with me whilst I painstakingly translate all of the annotations and then figure out how to fix the broken tweak.

I've been super busy over the past week so yesterday evening was only the first real chance I had to sit down and look at it, hence the post now. 

Patience is all I ask, I will figure it out in the end 🙂 

Thanks, I appreciate the support. 

 

  • Like 7
  • Upvote 1

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Thanks for the update Matt. 

 

 

Edited by GSalden

Share this post


Link to post
Share on other sites

Thanks Matt!

You will figure it out and we will benefit from it.

Share this post


Link to post
Share on other sites

Thanks Matt. Let me know it you need any help with Russian 😏

  • Like 1

Share this post


Link to post
Share on other sites

I wonder whether it's worth re-writing in something other than Delphi? C++ or something?

Adam.

  • Like 1

Share this post


Link to post
Share on other sites
6 hours ago, Adamski_NZ said:

I wonder whether it's worth re-writing in something other than Delphi? C++ or something?

Adam.

It's being written in C# by another guy as we speak 🙂

Share this post


Link to post
Share on other sites

thanks for the update Matt !

As PTA is working expect this one small issue, take your time !

Best, Carsten

Share this post


Link to post
Share on other sites
7 hours ago, MattDavies said:

It's being written in C# by another guy as we speak 🙂

Yay!!!!!!!!!!!! 👍 😋

Adam.

Share this post


Link to post
Share on other sites
17 hours ago, RTK1972 said:

thanks for the update Matt !

As PTA is working expect this one small issue, take your time !

Best, Carsten

Not the small ;), I use this tweak (its important). But NP, I’ll can wait for the fix. TY!

Share this post


Link to post
Share on other sites

Hi Matt, 

could you please explain step by step how to fix this problem? 

User GSalden did it in another topic , but it is so confusing for a PTA Newbie  ;)

Thank you in advance. 

Mav

Share this post


Link to post
Share on other sites
37 minutes ago, Maverick3333 said:

Hi Matt, 

could you please explain step by step how to fix this problem? 

User GSalden did it in another topic , but it is so confusing for a PTA Newbie  😉

Thank you in advance. 

Mav

Wait for the patch/new version of PTA.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now