Jump to content

Radial9

F1 GTN750 Unusable After P3D4.4 Update

Recommended Posts

I'm going to try to remain calm and polite in explaining my utter frustration dealing with the F1 support system over the past few days, AGAIN, after promising myself I would not deal with these people again, as over 17 years EVERY time I buy something from them and need assistance it is a MAJOR headache and frustration filled endeavor. Wrapper Crapper! Yes, I use the new Purchasing Agent now.

In order to get to the support forum you need to register your purchase with your valid username on the open forum along with providing your purchase certificate number. Their system WILL NOT recognize my VALID certificate number.

Perhaps someone has encountered a similar problem after updating their GTN750. I bought it to use with the A2A Bonanza V35, which I am truly enjoying learning to fly.

When I load the AC I get an error dialog that suggests I update my F1 GTN750 definitions files, using the F1UpdateTool. I have done so, I now show files version 1.13 and I can see the P3D4.4 versions listed numerous times in the Supported Simulator Version window. Yet I continue to get the error upon loading the AC that uses the F1GTN750 to update my definition files via the F1UpdaterTool.

Once loaded, the GTN takes a full five seconds to zoom, pan to a new location map, or load any menu. UNUSABLE. Behavior began upon updating GTN750 to use with P3D4.4.

Anyone have any suggestions as to a possible fix? I suppose I could uninstall the whole GTN750 and reinstall, but, once again, it teaches me to buy product from this vendor. It's not that I'm surprised or irritated that there are bugs or issues, I get that. It's what I have to go though, DAYS of hoop jumping, to even begin to explain my issues to them. EVERY... SINGLE... TIME......

I usually pride myself on being civil and polite, but this keeps going on and on and on, years after years after years....

Cheers,

Bob

Edited by Radial9

Share this post


Link to post

Hi, it takes more than the flightupdate tool. you need to get the latest version of gtn.

I believe its now ver 2.07....info is on support site

                                rick

  • Upvote 1

Share this post


Link to post

Yes, version.2.07 works, I got it right from the new Purchasing Agent library. Give it a try.

Share this post


Link to post

Installed F1 GTN and GNS Completed yesterday, I didnt notice any problems.

Share this post


Link to post

Unfortunately, the F1 messages are misleading..

They lead you to believe that only the Definitions Update is required..

Suggest you register for the GTN support forum where this is all explained.. and yes, V2.07 works in P3D4.4. :wink:

  • Upvote 1

Share this post


Link to post

Thank you Gentlemen...

I guess I will have to wait until F1 finds time to see why my certificate number is invalid and not permitting me to read the support forum where it is all explained.

But I truly appreciate the help gentlemen. My frustration remains...

Bob

 

 

Edited by Radial9

Share this post


Link to post
2 hours ago, Radial9 said:

Thank you Gentlemen...

I guess I will have to wait until F1 finds time to see why my certificate number is invalid and not permitting me to read the support forum where it is all explained.

But I truly appreciate the help gentlemen. My frustration remains...

Bob

 

 

In the interim, download a fresh copy of the GTN Complete gauge from the Flight1 sales page and reinstall it.

That should solve your problems. :smile:

Share this post


Link to post
2 hours ago, Radial9 said:

I guess I will have to wait until F1 finds time to see why my certificate number is invalid

I thought they wanted your order number, not the certificate number.

Share this post


Link to post

First, make sure you have already created a user account at SimForums (the register option is in the top menu). If you already are a registered Licensed Member and forgot your login name, please click here.

Next, locate your Proof of Purchase Certificate number Certificate numbers are different than your regular order number:

On Download Versions:

You will need a 2-part activation code. I will look like 3X492DGG-23N4IDN23. If you purchased from Flight1.co

Select Product
     Flight1 Super King Air B200 Version 2                 Super King Air B200 for FSX                 Super King Air B200 for Prepar3D                 Cessna 182 Turbo Skylane for Prepar3D                 Cessna 182 Turbo Skylane for FSX                 Cessna 177B Cardinal II GTN Complete                 GTN 750 for FSX                 GTN 650 for FSX                 GTN 750 for Prepar3D                 GTN 650 for Prepar3D GNS Complete                 GNS 530 for FSX                 GNS 430 FSX                 GNS 530 for Prepar3D                 GNS 430 for Prepar3D               
Forum Username
 (You must be already be a forum member)
Certificate ID
 -  (e.g. 298765-HG23A8H1)

Share this post


Link to post

when you posted to F1`, did you cut/paste your certificate# or enter in manually? Sometimes, if you cut/paste you can get an extra hidden character added which will make the registration invalid.

Vic

Share this post


Link to post

Appreciate the suggestions. Six attempts to obtain support forum registration throughout the day. Attempted all possible input methods. Cut paste upper lower case etc. It's FUBARd. Sent a support ticket in 0800 EST today with a detailed explanation. You would think I learned by now not to buy premium software where you cannot read the manual nor read the support forum prior to purchase. But we keep giving them our money so they aren't inclined to change their practices.

It will get sorted out eventually. Just no way to run a support operation IMHO. I may just attempt to download 2.0.7 tomorrow, uninstall 2.0.6 and upgrade. When I do get in they will receive my thoughts on the experience. Shame is the next guy will have to buy the software to hear my experience and opinion of their support PITA hoops.

Share this post


Link to post

 

9 hours ago, Radial9 said:

 

Once loaded, the GTN takes a full five seconds to zoom, pan to a new location map, or load any menu. UNUSABLE. Behavior began upon updating GTN750 to use with P3D4.4.

Cheers,

Bob

Not sure if this is related, but, I had this problem with my GTX970 and running in 4K resolution. GTN was slow as molasses even though the sim ran fine, and the pop out was even worse. When I upgraded to a 2080, slow zoom and slow GTN loading went away and she works perfect now.  

Share this post


Link to post
40 minutes ago, Radial9 said:

Appreciate the suggestions. Six attempts to obtain support forum registration throughout the day. Attempted all possible input methods. Cut paste upper lower case etc. It's FUBARd. Sent a support ticket in 0800 EST today with a detailed explanation. You would think I learned by now not to buy premium software where you cannot read the manual nor read the support forum prior to purchase. But we keep giving them our money so they aren't inclined to change their practices.

It will get sorted out eventually. Just no way to run a support operation IMHO. I may just attempt to download 2.0.7 tomorrow, uninstall 2.0.6 and upgrade. When I do get in they will receive my thoughts on the experience. Shame is the next guy will have to buy the software to hear my experience and opinion of their support PITA hoops.

I empathise with your position. To be fair I got a reasonably swift reply on the certificate-serial number-order number- email-address-password-hurdle jumping stuff, and I must admit that now F1 has the new purchase app things are much swifter ONCE you have transfered from the old clunky system to the new system but it does seem as though it is taking time to get that new system working with everyone on board.

I enjoy Simmarket's very efficient ONE email ONE password to access everything. No trawling through credit card numbers from four years ago, certificates, serial numbers, order numbers etc etc.The F1 purchase agent does work pretty well once you have it set up, but I think the need to "associate" your forum login for support with a product is still very clunky.

I wouldn't bother with the updater. Just download GTN complete 2.07 and leave the updater alone. Another thing I found is that the Garmin Trainer download link within the GTN installer resulted in a corrupt or faulty download, three times in a row, so I downloaded version 6.2.11 of the trainer direct from Garmin and it now works flawlessly.

Edited by robert young

Share this post


Link to post

Also not very happy with F1 GTN for my A2A Cherookee. Even with my new   2080 card installed a couple of weeks ago, it still very difficult to use the Home and Direct To buttons (they need a quick double click to eventually work, then slowly changing page or opening window for the direct to). I tried through A2A support to solve the problem as it’s not so bad when I use the GTN as a pop-up in others airplanes. I was trying yesterday to reinstall everything with the new F1 p3d 4.4 installer and the latest Cherookee installer but no joy. Also a minor issue with Spotlight for night lighting the cockpit. The GTN textures and button stay dark even if i overlit the area with a light beam. I was trying to locate where those textures are but cannot find them.

Time for Reality XP maybe ?

Share this post


Link to post

Lucky Me. Two days later after confirming my address I get the following response to my Flight1 support ticket.

You should now have licensed forum access.  You do not need to register further.

OK…

So, I spend 20 minutes reading through the four-page history of everyone learning how screwed up with misinformation the updating process is. Trying to decide WHO Flight1 support staff is addressing or what question is being answered is almost impossible. It’s like the kid at the keyboard at Flight1 quickly typed out a cryptic response on his way out the door, over and over, for weeks.

Would it be so hard to take an hour and write a simple upgrade process that addresses the issue, pin it to the top, and lock it? It may save countless responses in a thread that is nearly impossible to follow. I know... I sound like a disgruntled old codger (actually I am), but wait… there’s more.

I jot down what I believe to be the process. Of course, I must totally disregard the instructions for reinstalling the software in the manual that came with the download dated three years ago. Update or delete it? Sorry, can’t be bothered.

So now the old version is gone. I attempt to install 2.07. Run as Admin… Choose to reinstall using my Flight1 account info as the method rather than the old wrapper and key file (been there, done that… no thank you). And what is the response…. “Sorry the information submitted could not be validated because your account login or password is incorrect.”  No.. it is not. I maliciously write these things down in my log book as they are created. I remember too as EVERY field in the entire full page Flight1 create account process has to be hand typed as 21st century auto-fill passed these guys by. Oh… and BTW  I also get “Don’t keep trying as too many login attempts will shut your account down”. Really????

$64.95 for software that is 85% Garmin Trainer software and now close to three days and as many hours of tickets, hoop jumping and head scratching. Dug out the ticket and started over. These folks should hang their heads in shame. And shame on me for buying from these people, once again.

Not Cheers,

Bob

 

Share this post


Link to post

Just received a response back from my inquiry via the Flight1 software support ticketing system.

"The forum account is separate from the Flight1.com account, so the passwords are different. I believe all you need to do is to install 2.07 on top of the earlier version.

Sorry you are having issues... but we just do not know the software here in the ticket system.. The main developer is working the forum and does not do tickets. If you post there at the forum in a new thread, and give us the thread, we can send it to the developers attention.

Thanks,"

This after reading on the site" The best way to get  support is via the support ticketing system."

This IS NOT a software support issue. It IS a ticketing, licencing and ACCESS issue.

Unbelievable.

 

At this point I'm just writing off the $65 and sending the developer of LittleNavMap a good donation. Love the program, I need to figure out how to make an aircraft profile that fits the A2A Bonanza V35. Should not be too hard once I find the data. I use LNM all the time for my Manfred Jahn C47 and quite frankly I don't see anything on the G1000 that I cannot get from LittleNavMap a WHOLE lot easier.

I have had a personal bias toward the old FSX GPS systems for years, mostly from the dial mouse PITA navigation while flying. I thought it was time to set that bias aside and learn GA GPS procedures. Worked out swell.

I think I will just stick with my VOR's, NDB's and good old pilotage for GA flying.

Cheers,

Bob

 

Share this post


Link to post

And on that note, we'll say goodbye to this thread.

 

Vic

Share this post


Link to post
Guest
This topic is now closed to further replies.
×
×
  • Create New...