Jump to content

Sign in to follow this  
jt8d9a

X-ROTORS AW139

Recommended Posts

On 1/28/2019 at 5:27 PM, Scarp said:

A USA livery thanks!!

  • Upvote 1

|Ryan Butterworth|

| i7 4790K@4.4GHz | 32GB RAM | EVGA GTX 1080Ti | ASUS Z97-Pro | 1TB 860 Evo | 500GB 840 Evo Win10 Pro | 1TB Samsung 7200rpm | Seasonic X750W |

 

 

Share this post


Link to post
Share on other sites

Unless I mistake, I did not see it mentioned in the thread : the website https://www.x-rotors.com/ now has more content.

I find it interesting to have the "Custom Livery" service. Never see before for me.

However the process and workflow to create a custom livery is not enough detailed and one cannot see how its expectations will be met. And the message box to specify requirements is too small.

Edited by Simicro

- TONY -
ugcx_banner.png

 

Share this post


Link to post
Share on other sites

AW139 RC2 Change log

This is Release Candidate 2 change log

  • Fixed the marching ants issue affecting many textures on some graphic cards due to wrong UV maps
  • Fixed internal glass opacity, as reported too dark by many pilots using VR headsets
  • Fixed collective trim hat switch function, when CLTV/YAW trim is on the switch trims collective, otherwise it changes the reference target parameter value if a FD collective mode is engaged (ie. VS or ALT reference)
  • Fixed rotor brake strenght
  • Fixed vents sound when battery is off

Download from your private area or grab it from here!

  • Upvote 1

Share this post


Link to post
Share on other sites

Could anyone educate me in using the battery the right way? Following the start up checklist, the main bus and ess bus drains, the landing and taxi lights go dim after awhile - (spotlight does not).

How should I configure the switches to keep electrical power up while in flight instead of draining them?

Have read the user guide, what am i missing?

Using  rc2

 

Many thanks

 

Share this post


Link to post
Share on other sites

Are you losing power while in flight? I don't see you mentioning the generators, make sure they are switched on.

Share this post


Link to post
Share on other sites
7 hours ago, Scarp said:

Are you losing power while in flight? I don't see you mentioning the generators, make sure they are switched on.

Hi Scarp,

 

Yes generators 1 and 2 are on.

I love your artwork too, many thanks for the great liveries.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    28%
    $7,035.00 of $25,000.00 Donate Now
×
×
  • Create New...