mihajlo123

Direct scenario start

Recommended Posts

Hello,

Since i updated Prepar3D from 4.3 to 4.4. When i am starting the sim, it directly starts a scenario. 

Does anyone knows what the problem is?

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Go to your menu and click OPTIONS - GENERAL - and check off > SHOW SCENARIO STARTUP SCREEN

Share this post


Link to post
1 minute ago, vcarlo said:

Go to your menu and click OPTIONS - GENERAL - and check off > SHOW SCENARIO STARTUP SCREEN

Thanks but that is not the problem. I want to start a scenario but when p3d is loaded in, without clicking on anything, It directly starts a scenario. So i can't start a scenario and have to reload my P3D until i can set up my own scenario. 

Share this post


Link to post

Sorry, lost in translation.  I don't understand what you're seeing.  When you see your scenario, go to the menu bar across the top of the screen.  When you click on OPTIONS, GENERAL, is there already a check in the box SHOW SCENARIO STARTUP SCREEN ??? 

 

Share this post


Link to post

 i would have deleted Prepar3.cfg in :\Users\%YOUR_USER_ACCOUNT%\AppData\Roaming\Lockheed Martin\Prepar3D v4\

Share this post


Link to post
7 minutes ago, vcarlo said:

Sorry, lost in translation.  I don't understand what you're seeing.  When you see your scenario, go to the menu bar across the top of the screen.  When you click on OPTIONS, GENERAL, is there already a check in the box SHOW SCENARIO STARTUP SCREEN ??? 

 

Yes, When i start P3D, it loads, then i see the scenario start menu. I can't even change an a/c or dep airport because the scenario will start directly. Without clicking on anything. 

Edited by mihajlo123

Share this post


Link to post
2 minutes ago, roarkr said:

 i would have deleted Prepar3.cfg in :\Users\%YOUR_USER_ACCOUNT%\AppData\Roaming\Lockheed Martin\Prepar3D v4\

Already tried that and it worked for 1 day, Then the problem Arisses again. 

Share this post


Link to post

Since this happened after your update, you may want to try an UNINSTALL and REINSTALL of the 4.4 CLIENT only.

Share this post


Link to post
48 minutes ago, vcarlo said:

Since this happened after your update, you may want to try an UNINSTALL and REINSTALL of the 4.4 CLIENT only.

I already tried that to. 

Share this post


Link to post

(long shot but maybe worth mentioning)...

if windows 10 shuts down before a program/process has completely finished; the task will be restarted when windows starts. P3D can take a minute or two to shut down completely AFTER the icons disappear and a shutdown or reboot within that time will often restart P3D when windows starts up the next time.

Edited by jpf

Share this post


Link to post
53 minutes ago, jpf said:

(long shot but maybe worth mentioning)...

if windows 10 shuts down before a program/process has completely finished; the task will be restarted when windows starts. P3D can take a minute or two to shut down completely AFTER the icons disappear and a shutdown or reboot within that time will often restart P3D when windows starts up the next time.

Will try that this evening. Thanks! Will be back soon. 

Share this post


Link to post
Quote

Already tried that and it worked for 1 day, Then the problem Arisses again

Does a statement get added to the Prepar3d.cfg file to determine what happens when P3D loads? If so, what is it? This is a general question for the AVSIM community, not the OP.

Edited by Christopher Low

Share this post


Link to post

@mihajlo123
Open Prepar3D.cfg
Under [USERINTERFACE] you should have this:
SHOW_SCENARIO_WINDOW=1

If the sim is not shutting down properly Prepar3D.cfg will not save your (changes) settings.

Share this post


Link to post

Hi all,

The problem is not that the scenario screen isn't showing. I'm seeing the scenario start up screen but directly after launching P3D and showing the start up screen, it iniate a scenario by itself. While showing the scenario screen. So no problems with showing the scenario window. I just can't select a/c or airport because as soon it transitions from start up screen to scenario window, It starts the scenario. 

Share this post


Link to post

So, that begs the question......is there another statement in the Prepar3d.cfg file that can force load the default scenario if it is not set correctly?

Share this post


Link to post

Are you using SimStarter or similar add-on? These launch P3D with custom cfg settings.

Regards 

Simbol 

Share this post


Link to post
13 hours ago, simbol said:

Are you using SimStarter or similar add-on? These launch P3D with custom cfg settings.

Regards 

Simbol 

Nope, Don't use any of that kind. 

Rebooted my PC with no application running. Started p3d fresh and it still is starting an scenario while showing the scenario window. 

Share this post


Link to post

Maybe your cfg files are read only or you dont have Administrator rights.

Share this post


Link to post

Hi everyone,

I'm also having this issue I have tried the things above as suggested but they aren't working.

https://gyazo.com/38de974891cb29bbfc2215f73c5f93ad

Thanks

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now