tcbs1p3r101

CTD and P3D Scenery Library all messed up

Recommended Posts

Hello, Im quite new here but I have recently had a crash to desktop and I am kinda concerned:

Faulting application name: Prepar3D.exe, version: 4.4.16.27077, time stamp: 0x5bfdbb35
Faulting module name: KERNELBASE.dll, version: 10.0.17134.441, time stamp: 0x428de48c
Exception code: 0xc0020001
Fault offset: 0x000000000003a388
Faulting process id: 0x18cc
Faulting application start time: 0x01d4b131d1599fcd
Faulting application path: A:\Prepar3d V4.4\Prepar3D.exe
Faulting module path: C:\WINDOWS\System32\KERNELBASE.dll
Report Id: cfe6871d-08aa-4d71-917b-7edfd33bcbf1
Faulting package full name: 
Faulting package-relative application ID: 

 

Im a little afraid because I accidentally messed with the scenery library because I was trying to get scenery to load faster and avoid blurries but I completely screwed it I think. I heard deleting the scenery library was the right idea because P3D will make a new one. But I just want to confirm that, if any of you guys know how to get my sim to run better/ eliminate blurries as well. My Specs are:

Intel Core i7 8086k Overclocked to 5gz on all cores

GTX 1080TI

32gb of 3000mhz ram

PSU 750 gold

 

Thank you so much!

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

1 hour ago, tcbs1p3r101 said:

I heard deleting the scenery library was the right idea because P3D will make a new one. But I just want to confirm that, if any of you guys know how to get my sim to run better/ eliminate blurries as well.

This is true.  It will be replaced with the default.  However, P3D also uses add-on.xml's so, if you had any add-on scenery, it load via the Prepar3D V4 Add-ons.  If you have add-ons, you should use the Lorby-Si Addon Organizer - https://www.avsim.com/forums/forum/795-lorby-si-freeware/.  Many of the commercial add-ons will make add-on.xml's for the scenery and you have to do nothing but the Addon Organizer manages the scenery.

The kernelbase.dll has no known fix as there are several possibilities.  The AVSIM CTD Guide provides a list of fixes that worked for others for this dll.  I would suspect your issues with the scenery is causing the error.

For the blurries (and since you have the same system as mine), you need to go into the BIOS and look for CPU and then Hyper-Threading.  It is turned on by default.  Turn it off and your scenery will be very crisp and clear.  Make sure you have no AffinityMask Tweak in your P3D.cfg.  Simple fix. 

Share this post


Link to post
Share on other sites

Ok, I have just disabled hyperthreading and installed the addon manager. Will this automatically number things and fix it?

Share this post


Link to post
Share on other sites

Also, would you mind sharing your settings/link to a post where you may have chared in the past? Also thank you so much for the quick response!

Share this post


Link to post
Share on other sites
11 hours ago, tcbs1p3r101 said:

installed the addon manager. Will this automatically number things and fix it?

I place photo scenery all the way down, just above the default scenery.  Airports, like FSDT and FlightBeam are next.  I also put DD scenery near the top too like SeattleX, WashX, and New York City X.

 

10 hours ago, tcbs1p3r101 said:

Also, would you mind sharing your settings/link to a post where you may have chared in the past? Also thank you so much for the quick response!

I'll post some images of my current settings later.  Just got up...

Share this post


Link to post
Share on other sites

Here are my current settings.  For the video card, I leave the settings at the default for P3D.

y4mf0RRTzPND_QaIb7aU5mytPPJNMVjxSzVwriYi

y4mTDDQ7h1fxZqzavej-63AXU7lYuhC0_t_YhJSG

y4m5Zx_bcxNZRI6OUwr8oSB_D_rr3iyGfPaMr2K8

y4msbswc0ZywUkeggE3LdCiAznt5z33yTJcAODn2

Share this post


Link to post
Share on other sites

Thanks for the responses once again. I changed everything recommended besides orbx stuff as I believe they may be in the right place(City Scene Orlando us photoreal). But I also changed the settings and so far so good. Doesn't setting the fps to unlimited not allow scenery to load as fast?

Share this post


Link to post
Share on other sites
2 hours ago, tcbs1p3r101 said:

Doesn't setting the fps to unlimited not allow scenery to load as fast?

You can safely set it to 40 but your machine should have no problems running a scenario at unlimited.  I rarely see FPS below 30 and, if it does go to 30, those 10 seconds of pain and suffering at fps 30 I see no difference whatsoever.  I do not know how well Orbx City Scene Orlando runs in your system, but there is a long discussion about it in the Hangar Chat Forum.  Since it does contain photoscenery, you may suffer some issues with it even if you are flying in Europe or San Francisco as all enabled photoscenery loads no matter where in the world you are located.

Share this post


Link to post
Share on other sites

interesting. Well @Jim Young thank you so much for personally answering all my questions and being so nice to a new member. I hope to see you around and ill come back to you if I have any problems. Thanks!

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now