Jump to content

Sign in to follow this  
bigmike

Can't get v4 (purchased from Flightsimstore)

Recommended Posts

The Flight Sim Store seem to be having a liquidation sale.  They also seem to be not taking updates from product vendors (or at least are not reading their emails).   In consequence that now would appear to make 3.4 the final build available for Flight Sim Store customers.   As they have their own licensing scheme  I cannot provide an updated FSS installer and the Fastspring installer will not accept the FSS licenses.   

The only option that you have  is that if you have purchased or now go and purchase the cloud shadows addon from my website then as well as giving you cloud shadows that will also update the installed fixer to the latest version. So  CloudShadows 1.10 patched from 3.4 to 3.5 and the latest build CloudShadows 1.12 now patches from 3.4/3.5 to 4.0 (at least now I have fixed the problem  raised in another post)

Edited by SteveFx

Share this post


Link to post
Share on other sites

Hi.  I purchased your scenery fixer from the flightsimstore but have been unable to obtain the new version 4.  I have re-downloaded the product several times over the past 2 months but it is always v3.4

As a customer who purchased your product I should be able to obtain the updates despite whatever problems the Flightsimstore vendor is having.  It should not matter where I purchased it from.

Can you please look into this problem and try to get it resolved?  There should be a way for folks like me to transfer our licenses to another vendor, or to you, so that we can obtain updates.

Thank you.

Dave

 

Share this post


Link to post
Share on other sites

Version 3.4 is the last version that is available to flight sim store customers as they are not taking new updates.  They issued their own licenses and built their own installer so I cannot provide a version 4.0 installer.

 You can however upgrade to version 4.0 by purchasing the cloud shadows addon, which will patch an already installed copy of 3.4 FSS to version 4.0

Share this post


Link to post
Share on other sites
22 hours ago, SteveFx said:

Version 3.4 is the last version that is available to flight sim store customers as they are not taking new updates.  They issued their own licenses and built their own installer so I cannot provide a version 4.0 installer.

 You can however upgrade to version 4.0 by purchasing the cloud shadows addon, which will patch an already installed copy of 3.4 FSS to version 4.0

So I have to pay for cloud shadows to get updates that I'm already entitled to by virtue of having *paid* for your product?  Are you kidding?

You are the developer and you made the decision to sell your product through the Flightsimstore.  You were paid royalties or whatever when the Flightsimstore sold your product.  It is therefore your responsibility to see that legitimate customers are taken care of.

Simply blaming the Flightsimstore is not resolving the problem.

Are you going to help your customers or are you going to shirk your responsibility? 

We are simply asking that updates be made available to us.  Do you not care about your reputation?

Dave

 

 

 

Share this post


Link to post
Share on other sites

Dave you purchased a software  product in 2013/2014 - so 4 or 5 years ago. 

The latest version that you could have possibly  bought from the FSS store was 2.6 in Dec 2014. There was no suggestion at the time of purchase that all future versions would be included  so I don't really follow where this entitlement to all future versions that you perceive exists comes from?   Its not the way that software generally works after all is it?

At no cost to you I have provided you with between 10 -20 enhancements/upgrades (it depends when in 2013/2014 you purchased) . This was a free bonus to you. 

For reasons outside my control I have no route to deliver any further versions to these old FSS customers.  I do not know their names or their licenses and I cannot produce a FSS installer as they wrote that code not me. Therefore I have decided that 3.4  will be the final version for all customers who purchased prior to 2015. 

The 3.4 version that you have works well and for a long time I was planning it to be the final version.

For anyone who feels disadvantaged by this I have come up with a means to upgrade to the  latest version (and any subsequent versions) at a 50% discount* which after such a long passage of time seems  a good deal to me - especially as included with this is the cloud shadows addon itself which in my view is well worth its asking price on its own.  But no one is forcing you to do this - you have a good working version of the fixer already.

Now there is a separate issue which is that in the future the FSS activation servers may stop working.  Whilst that won't stop your fixer working immediately it would be problematic if you purchased a new PC or needed to reinstall.  

I totally agree that  customers should not lose a working product because of the issues with the flight sim store and so I am working towards a solution - however for the reasons explained that is far from easy. I currently plan to deal with this on a case by case basis. So when/if the servers go down and someone needs to reinstall I will provide them with a new copy of 3.4 and a new license - and also ensure that cloud shadows can patch from that 3.4 version to future versions.

 

* To clarify the discount quoted represents the  price differential from a copy of cloud shadows to upgrade the FSS version and the equivalent bundle of a V4.0 Fixer and Cloud Shadows which is what most new customers purchase.    The discount is less if compared against the V4 Fixer on its own  (33%). 

The discount is also 50% if you compare the Cloud Shadows price with the cost of the Fixer  in 2013/2014.

 

 

Edited by SteveFx
Clarify discount %
  • Like 1

Share this post


Link to post
Share on other sites
On 24/01/2019 at 13:53, dave2013 said:

Então eu tenho que pagar por sombras de nuvem para obter atualizações que eu já tenho direito em virtude de ter * pago * por seu produto? Você está de brincadeira?

Você é o desenvolvedor e tomou a decisão de vender seu produto por meio do Flightsimstore. Você recebia royalties ou o que quer que fosse, quando a Flightsimstore vendia seu produto. Portanto, é sua responsabilidade garantir que os clientes legítimos sejam atendidos.

Simplesmente culpar o Flightimstore não está resolvendo o problema.

Você vai ajudar seus clientes ou vai fugir de sua responsabilidade? 

Estamos simplesmente pedindo que as atualizações sejam disponibilizadas para nós. Você não se importa com sua reputação?

Dave

 

 

 

Concordo com o Dave, esta conduta não está correta!

Desejamos atualizar o DX10.

Francisco Garcia

  • Like 1

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×
×
  • Create New...