Jump to content
Sign in to follow this  
wheels1911

Joystick / Controler stoped working FSX SE

Recommended Posts

I had the logistic 3d pro... It stopped working so I figured it broke.... So I went out and bought the Thrustmaster Flight Hotas X........... also does not work.....So now I know its the game..1 week ago my joystick worked... I haven't downloaded anything new... I even did the steam game files check........ controller doesn't show  up in FSX setting just has "free look" and "mouse yoke" of course I've tried different USB's... IDK what else to do... I don't want to uninstall becuse I have 2 PMDG'S...... GSX.... edok...   addon secenery


Jordan Wheeler

Share this post


Link to post
Share on other sites

When the game loads up on the opening screen, right click & check the bottom of the menu that pops up..

If mouse yoke has a check mark, deselect it & you should get back control of your joystick.

Cheers....

 

Share this post


Link to post
Share on other sites
29 minutes ago, OleGreyGhost said:

When the game loads up on the opening screen, right click & check the bottom of the menu that pops up..

If mouse yoke has a check mark, deselect it & you should get back control of your joystick.

Cheers....

 

Sorry I may not have explained enough. FSX literally does not even see my Joystick... Setting> controls .........No joy stick... Like its not there.. so the mouse yoke has really nothing to do with this....it also deselected of course 


Jordan Wheeler

Share this post


Link to post
Share on other sites

This looks like a joystick driver issue.  Like OleGreyGhost said, find and download the necessary drivers for the sticks.

Failing that, try a powered USB hub (that is, it plugs into a power outlet).  It is possible you have too many USB devices plugged in and your computer does not have enough power on its own to handle them all.  I use so many controllers for FSX:SE that I have to use the USB hub for a couple of them to be fully running and recognized.


Sim: Prepar3D 5.2 (main) and Microsoft Flight Simulator (2020), CH Eclipse Yoke, Thrustmaster Airbus TCA Side Stick, CH Pro Throttle, CH Pro Pedals, Saitek Cessna trim wheel, TrackIR 5, SPAD.neXt running 3 Saitek Logitech panels, ButtKicker Gamer 2, Razer Naga Chroma gaming mouse

System: Intel i5-10600K CPU @ 4.10 GHz, Nvidia GeForce RTX 2080 Ti, 64GB DDR4 RAM @ 4200 MHz, ASRock Z490M Pro4, 2TB Intel NVMe SSD 660p, 3 monitors

Share this post


Link to post
Share on other sites

Same thing happened to me. Suddenly, my CH yoke and pedals ceased to be recognized. I wound up doing a system restore back a couple days and that fixed it.

Edited by Ken Pryor
fixed typo

Share this post


Link to post
Share on other sites

Well, it did it again. After using System Restore, everything returned to normal and I could use the yoke and pedals as usual. Tonight, FSX stopped seeing them again and Windows sees them but doesn't know what they are. No clue how to proceed.

Share this post


Link to post
Share on other sites

I rebooted and Windows installed updates. Now the yoke and pedals seem to be working again. Crossing my fingers that they'll continue to work.

Share this post


Link to post
Share on other sites
On 28 January 2019 at 7:04 AM, wheels1911 said:

Sorry I may not have explained enough. FSX literally does not even see my Joystick... Setting> controls .........No joy stick... Like its not there.. so the mouse yoke has really nothing to do with this....it also deselected of course 

There seems to have been a controller problem with Steam for some people recently. Start Steam and try changing these settings (make sure FSX isn't running). In the top left of the Steam panel, go to Steam->Settings->Controller->General Controller Settings and deselect everything. Then simply close out. Restart FSX and if you go to Controllers in the game under Settings your controllers should be there.

Edited by vortex681

 i7-6700k | Asus Maximus VIII Hero | 16GB RAM | MSI GTX 1080 Gaming X Plus | Samsung Evo 500GB & 1TB | WD Blue 2 x 1TB | EVGA Supernova G2 850W | AOC 2560x1440 monitor | Win 10 Pro 64-bit

Share this post


Link to post
Share on other sites

Thank you very much for that info! I've still been fighting the problem off and on and had wondered if Steam might have anything to do with it. I'll give what you said a try.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    53%
    $13,405.00 of $25,000.00 Donate Now
×
×
  • Create New...