Jump to content

Egbert Drenth

Vertx DA62 - Power and startup??

Recommended Posts

Hi,

I bought the DA62 a while ago but never flown with it until now.
I selected cold and dark startup mode but there is no way I get power on, let alone can start the engines. I suspect my battery is empty.
(Eventhough I have in FSUIPC batteries set to unlimited, but I guess DA62 has proprietary batteries)

In the manual it is advised to enable external power (which I did on the ceiling) then:

  • Pressed Elec Master ON
  • Enabled Fuel levers (on the floor)

G1000 remains black, no power at all. Flipping engines switches to Master as well and starting engines didn't help either.
Any help is welcome.

BTW: does have Vertx a forum. Looked for one on their website but couldn't find.

Egbert

 

Share this post


Link to post

I would suggest downloading again. I had similar issues with older versions but the latest updates resolved them. 

Share this post


Link to post
16 minutes ago, pedwards said:

I would suggest downloading again

I checked and it appears I already have installed the latest version (V1.053) but I'll redownload/reinstall again.

Share this post


Link to post

Your battery might be drained.….you have to connect the ground power to recharge it.

  • Upvote 1

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...