Jump to content

Sign in to follow this  
Robert Edwards

I can see me BUT CANNOT See Online Traffic

Recommended Posts

Solved my own problem:

Went to Main Menu -> Tools -> Flight Simulator Connection in Little Navmap.

It is there that one must check "Fetch AI and Multiplayer Aircraft" in order for AI or, in my case, LiveTraffic, aircraft appears on the map. Somehow had missed that step.

Share this post


Link to post
Share on other sites

Not sure if I'm the only one but still not working here. Any ideas would be appreciated

Windows 10 system
X Plane 11.33 (release version)
VATSIM connecting with X Squawkbox 1.3.3
LittleNavMap 2.2.4, Little XP Connect 1.0.14
I have disabled all other add on plugins (checked carefully).

I can see all VATSIM traffic out the window and on the X Plane internal map.
I can see my own aircraft in LittleNavMap.
Fetch AI or Multiplayer aircraft is checked ON.
Show AI and Multiplayer Aircraft is ON.
The Simulator Aircraft window AI/ Multiplayer tab in LittleNavMap says no AI or multiplayer aircraft found.

Stumped. I've had to be away from online flying for a bit but I thought it had been working fine with earlier versions of X Plane and LittleNavMap??

Thanks and thanks for a fantastic utility!

Share this post


Link to post
Share on other sites

Thanks for the detailed report, @crii.

No idea what can be wrong there. The aircraft should be visible if you can see the aircraft in the X-Plane internal map.

LNM reads the multiplayer information from these data refs. You can check these If you have the dataref editor/viewer installed.

Can you see normal AI in LNM if enabled in X-Plane?

Edit: Can you see the orange online network aircraft on the map (the ones which are updated only every few minutes)? Is VATSIM enabled in the options dialog?

Alex

Edited by albar965
More questions

Share this post


Link to post
Share on other sites

Thanks for the reply.

I also tried connecting with the VATSIM SWIFT client and get same result.

The sim/multiplayer/position/plane[x] DATA REFS appear to be correct when I watch them in Dataref Editor. They are populated with non-zero values.

X-plane generated AI shows correctly (white aircraft).

If I turn on VATSIM in the ONLINE tab the time delayed, network generated orange aircraft appear normally.

As far as I know all the VATSIM clients somehow suppress the XP native AI so they can replace it with the network traffic. May they are somehow suppressing the output of the datarefs??????? Just wild speculation.

Not really that big a deal anyway. I just thought that I remembered using it in the past?

Share this post


Link to post
Share on other sites

I'm in the same situation with X-IVAP. I can see the Orange planes (from the online source) but not the white ones from the sim.

If X-IVAP is DISABLED I see the white planes. (from X-Plane AI traffic)

If X-IVAP is ENABLED but NOT CONNECTED I don't see the white planes. (from X-Plane AI traffic)

If X-IVAP is CONNECTED I don't see the white planes and the datarefs seem not to be populated correctly.

 

This might be something about how the traffic is injected into the sim, and not related to LNM directly.

Share this post


Link to post
Share on other sites
On 5/18/2019 at 8:38 AM, raptor2003 said:

If X-IVAP is DISABLED I see the white planes. (from X-Plane AI traffic)

If X-IVAP is ENABLED but NOT CONNECTED I don't see the white planes. (from X-Plane AI traffic)

If X-IVAP is CONNECTED I don't see the white planes and the datarefs seem not to be populated correctly.

Thanks for testing. Looks like I really need to have a closer look at this issue with X-IVAP. I opened an issue for 2.4 for tracking: https://github.com/albar965/littlenavmap/issues/414

Alex

Share this post


Link to post
Share on other sites

i found that Little Nav Map will not show VATSIM traffic if XPUIPC plugin is active.  Deactivate and it works fine.  However XPUIPC is needed for PlanG.

 

Malcolm

Share this post


Link to post
Share on other sites

Thanks for the feedback, Malcolm. Good hint. Maybe there are conflicts with DLLs that are used by XPUIPC and Xpconnect. I'll check this later for the 2.4 release.

Does the X-Plane log.txt show any errors? Can you see messages about Xpconnect like the one below?

Loaded: /data/alex/Programme/X-Plane 11/Resources/plugins/Little Xpconnect/64/lin.xpl (ABarthel.LittleXpconnect.Connect).

Alex

Share this post


Link to post
Share on other sites

I have a question relating to some lines above, DATA REFs in XPLane:

LNM is reading the mentioned data refs. Does that mean, that all these data refs have to be activated in XPlane-menu Data Output/ Dataref  ?
And if so, which IP-Adress and Port should i use?

I am flying with a private server (fsd) without whazzup-file. The connection is made with swift. 3 AI-Planes are activated.

In active session i can see my Co-Flyers in the XPlane-View. Th XPlane-Map shows 3 "freezed AI" also does LNM for a while. After 2-3 Minutes the AI disappear in LNM, no Co-Flyer from the swift-connection is shown.

I am searching so long to solve that problem, no success.

LNM does not show my Co-Flyers.

Share this post


Link to post
Share on other sites
1 hour ago, fsspn said:

Does that mean, that all these data refs have to be activated in XPlane-menu Data Output/ Dataref  ?

No. There is nothing to activate. The network client software (SWIFT and others) either fills these or LNM cannot display the traffic if you do not use a whazzup -file.

LNM does rely on these datarefs. If you can see the planes in the X-Plane map you should see them in LNM too.

This is all a general problem in X-Plane. These datarefs are too limited and clients use other means to "inject" aircraft into the simulator which LNM cannot detect.

Alex

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    10%
    $2,610.00 of $25,000.00 Donate Now
×
×
  • Create New...