Jump to content

Geoffery

Xplane11 - MCP and EFIS working! But with some glitches

Recommended Posts

Hi Team,

I finally got the Virtual Avionics MCP and EFIS to work in XPlane 11, but with some gotchas along the way. I have had both for a while, and they work perfectly in P3D with the PMDG737 and iFly737, 747. And while they work in XPlane 10 I have never been able to get them to work in XPlane 11, until now!

Following the install instructions, with the latest drivers I would either get crashes or unresponsive hardware. Checking the XPlane logs showed this:

Error Code = 126 : The specified module could not be found

I searched this error and found that it means Windows is missing one or more of the Microsoft Visual C++ redistributable packages. I am not a programmer, but this seemed to be pointing to the issue. I found this all in one package from a reputable site, you can search on google (see below). It is basically an all in one Net Framework package. Then with surplus hardware I created a new PC, with a new install of Windows. I started with Windows 7, planning on 7,8 and 10 testing.

The clean install gave me the exact same error - Error Code 126, and hardware that was unresponsive. So then I installed the file mentioned above (Visual C++ Runtime installer) and fired up XPlane. Voila! No error code in the log, Virtual Avionics icon green in the task bar, Zibo737 sitting on the tarmac. I changed the course on the MCP, XPlane responded! I toggled a few switches on the EFIS - yes, working as expected. Off to the races....   

But there are a few things not working and some glitches -

MCP:
Heading display
Altitude display
Both display figures and will adjust as you move the hardware dials but no change is made to the sim MCP. But when you move the sim MCP the Virtual Avionics MCP figures will change to match your sim figures. Odd.
EFIS:
Range won't change when you move the dial
VOR/ADF switches don't change in sim

I tried a clean install with Windows 8, Windows 8.1 and Windows 10 but it did not work. Installing the framework package got the plug in working, but most functions did not work including the LED digits. The only OS I got working was Windows 7. Again, I am not a programmer but it seems newer versions of the NetFramework are conflicting with the code.

NetFramework file:
Visual C++ Runtime Installer (All-In-One) v56 Major Geeks

To sum up:
XPlane 11
Windows 7 only
Runtime Installer from above
Latest VA driver, follow install instructions
Zibo (version does not seem to matter)

As a test I networked up my "new" Win7 system with working Virtual Avionics Hardware to my main Win10 system and it worked fine - as I manipulated the MCP and EFIS everything worked as expected across the two PCs (everything except the glitches listed above). Next step is a full flight - checking all functions. I think voice commands will get me around the Heading and Altitude bugs above, and I can map a button to change range on the EFIS. I will keep you posted of my progress.

Happy flying.....

Share this post


Link to post
Share on other sites

I recently bought the MCP and EFIS, the hardware looks great, but I've run into 1 of these same glitches you are talking about.

 

Everything is working perfectly, all functions are reacting properly. Then all of a sudden, the hardware will continue to display changes (ie, moving the heading will change the digits on the hardware) but it does not get put into the sim.

The VA icon is still green in the tray when this happens, the only way I have found to fix it is to close VA interface, close the prosim MCP, and reopen those programs. 

I operate Windows 10, prosim737 latest version, VA interface latest version.

Help would be appreciated! 

 

Matt

Share this post


Link to post
Share on other sites

WOW. Good thing I checked here first before blowing $600 on their MCP. No fix to the problems in this post???

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...