Taxelrod

GTN750 / C172SP goes crazy entering holds

Recommended Posts

I’m running the latest release of the RXP GTN750 (from two days ago or so), xplane 11.32v2, and the non-G1000 C172.  All works well with the autopilot with the big exception of holds and procedure turns.  The GTN display will show that the hold is coming up, show the correct entry path on the map, and announce a turn ahead to the proper heading.  When the moment arrives, though, it almost always turns in the opposite direction and then gets ever more confused.  Same with procedure turns.  I’d guess the connection to the autopilot is somehow reversed, but it follows complex GPS routings without trouble.

Any thoughts most welcome.  This is making IFR practice with this setup pretty tough!

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I’m happy to report that this problem is likely restricted to the C172SP. Performs flawlessly with the x-plane Baron.  I now have a reasonable training setup, though it’s sure been awhile since I’ve flown a twin in real life.  It’s coming back...

Share this post


Link to post
Share on other sites

Hi,

There is a remaining bug in the latest version when you load an aircraft cold and dark and we're finalizing the fix (and tests) prior releasing it. The bug might have had an impact as well when flying with the C172?!

Share this post


Link to post
Share on other sites

Hi, v2.5.16 is now released.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now