SledDriver

P3D multicore usage anomoly

Recommended Posts

Posted (edited)
55 minutes ago, SledDriver said:

Struggling a bit here.

I have RTSS installed. Followed your instructions as to the startup order.

Got the sim running. Turned off Vsync and made framelimit unlimited in sim.

Opened RTSS.

Added a new profile for P3D. Selected it.

Clicked the Scanline Sync until it said x/2.

Entered 60 into the space beside Scanline Sync.

Is that it?

Is there anything else I need to do in RTSS? Cos the framerate in the sim according to the in sim FPS (Shift-Z) is jumping around between 36 and 39. I was expecting it to be locked on 30.

What have I done wrong?

Hello SledDriver,

First open RTSS and next P3D

Cattura.jpg

 

Edited by Simone99

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Hmm. Something is not right.

I put those setting in and it always shows 37fps. I have a 60Hz monitor so that ain't right...

Only way I can get 30fps is to put 30 in the "Framerate limit", but that's not what you guys say I need to do.

Any ideas?

Share this post


Link to post
1 hour ago, SledDriver said:

Hmm. Something is not right.

I put those setting in and it always shows 37fps. I have a 60Hz monitor so that ain't right...

Only way I can get 30fps is to put 30 in the "Framerate limit", but that's not what you guys say I need to do.

Any ideas?

I haven't tried this method yet (Scanline sync/2) so i don't know if it works for me. 
I discovered this method today by reading this topic in the morning.
So far I have used the limit of the RTSS frame at 32 but now I want to try this method after lunch time and give you my 'test'
In some case my RTSS don't block FPS (frame limit mode and NO scanline) and to resolve this i close and open RTSS until block FPS.

So you can try close/open RTSS multiple time (also administrator) and MAYBE it work. ->  (restart only rtss not the sim)
Also you can try increase the application level to high


PS: Sorry for bad english 😧

Share this post


Link to post

>So you can try close/open RTSS multiple time (also administrator) and MAYBE it work. ->  (restart only rtss not the sim)
>Also you can try increase the application level to high

Thanks for the ideas. I tried them, but it still doesn't work as expected.

Share this post


Link to post

Are you using the latest version of RTSS?

Share this post


Link to post
Posted (edited)
3 hours ago, SledDriver said:

Hmm. Something is not right.

I put those setting in and it always shows 37fps. I have a 60Hz monitor so that ain't right...

Only way I can get 30fps is to put 30 in the "Framerate limit", but that's not what you guys say I need to do.

Any ideas?

Verify with a different framerate counter. P3D's internal limiter is wildly inaccurate at times and fluctuates all over the place.

Edited by Sethos1988

Share this post


Link to post
On 4/10/2019 at 8:26 PM, SledDriver said:

Do you guys deliberately bury your heads in the sand. I took the time and trouble to write that report because it works.

Sled, I achieved a consistent "perfectly smooth" sim maybe 2y ago after a decade of struggling with this or that approach w/ marginal success.  I'm on a now nearly 6y/o system.  Perfection stops when the main thread approaches 100% utilization.  With your configuration and setup, what happens to smoothness when you encounter a scenario that is beyond what your machine can manage, despite how you set it up?  

Share this post


Link to post
Posted (edited)
10 minutes ago, Sethos1988 said:

Verify with a different framerate counter. P3D's internal limiter is wildly inaccurate at times and fluctuates all over the place.

I think he used RTSS frame limiter and not p3d limiter

Edited by Simone99

Share this post


Link to post
Just now, Simone99 said:

I think he used RTSS frame limiter and not p3d limiter

I know, just saying he needs to confirm the numbers with a different frame rate counter, if he's using P3D's own (Shift + Z) numbers, as they rarely seem to match the actual framerate.

Share this post


Link to post
Posted (edited)
51 minutes ago, SledDriver said:

>So you can try close/open RTSS multiple time (also administrator) and MAYBE it work. ->  (restart only rtss not the sim)
>Also you can try increase the application level to high

Thanks for the ideas. I tried them, but it still doesn't work as expected.

So the frame limiter work but scanline not. I will try soon and report if for me work.

6 minutes ago, Sethos1988 said:

I know, just saying he needs to confirm the numbers with a different frame rate counter, if he's using P3D's own (Shift + Z) numbers, as they rarely seem to match the actual framerate.

Yeah sorry i didn't understand completely your comment. Personally i am using Nvidia FPS counter for all games. (YES.. p3d isn't a game 😝

Edited by Simone99
Error

Share this post


Link to post
Posted (edited)
3 hours ago, SledDriver said:

Hmm. Something is not right.

I put those setting in and it always shows 37fps. I have a 60Hz monitor so that ain't right...

Only way I can get 30fps is to put 30 in the "Framerate limit", but that's not what you guys say I need to do.

Any ideas?

Yes, you need to specify your "Framerate Limit".  I use 29... so that my framerate stays under 1/2 of the 60 Hz my monitor gives.

Cheers,

Greg

Edit: Additionally, I start the sim and wait until the main page loads, then start RTSS, and then load my Scenario.  Works fine for me.

Edited by lownslo

Share this post


Link to post
On 3/29/2019 at 10:02 PM, SledDriver said:

However, if I then within the same sim session I re-enable core0 for P3D, core0 now acts just like all the others, jogging along nicely at 20-50% exactly like all the other cores. The 100% hammering is gone, yet the sim continues to work just fine with no visible difference in performance.

Now right off the bat I can't relate to one of your key premises, because the ONLY time I see the main thread (Physical Core1) hit 100% is when the scenario is beyond the single-core performance capacity of my now 6y/o CPU.  My understanding has always been that the main thread grabs the bulk of the CPU required work, while the other available cores manage terrain texture loading.  Your theory (how you explain your performance) seems to fly in the face of that pardon the pun--you're saying P3D can DISTRIBUTE the main thread over all cores, but that was never how P3D was explained to work, at least from my understanding.  Indeed, it could be that you are impairing single core performance by cutting down the main thread to match whatever the other cores are doing if you follow the logic. 

With the AM I use, HT enabled, the old theoretical understanding seems to hold up completely: when I'm flying thru very detailed terrain the LP's I have available for terrain texture loading are variably busy sometimes up to 100% for several of those 8 LP's at a time sometimes and yet I can have the physical core available to the main thread hit only 75% for example.

Share this post


Link to post
9 hours ago, SledDriver said:

Struggling a bit here.

I have RTSS installed. Followed your instructions as to the startup order.

Got the sim running. Turned off Vsync and made framelimit unlimited in sim.

Opened RTSS.

Added a new profile for P3D. Selected it.

Clicked the Scanline Sync until it said x/2.

Entered 60 into the space beside Scanline Sync.

Is that it?

Is there anything else I need to do in RTSS? Cos the framerate in the sim according to the in sim FPS (Shift-Z) is jumping around between 36 and 39. I was expecting it to be locked on 30.

What have I done wrong?

This is exactly what I am doing.  Should be OK.

If you turn off RTSS, your framerates should return to whatever your unlimited setting delivers. 

RTSS can be turned on or off either before or during flight, so you can see it operating.  Verify that you can see the effect.

Do not worry about the exact fps readout... mine is typically 28-30 with RTSS active.

Not solid 30.

The real test is whether you get smooth, fluid flight.

Share this post


Link to post
2 hours ago, lownslo said:

Yes, you need to specify your "Framerate Limit".  I use 29... so that my framerate stays under 1/2 of the 60 Hz my monitor gives.

Cheers,

Greg

Edit: Additionally, I start the sim and wait until the main page loads, then start RTSS, and then load my Scenario.  Works fine for me.

Greg, you are using a different approach to RTSS.. the framerate limiter.

That is actually not what we are discussing here.. sorry.. :unsure:

Share this post


Link to post
2 hours ago, newtie said:

Are you using the latest version of RTSS?

Yup. Straight from the Guru site. I assume that's the latest.

Share this post


Link to post
2 hours ago, Sethos1988 said:

Verify with a different framerate counter. P3D's internal limiter is wildly inaccurate at times and fluctuates all over the place.

P3D and RTSS agree on the 37fps. Do you have a recommended 3rd party checker?

 

Share this post


Link to post

OK I'll read all these replies in a bit and check it all out.

Thanks everyone.

Share this post


Link to post

Are you using NVI?

Share this post


Link to post
4 hours ago, Noel said:

Sled, I achieved a consistent "perfectly smooth" sim maybe 2y ago after a decade of struggling with this or that approach w/ marginal success.  I'm on a now nearly 6y/o system.  Perfection stops when the main thread approaches 100% utilization.  With your configuration and setup, what happens to smoothness when you encounter a scenario that is beyond what your machine can manage, despite how you set it up?  

I do all my testing in worst case scenario I can think of. Anything else is pointless. I'm not interested in gliding through the desert only to hit fps hell when I go anywhere near civilisation. 🙂

Share this post


Link to post
4 hours ago, Simone99 said:

I think he used RTSS frame limiter and not p3d limiter

Correct

Share this post


Link to post
Just now, SledDriver said:

I do all my testing in worst case scenario I can think of. Anything else is pointless. I'm not interested in gliding through the desert only to hit fps hell when I go anywhere near civilisation. 🙂

And that may again explain some differences in user experience..

I like the fluid feel of my airplane in "normal" scenery situations, and recognize that downtown LA or SEA with full Orbx regions is going to introduce a minor performance impact which I will have to live with. No blurry scenery or fps hell though :cool:.

Share this post


Link to post
4 hours ago, lownslo said:

Yes, you need to specify your "Framerate Limit".  I use 29... so that my framerate stays under 1/2 of the 60 Hz my monitor gives.

Cheers,

Greg

Edit: Additionally, I start the sim and wait until the main page loads, then start RTSS, and then load my Scenario.  Works fine for me.

Top post on this page disagrees with you. Who is right?

Is it as suggested a the top of this page:

Framerate limit = 0
Scanline Sync = x/2

Or is it

Framerate limit = 30
Scanline Sync = x/2

Please don't guess.

Share this post


Link to post
1 minute ago, SledDriver said:

Top post on this page disagrees with you. Who is right?

Is it as suggested a the top of this page:

Framerate limit = 0
Scanline Sync = x/2

Or is it

Framerate limit = 30
Scanline Sync = x/2

Please don't guess.

No guessing.. my recipe calls for the first option.

Share this post


Link to post
3 minutes ago, SledDriver said:

Top post on this page disagrees with you. Who is right?

Is it as suggested a the top of this page:

Framerate limit = 0
Scanline Sync = x/2

Or is it

Framerate limit = 30
Scanline Sync = x/2

Please don't guess.

I'm using the first option also with good results. 

Share this post


Link to post
4 hours ago, Noel said:

you're saying P3D can DISTRIBUTE the main thread over all cores, but that was never how P3D was explained to work

By who? The actual guys who wrote it?

Did you ever actually look at the thread count on your modern PC with anything running. It's not uncommon to have no 'apps' open and the CPU still be handling 20,000 threads, and you're trying to tell me that P3D main routines are in one thread.

That just doesn't make sense.

P3D main processing will be thousands of threads, all perfectly capable of being distributed across many cores.

That's just how CPU's work.

The fact that it loads up Core0 unless you stop it, is almost certainly legacy programming which has not yet been rewritten by LM.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now