Ekim

P3d 4.5 is out!

Recommended Posts

Donkey and a cart, thank god i’ve Posted every day in their forums for this. God is good installing now.

  • Like 5
  • Upvote 3

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

1 minute ago, Shylock_35 said:

Donkey and a cart, thank god i’ve Posted every day in their forums for this. God is good installing now.

LOL!

Share this post


Link to post
11 minutes ago, Sethos1988 said:

Isn't it usually around this point they start to move on to the next major branch, 5.0 in this case or have we seen iterations beyond x.5 in the past?

Never was a 3.5 but there was a 2.5. Never beyond .5 that I recall.

Share this post


Link to post

yeah what are the usual suspects that need updating:

ASP4

FSUIPC

PTA

 

Share this post


Link to post

And nobody has seen the signs:

 

Sz7yEPe.jpg

  • Like 3

Share this post


Link to post
27 minutes ago, ideoplastic said:

Does this mean that the PMDG aircraft won't work until updated by developer?

thanks

Usually PMDG aircraft don't need updates, so their aircraft should work!

  • Upvote 1

Share this post


Link to post

And folks, while you're heading over to https://www.prepar3d.com to download v4.5, be aware of this phishing site, and double-check the url before entering login/password info:

Edit:  L-M says this was a bad redirect and has been fixed.

  • Like 2

Share this post


Link to post
1 hour ago, Jetset408 said:

Can anyone remind me if there are any addons that dont like Content updates? I think one has to re-run FTX Central for ORBX stuff, but apart from that...?

It's the Scenery update that forces you to re install FTX Global. The Content update is save to do without any re-installs.

  • Upvote 1

Share this post


Link to post
5 minutes ago, Ekim said:

Usually PMDG aircraft don't need updates, so their aircraft should work!

Thank you Ekim.

 

Share this post


Link to post
28 minutes ago, Sethos1988 said:

Active Sky always needs a compatibility patch. They are usually pretty fast bringing that out, however.

It is already out.

Share this post


Link to post
1 minute ago, Farlis said:

It's the Scenery update that forces you to re install FTX Global. The Content update is save to do without any re-installs.

Well Content sometimes affected the GSX UI so GSX might need to run Live Update just to be safe.  

Share this post


Link to post
7 minutes ago, Farlis said:

It's the Scenery update that forces you to re install FTX Global. The Content update is save to do without any re-installs.

IIRC, if running ORBX sceneries, you need to run FTXCentral once after a content update so that the configs are all properly augmented/updated.

Regards

  • Upvote 4

Share this post


Link to post

What about this line in the Scenery update: 

  • Added more building scenery objects.

If using ORBX FTX Global, will we see an improvement if we install the Scenery update?

Share this post


Link to post
9 minutes ago, Farlis said:

It is already out.

Awesome, thanks 🙂

Share this post


Link to post

PMDG has confirmed their planes work in 4.5, tested the latest release candidate!

  • Like 1
  • Upvote 2

Share this post


Link to post

woohoo now fslabs can release their update

  • Upvote 1

Share this post


Link to post
1 minute ago, Nyxx said:

I see one from 6th April no mention of 4.5? 

https://hifisimtech.com/downloads/#ASP4

Yeah, also a bit confused. Nowhere do they mention 4.5 at all. However, they do say "P3D compatibility update". So it might be a way of making it 4.5 compatible a few days in advance, without mentioning that 4.5 is releasing and breaking the NDA.

Share this post


Link to post
1 minute ago, BBoyJD10 said:

That open beta supports 4.5 just confirmed myself.

 

Just now, Sethos1988 said:

Yeah, also a bit confused. Nowhere do they mention 4.5 at all. However, they do say "P3D compatibility update". So it might be a way of making it 4.5 compatible a few days in advance, without mentioning that 4.5 is releasing and breaking the NDA.

OK great guys thanks.

Share this post


Link to post

Hifisimulations need to make a new update of ASP4, it is not compatible. I checked it for some minutes ago.

Share this post


Link to post
Just now, casv said:

Hifisimulations need to make a new update of ASP4, it is not compatible. I checked it for some minutes ago.

Install the open beta 🙂

  • Upvote 1

Share this post


Link to post

Ok, removed tomatoshade, removed  tomato reflections, restored ai_player.dll, 5 more mins and will reinstall client and content

Share this post


Link to post
1 minute ago, Johnny19 said:

Ok, removed tomatoshade, removed  tomato reflections, restored ai_player.dll, 5 more mins and will reinstall client and content

When you install the new client it will set shaders back to default reflections might be a different thing ofc.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now