Jump to content
Sign in to follow this  
Ekim

P3d 4.5 is out!

Recommended Posts

1 hour ago, RTK1972 said:

just took the first flight. Same i use as a test scenario with 4.4

I have to say that i am really disappointed in terms of performance. i nearly have 25% less fps and it is stuttering like crazy......

You fu**ed it up. Maybe you didn't delete the shader cache or something like that. If troubles arise it's better to rename prepared3d.cfg and let rebuild it.

  • Like 1

System: i9 9900k@4.9 - 32 GB RAM - Aorus 1080ti --- Sim/Addons: P3D v5 + ProSim737
Signature3.png

Share this post


Link to post
Guest
12 hours ago, Shylock_35 said:

Any word on the donkey and cart??? 

They've put the cart before the donkey but if you install Donkey Professional v 4.9.5.1.2 Beta 5, it works provided that you disable your antivirus and update to the latest Nvidia drivers.

Share this post


Link to post

My biggest issue with 4.4 was the loading time at the 6% mark and I hoped for improvements with 4.5. And wow, LM nailed it! The loading times at the 6% mark for the ORBX CityScene sceneries are now neglectable (running on a Samsung EVO860 SSD). Barcelona loads only 20seconds and Gold Coast some 8 seconds at 6%.

I cannot see any big FPS change (neither negative nor positive), but night lighting looks better. All in all, I am very happy and the 6% fix alone made it worth for me to update. Other than the ORBX stuff, my installation uses the add-on.xml method. This makes upgrading easy and I always do a vanilla new install of the whole sim (including settings and shaders). On my setup, the sim runs best without any P3D.cfg tweaks and I am not concerned about any lost settings when updating. The only file I always keep is my controls configuration, but everything else is handled by the add-on.xml and FTX Central.

  • Like 3

Best,
Christoph

Display resolution: 1920x1080 (8xSSAA)    GPU: 1080TI     CPU: i7-7700K (5.0 OC)    RAM: 16GB     SSD: Samsung 850Evo     Monitor: 27K

FSBetaTesters3.png

Share this post


Link to post

what about terrain and texture loading in square patches? has it been resolved?

  • Like 1

Ramon De Valencia

Intel i7 9700k @ 5.0Ghz / Windows 10 Professional 64 bit / 16GB DDR4 3200MHz CL14 RAM / EVGA NVIDIA GTX 1080TI 11GB RAM / 256MB SSD (OS Drive) / 500MB M.2 EVO (sim) / 750watt PSU

Share this post


Link to post
36 minutes ago, JoeFackel said:

You fu**ed it up. Maybe you didn't delete the shader cache or something like that. If troubles arise it's better to rename prepared3d.cfg and let rebuild it.

lol

Share this post


Link to post
Quote

After disabling sheds, greenhouses and lighthouses in the TE NLD control panel my loading times improved significantly as a matter of fact loading times of other intensive ORBX scenery such as Orlando and Gold Coast loading times were dramatically improved.

Yes, but then you do not see sheds, greenhouses and lighthouses in the Netherlands scenery. Not exactly a solution.

For the record, I have never suffered from excessively long loading times in P3D v4, but then I disable those scenery areas that I am not going to use, and I also have all of those 3DM files disabled in ORBx TrueEarth GB South.

  • Upvote 1

Christopher Low

UK2000 Beta Tester

FSBetaTesters3.png

Share this post


Link to post
6 minutes ago, georgiosgiannoukos said:

 Casv  is it Reload Shaders or Reload user objects you mean, in Options, key assigments?

Geo

Reload Shaders it is.

Share this post


Link to post
23 minutes ago, Wolkenschreck said:

My biggest issue with 4.4 was the loading time at the 6% mark and I hoped for improvements with 4.5. And wow, LM nailed it!

While it’s good to hear that this somewhat irksome issue has, to a large extent, been resolved one has to ask why it has taken so long to confront this issue? Doubtless other priorities have taken precedent.

Loading delay times at the 6% mark seemed to be directly proportional to the number and complexity of active scenery areas. If you restricted active areas by disabling those considered to be irrelevant for a particular flight then the 6% issue was no longer significant. Compare loading times of any flight scenario from a virgin installation against one that has numerous scenery additions and the problem is clearly exposed. 

It would seem, therefore, that the code has been changed in some way to make these pre-flight manipulations of active sceneries unnecessary, and Prepar3D is no longer scanning/loading data from scenery covering areas far remote from your current intended flight situation. If this is the case then it must be welcomed. I assume that there will also be enhanced mechanisms to deal with the loading and unloading of scenery during any particular flight.

Haven’t updated as yet so unable to confirm.

Mike

  • Upvote 1

My rig: ASUS ROG Rampage V Extreme, i7-5960X (Dynamic OC 4.6 GHz - all cores, HT=ON, AM=21845), Corsair H110i GT Cooler, G.SKILL Ripjaws 4 16GB (4 x 4GB) DDR4 3000, ASUS GTX 1080Ti ROG STRIX 11GB, (Drivers: 441.66 (Win7), 472.12 (Win10)), Samsung 850 EVO 1TB SSD x4, Samsung 970 EVO 2TB V-NAND M.2, EVGA 1200 P2 Watt PSU, Cooler Master HAF X, ASUS PG278Q (G-Sync) at 120Hz. Oculus Rift. Dual Boot: Windows 10 Pro 64bit (2004) / Prepar3D v5.1.12.26829, Windows 7 Pro 64bit / Prepar3D v4.5.12.30293.

Share this post


Link to post

I updated my P3D without problems and many addons work without updating (I had to update PTA and Active Sky). For me, it is one of the best updates I have seen in Prepar3D!

 

2019-4-10-14-31-57-820.jpg

2019-4-10-14-29-41-174.jpg

 

And loading times are much faster!

  • Like 5
  • Upvote 1

I7-10700 (4.8 GHz with HT enabled)

2x8 DDR4 

Gigabyte RTX 2070 Super OC Gaming

Share this post


Link to post

Any improvement in performance?  I got a small bump in some of the recent releases and am wondering if that's the case for 4.5

Share this post


Link to post
9 hours ago, daelight said:

Same trouble, rebooted the PC. All good after that.

Thanks daelight, tried that too, didn't work. Today is a new day........


ROG MAXIMUS X HERO, Intel Core i7 8700K, 32 GB's 3200 RAM, Gigabyte RTX3080,

Share this post


Link to post

i'm good with all the stuff and addons and visual quality and loading times ( Fresh install of the whole sim with deleting all the folders in Roaming and local and Pdata folder ). everything new, but I have one little issue, wether My FPS limiter inside the sim is set to unlimited, limited, Vsync off or on, Nvidia Setting on - off ... Almost evey possible single setting that I have tried from all defaults to changing them one by one to removing and reinstalling my Nvidia Driver using DDU in Safe mode, removing Any hardware monitoring apps, and cleaning winreg from their footprints.... However, My FPS is locked at 30FPS ... I know some scenes that my system is able to maintain 150-180 FPS on the default installation, there I'm getting 30FPS ... I know a place in my sim where on the most demanding situation I used to maintain 40-45 FPS , again stuck at 30FPS :|. anyone with any idea ?

Best Regards.


Saman Mahdi Abadi 
there is absolute logic in pure illogic ! S.M.A
B1.1 Mechanic

1hxz6d.png

Share this post


Link to post
8 minutes ago, Samany69 said:

i'm good with all the stuff and addons and visual quality and loading times ( Fresh install of the whole sim with deleting all the folders in Roaming and local and Pdata folder ). everything new, but I have one little issue, wether My FPS limiter inside the sim is set to unlimited, limited, Vsync off or on, Nvidia Setting on - off ... Almost evey possible single setting that I have tried from all defaults to changing them one by one to removing and reinstalling my Nvidia Driver using DDU in Safe mode, removing Any hardware monitoring apps, and cleaning winreg from their footprints.... However, My FPS is locked at 30FPS ... I know some scenes that my system is able to maintain 150-180 FPS on the default installation, there I'm getting 30FPS ... I know a place in my sim where on the most demanding situation I used to maintain 40-45 FPS , again stuck at 30FPS :|. anyone with any idea ?

Best Regards.

Assuming you're using Windows 10, did you turn off the 'Game Bar'? I've heard that has been the cause of a few mysterious FPS locks in various games.


8700K Delid @ 5GHz | G.Skill 32GB DDR4 @ 3600MHz | MSI 1080 Ti Sea Hawk X | Windows 10 Pro (2004) | Monitors: LG 27UK650 / Acer XB270HU

Share this post


Link to post
1 hour ago, Samany69 said:

i'm good with all the stuff and addons and visual quality and loading times ( Fresh install of the whole sim with deleting all the folders in Roaming and local and Pdata folder ). everything new, but I have one little issue, wether My FPS limiter inside the sim is set to unlimited, limited, Vsync off or on, Nvidia Setting on - off ... Almost evey possible single setting that I have tried from all defaults to changing them one by one to removing and reinstalling my Nvidia Driver using DDU in Safe mode, removing Any hardware monitoring apps, and cleaning winreg from their footprints.... However, My FPS is locked at 30FPS ... I know some scenes that my system is able to maintain 150-180 FPS on the default installation, there I'm getting 30FPS ... I know a place in my sim where on the most demanding situation I used to maintain 40-45 FPS , again stuck at 30FPS :|. anyone with any idea ?

Best Regards.

I don’t mean to hijack this post but honestly you shouldn’t run frames that high anyways. Sync your frames to your monitors refresh rate. If it’s 60hz then your frames should be locked at 60fps. That provides up with the best performance. But if your monitor is at 144hz then I guess you can still lock your frames that high but anytime the frames dip below that magic number you’ll get annoying stutters. 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    53%
    $13,405.00 of $25,000.00 Donate Now
×
×
  • Create New...